summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsoloturn2023-10-30 07:43:22 +0100
committersoloturn2023-10-30 07:43:22 +0100
commitf4b96c00ca823575e914cf04069bea7df1e5f8cb (patch)
tree6df285c11e2a38a8d6b28cd64a628e79840075ab
parent18031d729182f1091c85a030b0fdf0a1eefbed6a (diff)
downloadaur-f4b96c00ca823575e914cf04069bea7df1e5f8cb.tar.gz
remove stdint patch, rename cmark, llvm-project
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD9
3 files changed, 6 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1056c1f1f751..aeabcba95868 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = swift-language-git
pkgdesc = The Swift programming language, taken directly from the Apple repository
- pkgver = swift.DEVELOPMENT.SNAPSHOT.2023.10.07.a.r27.g254450981
+ pkgver = swift.DEVELOPMENT.SNAPSHOT.2023.10.28.a.r20.g7db7b21c8
pkgrel = 1
url = https://swift.org/
arch = x86_64
@@ -41,7 +41,6 @@ pkgbase = swift-language-git
source = apple-llvm-project::git+https://github.com/apple/llvm-project#branch=stable/20220421
source = swift-llvm-bindings::git+https://github.com/apple/swift-llvm-bindings#branch=stable/20220421
source = 0001-arch-aur-patches.patch
- source = 0002-stdint.patch
source = indexstore-db::git+https://github.com/apple/indexstore-db#branch=main
source = yams::git+https://github.com/jpsim/Yams#commit=5.0.1
source = sourcekit-lsp::git+https://github.com/apple/sourcekit-lsp#branch=main
@@ -99,6 +98,5 @@ pkgbase = swift-language-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
- md5sums = SKIP
pkgname = swift-language-git
diff --git a/.gitignore b/.gitignore
index fa93102d9bec..624894e980ff 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,10 +2,10 @@
/pkg/
*.tar.xz*
*.tar.gz*
-/cmark/
+/apple-cmark/
/indexstore-db/
/llbuild/
-/llvm-project/
+/apple-llvm-project/
/sourcekit-lsp/
/swift-asn1/
/swift-argument-parser/
diff --git a/PKGBUILD b/PKGBUILD
index 10db2f87b2b2..c9975f997951 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Andrew Sun <adsun701@gmail.com>
pkgname=swift-language-git
-pkgver=swift.DEVELOPMENT.SNAPSHOT.2023.10.07.a.r27.g254450981
+pkgver=swift.DEVELOPMENT.SNAPSHOT.2023.10.28.a.r20.g7db7b21c8
pkgrel=1
pkgdesc="The Swift programming language, taken directly from the Apple repository"
arch=('x86_64')
@@ -35,7 +35,6 @@ source=(
'apple-llvm-project::git+https://github.com/apple/llvm-project#branch=stable/20220421'
'swift-llvm-bindings::git+https://github.com/apple/swift-llvm-bindings#branch=stable/20220421'
'0001-arch-aur-patches.patch'
- '0002-stdint.patch'
'indexstore-db::git+https://github.com/apple/indexstore-db#branch=main'
'yams::git+https://github.com/jpsim/Yams#commit=5.0.1'
'sourcekit-lsp::git+https://github.com/apple/sourcekit-lsp#branch=main'
@@ -96,7 +95,6 @@ md5sums=(
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
)
@@ -109,7 +107,6 @@ options=(!strip)
prepare () {
( cd swift && patch -p1 -i "$srcdir/0001-arch-aur-patches.patch" )
- ( cd llvm-project && patch -p1 -i "$srcdir/0002-stdint.patch" )
}
pkgver() {
@@ -121,8 +118,8 @@ build() {
cd "$srcdir"
# Fix /usr/include error
find "$srcdir/swift/stdlib/public/SwiftShims" -type f -print0 | xargs -0 sed -i 's|/usr/include/x86_64-linux-gnu|/usr/include|g'
- find "$srcdir/llvm-project/clang" -type f -print0 | xargs -0 sed -i 's|/usr/include/x86_64-linux-gnu|/usr/include|g'
- find "$srcdir/llvm-project/clang-tools-extra" -type f -print0 | xargs -0 sed -i 's|/usr/include/x86_64-linux-gnu|/usr/include|g'
+ find "$srcdir/apple-llvm-project/clang" -type f -print0 | xargs -0 sed -i 's|/usr/include/x86_64-linux-gnu|/usr/include|g'
+ find "$srcdir/apple-llvm-project/clang-tools-extra" -type f -print0 | xargs -0 sed -i 's|/usr/include/x86_64-linux-gnu|/usr/include|g'
# By default in /etc/makepkg.conf this is "-D_FORTIFY_SOURCE=2"
# Which will break `compiler-rt`