summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFranco Masotti2017-03-09 15:20:14 +0100
committerFranco Masotti2017-03-09 15:20:14 +0100
commitb14a4620b8de1fda8b1a8e682a582f77d53ed782 (patch)
tree5654314f82f477977deef44a87026d1df5373824
parent278bf947e7a08220bdadc69206f9ea10db34439c (diff)
downloadaur-swish-cplint-bin.tar.gz
Updated to new version.
-rw-r--r--.SRCINFO11
-rw-r--r--.install4
-rw-r--r--PKGBUILD13
-rwxr-xr-xrun.sh4
4 files changed, 19 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 529f487a0e5f..7c24c9c59be3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = swish-cplint-bin
pkgdesc = SWI-Prolog for SHaring: a SWI-Prolog web IDE integrated with the cplint suite - precompiled version
- pkgver = r1789.2563692
+ pkgver = r1849.519a5ac
pkgrel = 1
url = https://github.com/friguzzi/swish
install = .install
@@ -10,12 +10,15 @@ pkgbase = swish-cplint-bin
makedepends = sed
makedepends = unzip
makedepends = curl
- depends = libxinerama
- depends = libxpm
+ depends = bash
+ depends = coreutils
+ depends = gawk
depends = git
depends = graphviz
- depends = swi-prolog-devel
+ depends = libxinerama
+ depends = libxpm
depends = rserve-sandbox-docker-bin
+ depends = swi-prolog-devel
conflicts = swish
conflicts = swish-cplint
source = git+https://github.com/friguzzi/swish#branch=master
diff --git a/.install b/.install
index c4aeefd3c07c..6902e56bc66e 100644
--- a/.install
+++ b/.install
@@ -1,8 +1,8 @@
post_install() {
# Add swish user and group with a home directory (which will contain all
# the packs).
- getent group swish &>/dev/null || groupadd -r swish >/dev/null
- getent passwd swish &>/dev/null || useradd -m -d /home/swish \
+ getent group swish 1>/dev/null 2>/dev/null || groupadd -r swish >/dev/null
+ getent passwd swish 1>/dev/null 2>/dev/null || useradd -m -d /home/swish \
-r -g swish swish >/dev/null
# Add swish user to the rserve group. If this is not done, access to the
diff --git a/PKGBUILD b/PKGBUILD
index 79ae28318d8f..e3ee841903bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,21 @@
# Maintainer: Franco Masotti <franco dot masotti at student dot unife dot it>
# Contributor: Franco Masotti <franco dot masotti at student dot unife dot it>
pkgname=swish-cplint-bin
-pkgver=r1789.2563692
+pkgver=r1849.519a5ac
pkgrel=1
pkgdesc="SWI-Prolog for SHaring: a SWI-Prolog web IDE integrated with the cplint suite - precompiled version"
arch=('x86_64')
url="https://github.com/friguzzi/swish"
license=('BSD')
-depends=('libxinerama'
- 'libxpm'
+depends=('bash'
+ 'coreutils'
+ 'gawk'
'git'
'graphviz'
- 'swi-prolog-devel'
- 'rserve-sandbox-docker-bin')
+ 'libxinerama'
+ 'libxpm'
+ 'rserve-sandbox-docker-bin'
+ 'swi-prolog-devel')
makedepends=('git'
'sed'
'unzip'
diff --git a/run.sh b/run.sh
index 359f1e31d970..9bfaafe3d4e8 100755
--- a/run.sh
+++ b/run.sh
@@ -1,4 +1,4 @@
-#!/usr/bin/env sh
+#!/usr/bin/env bash
#
# run.sh
@@ -81,7 +81,7 @@ killd()
# kill action only if process exists.
if [ -f "$pid_file" ]; then
pid=$(cat "$pid_file")
- ps -q $pid > /dev/null
+ ps -p $pid > /dev/null
if [ $? -eq 0 ]; then
kill -s TERM $pid
fi