summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorktamp2017-05-14 18:56:59 +0300
committerktamp2017-05-14 18:56:59 +0300
commit4cc7f9789d35c7b547074b4392c4a45b2d0826f4 (patch)
treeb2bb9dfe73d25d64f852426bdd9a10c2f60e13eb
downloadaur-sword25.tar.gz
Add package
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
-rw-r--r--sword25.sh3
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4e2e8751165c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = sword25
+ pkgdesc = "Broken Sword 2.5: The Return of the Templars" is a graphical point-and-click adventure game
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://www.brokensword25.com/
+ arch = any
+ license = custom
+ depends = scummvm
+ source = http://downloads.sourceforge.net/scummvm/sword25-v1.0.zip
+ source = sword25.sh
+ md5sums = cd1957e836e66279ad4b7ba799f022a9
+ md5sums = a4d9d1d1e11ee27ecf4642685af6447b
+
+pkgname = sword25
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c176202fc8f9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: ktamp <ktamp@chem.uoa.gr>
+
+pkgname=sword25
+pkgver=1.0
+pkgrel=1
+pkgdesc='"Broken Sword 2.5: The Return of the Templars" is a graphical point-and-click adventure game'
+arch=('any')
+url="http://www.brokensword25.com/"
+license=('custom')
+depends=('scummvm')
+source=("http://downloads.sourceforge.net/scummvm/$pkgname-v$pkgver.zip"
+ "$pkgname.sh")
+md5sums=('cd1957e836e66279ad4b7ba799f022a9'
+ 'a4d9d1d1e11ee27ecf4642685af6447b')
+
+package() {
+ #Install documentation
+ install -D -m644 $srcdir/README $pkgdir/usr/share/doc/$pkgname/README
+
+ #Install licenses
+ install -d $pkgdir/usr/share/licenses/$pkgname
+ install -m644 $srcdir/license-* $pkgdir/usr/share/licenses/$pkgname/
+
+ #Install binaries
+ install -D -m644 $srcdir/data.b25c $pkgdir/usr/share/$pkgname/data.b25c
+ install -D -m755 $pkgname.sh $pkgdir/usr/bin/$pkgname
+}
diff --git a/sword25.sh b/sword25.sh
new file mode 100644
index 000000000000..86760903b164
--- /dev/null
+++ b/sword25.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec /usr/bin/scummvm "$@" -f -p /usr/share/sword25 sword25