summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLiao Junxuan2023-10-18 18:30:52 +0800
committerLiao Junxuan2023-10-18 18:30:52 +0800
commit1e32d9ee3ffcf5ef85209694bade2b3a5837c2fd (patch)
treebf540a4db1efc367eeaa3e9487439f2e6bf46939
downloadaur-sxmo-dmenu.tar.gz
add sxmo-dmenu
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD51
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3402f9e1580e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = sxmo-dmenu
+ pkgdesc = Dmenu for sxmo - works via using volume/power keys for seletion along with some other patches
+ pkgver = 5.0.14
+ pkgrel = 1
+ url = https://git.sr.ht/~mil/sxmo-dmenu
+ arch = x86_64
+ license = MIT
+ depends = glibc
+ depends = libfontconfig.so
+ depends = libxft
+ depends = bash
+ depends = libxinerama
+ depends = libx11
+ provides = dmenu
+ conflicts = dmenu
+ source = sxmo-dmenu-5.0.14::https://git.sr.ht/~mil/sxmo-dmenu/archive/5.0.14.tar.gz
+ sha256sums = bbd6877b73db93b95f8bf15c33d5137a9a675ea335bf916d9318b84686284cea
+
+pkgname = sxmo-dmenu
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48b6d94564f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Junxuan Liao <mikeljx at 126 dot com>
+# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: T.J. Townsend <blakkheim@archlinux.org>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Thorsten Töpper <atsutane-tu@freethoughts.de>
+# Contributor: Thayer Williams <thayer@archlinux.org>
+# Contributor: Jeff 'codemac' Mickey <jeff@archlinux.org>
+
+pkgname=sxmo-dmenu
+pkgver=5.0.14
+pkgrel=1
+pkgdesc="Dmenu for sxmo - works via using volume/power keys for seletion along with some other patches"
+arch=('x86_64')
+provides=('dmenu')
+conflicts=('dmenu')
+url="https://git.sr.ht/~mil/sxmo-dmenu"
+license=('MIT')
+source=("${pkgname}-${pkgver}::$url/archive/$pkgver.tar.gz")
+sha256sums=('bbd6877b73db93b95f8bf15c33d5137a9a675ea335bf916d9318b84686284cea')
+depends=(
+ 'glibc'
+ 'libfontconfig.so'
+ 'libxft'
+ 'bash'
+ 'libxinerama'
+ 'libx11'
+)
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ echo "CPPFLAGS+=${CPPFLAGS}" >> config.mk
+ echo "CFLAGS+=${CFLAGS}" >> config.mk
+ echo "LDFLAGS+=${LDFLAGS}" >> config.mk
+}
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ make \
+ X11INC=/usr/include/X11 \
+ X11LIB=/usr/lib/X11 \
+ FREETYPEINC=/usr/include/freetype2
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make PREFIX=/usr DESTDIR="${pkgdir}" install
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ cd ${pkgdir}/usr/bin
+}
+