summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2015-06-13 00:00:49 -0400
committerKyle Keen2015-06-13 00:00:49 -0400
commitf8cc6b77ff1ca4831dcdfe0ab79701b38ea61a4d (patch)
treedf9c048d699be3bc4128b440e5b04edcf093700a
downloadaur-synaesthesia.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1cc7ff6388e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = synaesthesia
+ pkgdesc = Represents music graphically as coruscating field of fog and glowing lines
+ pkgver = 2.4
+ pkgrel = 1
+ url = http://www.logarithmic.net/pfh/Synaesthesia
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = sdl
+ depends = libsm
+ optdepends = esound: For line input.
+ source = http://www.logarithmic.net/pfh-files/synaesthesia/synaesthesia-2.4.tar.gz
+ md5sums = 784105cbeed3ab209231675f0e029497
+
+pkgname = synaesthesia
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..08a467edab24
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Kyle Keen <keenerd@gmail.com>
+# Maintainer: eric <eric@archlinux.org>
+# Contributor: Damir Perisa <damir.perisa@bluewin.ch>
+
+pkgname=synaesthesia
+pkgver=2.4
+pkgrel=1
+pkgdesc="Represents music graphically as coruscating field of fog and glowing lines"
+arch=('i686' 'x86_64')
+url="http://www.logarithmic.net/pfh/Synaesthesia"
+license=('GPL')
+depends=('sdl' 'libsm')
+optdepends=('esound: For line input.')
+source=(http://www.logarithmic.net/pfh-files/$pkgname/$pkgname-$pkgver.tar.gz)
+md5sums=('784105cbeed3ab209231675f0e029497')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make prefix="$pkgdir/usr" install
+}