summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Kröning2018-02-07 14:51:44 +0100
committerMartin Kröning2018-02-07 14:51:44 +0100
commit2227d1fa267781fd8e267aeb4f8e4e1d9c15b5d7 (patch)
treee05125825028a029a371d4a961ac5d67dedb22c2
parentc7297dd31760576b577b18efcead35909ccce9bf (diff)
downloadaur-2227d1fa267781fd8e267aeb4f8e4e1d9c15b5d7.tar.gz
Adapt to Appimage, update to 2.3.0
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD56
-rw-r--r--sync-my-l2p.desktop.diff13
-rw-r--r--sync-my-l2p.install11
5 files changed, 59 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2d18741962e9..3131c5724d71 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
-# Generated by mksrcinfo v8
-# Sat Jan 16 00:15:31 UTC 2016
pkgbase = sync-my-l2p
- pkgdesc = Sync the L2P of the RWTH Aachen with your Computer
- pkgver = 2.2.0
+ pkgdesc = Sync the L2P of RWTH Aachen University
+ pkgver = 2.3.0
pkgrel = 1
- url = http://www.sync-my-l2p.de/
- install = sync-my-l2p.install
- arch = i686
+ url = https://github.com/RobertKrajewski/Sync-my-L2P
arch = x86_64
- license = GPL
- makedepends = deb2targz
+ license = LGPL3
depends = qt5-base
depends = hicolor-icon-theme
- noextract = sync-my-l2p_2.2.0-0.vivid1_i386.deb
- source = https://github.com/Sync-my-L2P/Sync-my-L2P/releases/download/v2.2.0/sync-my-l2p_2.2.0-0.wily_i386.deb
- md5sums = e07689028a428d8540a41a3a8abc4763
+ noextract = SyncMyL2P-$pkgver-linux.AppImage
+ noextract = sync-my-l2p.desktop.diff
+ options = !strip
+ source = https://github.com/RobertKrajewski/Sync-my-L2P/releases/download/v2.3.0/SyncMyL2P-2.3.0-linux.AppImage
+ source = sync-my-l2p.desktop.diff
+ sha256sums = b1fb5fb354864a59be09837e4d44c6e213ec61fa41b0e6df4c3a7229fbccfd1a
+ sha256sums = 9fa15afce0c4c367341935f2ff1731b9cbac0e0a32df931356a15a3711f4a82d
pkgname = sync-my-l2p
diff --git a/.gitignore b/.gitignore
index c00df136d167..8ade2b4bb14b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,4 @@
-*.deb
+pkg/
+src/
+*.AppImage
+*.pkg.tar*
diff --git a/PKGBUILD b/PKGBUILD
index 212122f58958..2e62b2c82ab6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,40 @@
-# Maintainer: Jan-Erik Rediger <badboy at archlinux dot us>
-
+# Maintainer: Martin Kröning <m dot kroening at hotmail dot germantld>
+# Contributor: Jan-Erik Rediger <badboy at archlinux dot us>
pkgname=sync-my-l2p
-pkgver=2.2.0
+pkgver=2.3.0
pkgrel=1
-pkgdesc="Sync the L2P of the RWTH Aachen with your Computer"
-arch=('i686' 'x86_64')
-url="http://www.sync-my-l2p.de/"
-license=('GPL')
+pkgdesc="Sync the L2P of RWTH Aachen University"
+arch=('x86_64')
+url="https://github.com/RobertKrajewski/Sync-my-L2P"
+license=('LGPL3')
depends=('qt5-base' 'hicolor-icon-theme')
-makedepends=('deb2targz')
-install=sync-my-l2p.install
-
-if [ "$CARCH" = "x86_64" ]; then
- source=("https://github.com/Sync-my-L2P/Sync-my-L2P/releases/download/v${pkgver}/sync-my-l2p_${pkgver}-0.wily_amd64.deb")
- noextract=("sync-my-l2p_${pkgver}-0.vivid1_amd64.deb")
- md5sums=('9bd94c8b20e1405977980cadc3633ab1')
- _short_arch=amd64
-else
- source=("https://github.com/Sync-my-L2P/Sync-my-L2P/releases/download/v${pkgver}/sync-my-l2p_${pkgver}-0.wily_i386.deb")
- noextract=("sync-my-l2p_${pkgver}-0.vivid1_i386.deb")
- md5sums=('e07689028a428d8540a41a3a8abc4763')
- _short_arch=i386
-fi
+options=('!strip')
+source=("$url/releases/download/v$pkgver/SyncMyL2P-$pkgver-linux.AppImage"
+'sync-my-l2p.desktop.diff')
+noextract=('SyncMyL2P-$pkgver-linux.AppImage'
+'sync-my-l2p.desktop.diff')
+sha256sums=('b1fb5fb354864a59be09837e4d44c6e213ec61fa41b0e6df4c3a7229fbccfd1a'
+ '9fa15afce0c4c367341935f2ff1731b9cbac0e0a32df931356a15a3711f4a82d')
prepare() {
- deb2targz sync-my-l2p_${pkgver}-0.wily_${_short_arch}.deb
+ # Extract Appimage
+ chmod +x SyncMyL2P-$pkgver-linux.AppImage
+ ./SyncMyL2P-$pkgver-linux.AppImage --appimage-extract &> /dev/null
+
+ # Patch desktop file
+ patch squashfs-root/Sync-my-L2P.desktop sync-my-l2p.desktop.diff > /dev/null
}
package() {
- tar -C $pkgdir -xf sync-my-l2p_${pkgver}-0.wily_${_short_arch}.tar.xz
-}
+ # Install desktop file
+ install -Dm755 squashfs-root/Sync-my-L2P.desktop "$pkgdir"/usr/share/applications/sync-my-l2p.desktop
-# vim:set ts=2 sw=2 sts=2 et:
+ # Install icons
+ for size in 16 32 48 128; do
+ install -Dm755 squashfs-root/hicolor/${size}x${size}/apps/sync-my-L2P.png \
+ "$pkgdir"/usr/share/icons/hicolor/${size}x${size}/apps/sync-my-l2p.png
+ done
+
+ # Install bin
+ install -Dm755 squashfs-root/usr/bin/Sync-my-L2P "$pkgdir"/usr/bin/sync-my-l2p
+}
diff --git a/sync-my-l2p.desktop.diff b/sync-my-l2p.desktop.diff
new file mode 100644
index 000000000000..392aa6c76f34
--- /dev/null
+++ b/sync-my-l2p.desktop.diff
@@ -0,0 +1,13 @@
+--- Sync-my-L2P.desktop.orig 2018-02-07 10:43:25.590546451 +0100
++++ Sync-my-L2P.desktop.new 2018-02-07 11:11:49.414476580 +0100
+@@ -2,8 +2,8 @@
+ Name=Sync-my-L2P
+ Comment=Sync-my-L2P — L2P synchronisation tool
+ Comment[de]=Sync-my-L2P – Synchronsiert deine Dokumente aus dem L2P mit deinem Rechner
+-Exec=Sync-my-L2P
+-Icon=sync-my-L2P
++Exec=sync-my-l2p
++Icon=sync-my-l2p
+ Terminal=false
+ Type=Application
+ Categories=Qt;FileTransfer;Network;
diff --git a/sync-my-l2p.install b/sync-my-l2p.install
deleted file mode 100644
index 4852f04d4922..000000000000
--- a/sync-my-l2p.install
+++ /dev/null
@@ -1,11 +0,0 @@
-post_install() {
- gtk-update-icon-cache -f -q -t /usr/share/icons/hicolor
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}