summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-05 17:26:06 +0100
committerBartłomiej Piotrowski2018-01-05 17:26:06 +0100
commite7b1c8926314faa2f35098a862df803f796126ff (patch)
treea22969c348c6d8af2ba6fbffe5345b87053e4e0e
downloadaur-synce-sync-engine.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD26
-rw-r--r--synce-sync-engine.install18
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..52aa0225cce5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = synce-sync-engine
+ pkgdesc = SynCE sync-engine
+ pkgver = 0.16
+ pkgrel = 3
+ url = http://www.synce.org/
+ install = synce-sync-engine.install
+ arch = any
+ license = GPL
+ makedepends = python2-setuptools
+ depends = synce-core
+ depends = synce-rra
+ depends = librtfcomp
+ depends = python2-dbus
+ depends = python2-gobject2
+ depends = python2-lxml
+ source = http://downloads.sourceforge.net/synce/synce-sync-engine-0.16.tar.gz
+ md5sums = 92a9b81cba6c820f2639c50d79b6fd0d
+
+pkgname = synce-sync-engine
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..416f6a22a86d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id: PKGBUILD 273597 2017-12-10 16:17:07Z heftig $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Bartek Iwaniec <hash87 [at] gmail [dot] com>
+
+pkgname=synce-sync-engine
+pkgver=0.16
+pkgrel=3
+pkgdesc="SynCE sync-engine"
+arch=(any)
+license=('GPL')
+url="http://www.synce.org/"
+depends=(synce-core synce-rra librtfcomp python2-dbus python2-gobject2 python2-lxml)
+makedepends=(python2-setuptools)
+install=${pkgname}.install
+source=(http://downloads.sourceforge.net/synce/${pkgname}-${pkgver}.tar.gz)
+md5sums=('92a9b81cba6c820f2639c50d79b6fd0d')
+
+build() {
+ cd "$srcdir"/${pkgname}-${pkgver}
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir"/${pkgname}-${pkgver}
+ python2 setup.py install --root="$pkgdir"
+}
diff --git a/synce-sync-engine.install b/synce-sync-engine.install
new file mode 100644
index 000000000000..f1e89914cd56
--- /dev/null
+++ b/synce-sync-engine.install
@@ -0,0 +1,18 @@
+post_install() {
+echo
+echo "Before you start sync-engine, it is necessary to copy the basic configuration file to your home directory. "
+echo "If you would like to sync files, you need to edit the file as well."
+echo
+echo "mkdir -p ~/.synce"
+echo "cp /usr/share/doc/sync-engine/syncengine.conf.xml ~/.synce"
+echo
+echo "More info can be found at"
+echo "http://www.synce.org/oldwiki/index.php/SyncEngine#sync-engine"
+echo "http://wiki.archlinux.org/index.php/Sync_and_connect_with_windows_mobile"
+echo
+}
+
+post_upgrade() {
+ post_install
+}
+