summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustus Piater2016-10-03 18:08:01 +0900
committerJustus Piater2016-11-10 23:15:09 +0100
commit82af59105efe881d88196f46c05a076fee4fb3ed (patch)
tree5ba0b8377b961c6b7099a5317ec239de0db8827f
parentfc99c1bc7100fb0ee8280f070abe16a37eee9476 (diff)
downloadaur-82af59105efe881d88196f46c05a076fee4fb3ed.tar.gz
changes for version slated to become 1.5.2
dropped casts and libical2 patches
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD17
-rw-r--r--syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa-python2.patch75
-rw-r--r--syncevolution-1.5.1-casts.patch24
-rw-r--r--syncevolution-1.5.1-libical2.patch12
-rw-r--r--syncevolution-1.5.1-python2.patch39
6 files changed, 87 insertions, 95 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a21d346f2e13..d355242c0a4d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = syncevolution
pkgdesc = Synchronize PIM data via various protocols
- pkgver = 1.5.1
+ pkgver = 1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa
pkgrel = 1
url = https://syncevolution.org/
arch = i686
@@ -9,18 +9,15 @@ pkgbase = syncevolution
makedepends = intltool
makedepends = boost
depends = evolution-data-server
+ depends = libgnome-keyring
depends = neon
depends = openobex
depends = python2
depends = libunique
- source = https://download.01.org/syncevolution/syncevolution/sources/syncevolution-1.5.1.tar.gz
- source = syncevolution-1.5.1-casts.patch
- source = syncevolution-1.5.1-libical2.patch
- source = syncevolution-1.5.1-python2.patch
- sha256sums = 39f52049006c4a703bfe4b7cea3bb3298fe61b4ba9a8dbc367492409e4091c70
- sha256sums = c72fcc0f06d7958fbef98ffd379ebc95407d7bd29924e6ba63507ba7f82fcac6
- sha256sums = e12fd70af74b2771c6a83a6f42cfd64a943e9e5d3db93624865b08476d4b8f2c
- sha256sums = 3ccb195d45de1c1ad87f76dfc5927997988afa7031feb9f335fab63d6a317910
+ source = http://downloads.syncevolution.org/syncevolution/sources/syncevolution-1.5.1%2B20160926%2BSE%2B8fccc44%2Bunclean%2BSYSYNC%2B59b55aa.tar.gz
+ source = syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa-python2.patch
+ sha256sums = 3563ebaf6b9a29c9a8baa6487554821480bcc6ff5b870af632a45ed92fe31d11
+ sha256sums = 8167ca6bb392ccb2f36093eef0e76d8c6cde5d43dcc595ad73af9af838ea14ce
pkgname = syncevolution
diff --git a/PKGBUILD b/PKGBUILD
index f41bed19ba88..21b7d60cacd6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,28 @@
# Maintainer: Justus Piater <Justus-dev at Piater dot name>
pkgname=('syncevolution' 'syncevolution-http')
-pkgver=1.5.1
+pkgver=1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa
pkgrel=1
pkgdesc="Synchronize PIM data via various protocols"
arch=('i686' 'x86_64')
url="https://syncevolution.org/"
license=('LGPL')
-depends=('evolution-data-server' 'neon' 'openobex' 'python2' 'libunique')
+depends=('evolution-data-server' 'libgnome-keyring' 'neon' 'openobex' 'python2' 'libunique')
makedepends=('intltool' 'boost')
#changelog=
-source=("https://download.01.org/syncevolution/syncevolution/sources/$pkgname-$pkgver.tar.gz"
- "$pkgname-$pkgver-casts.patch"
- "$pkgname-$pkgver-libical2.patch"
+source=("http://downloads.syncevolution.org/syncevolution/sources/syncevolution-1.5.1%2B20160926%2BSE%2B8fccc44%2Bunclean%2BSYSYNC%2B59b55aa.tar.gz"
"$pkgname-$pkgver-python2.patch")
-sha256sums=('39f52049006c4a703bfe4b7cea3bb3298fe61b4ba9a8dbc367492409e4091c70'
- 'c72fcc0f06d7958fbef98ffd379ebc95407d7bd29924e6ba63507ba7f82fcac6'
- 'e12fd70af74b2771c6a83a6f42cfd64a943e9e5d3db93624865b08476d4b8f2c'
- '3ccb195d45de1c1ad87f76dfc5927997988afa7031feb9f335fab63d6a317910')
+sha256sums=('3563ebaf6b9a29c9a8baa6487554821480bcc6ff5b870af632a45ed92fe31d11'
+ '8167ca6bb392ccb2f36093eef0e76d8c6cde5d43dcc595ad73af9af838ea14ce')
prepare() {
cd "$pkgname-$pkgver"
- for patch in casts libical2 python2; do
+ for patch in python2; do
patch -p1 -i "$srcdir/$pkgname-$pkgver-$patch.patch"
done
}
build() {
cd "$pkgname-$pkgver"
- export CXXFLAGS="$CXXFLAGS -std=gnu++98"
./configure --prefix=/usr \
--libexecdir=/usr/lib/syncevolution \
--sysconfdir=/etc \
diff --git a/syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa-python2.patch b/syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa-python2.patch
new file mode 100644
index 000000000000..f1570e704822
--- /dev/null
+++ b/syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa-python2.patch
@@ -0,0 +1,75 @@
+diff -aur syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa.pristine/build/source2html.py syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa.new/build/source2html.py
+--- syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa.pristine/build/source2html.py 2014-04-25 16:55:47.000000000 +0900
++++ syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa.new/build/source2html.py 2016-10-03 16:45:11.170737592 +0900
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/python2
+
+ """
+ Converts source code (first parameter, can be - for stdin) to HTML
+diff -aur syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa.pristine/Makefile.in syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa.new/Makefile.in
+--- syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa.pristine/Makefile.in 2016-09-26 20:20:42.000000000 +0900
++++ syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa.new/Makefile.in 2016-10-03 16:45:12.627421123 +0900
+@@ -12031,7 +12031,7 @@
+ fi; \
+ done
+ src/ClientTest.cpp.html: build/source2html.py test/ClientTest.cpp
+- $(AM_V_GEN)python $+ >$@
++ $(AM_V_GEN)python2 $+ >$@
+
+ # copy base test files
+ $(filter-out %.tem, $(filter src/testcases/%, $(subst $(top_srcdir)/test/,src/,$(CLIENT_LIB_TEST_FILES)))) : src/% : $(top_srcdir)/test/%
+diff -aur syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa.pristine/src/dbus/server/pim/examples/search.py syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa.new/src/dbus/server/pim/examples/search.py
+--- syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa.pristine/src/dbus/server/pim/examples/search.py 2014-10-31 01:54:09.000000000 +0900
++++ syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa.new/src/dbus/server/pim/examples/search.py 2016-10-03 16:45:09.797388364 +0900
+@@ -1,4 +1,4 @@
+-#! /usr/bin/python -u
++#! /usr/bin/python2 -u
+ # -*- coding: utf-8 -*-
+ # vim: set fileencoding=utf-8 :#
+ #
+diff -aur syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa.pristine/src/dbus/server/pim/examples/sync.py syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa.new/src/dbus/server/pim/examples/sync.py
+--- syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa.pristine/src/dbus/server/pim/examples/sync.py 2014-10-31 01:54:09.000000000 +0900
++++ syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa.new/src/dbus/server/pim/examples/sync.py 2016-10-03 16:45:08.950711900 +0900
+@@ -1,4 +1,4 @@
+-#! /usr/bin/python -u
++#! /usr/bin/python2 -u
+ # -*- coding: utf-8 -*-
+ # vim: set fileencoding=utf-8 :#
+ #
+diff -aur syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa.pristine/src/dbus/server/pim/testpim.py syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa.new/src/dbus/server/pim/testpim.py
+--- syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa.pristine/src/dbus/server/pim/testpim.py 2014-10-31 01:54:09.000000000 +0900
++++ syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa.new/src/dbus/server/pim/testpim.py 2016-10-03 16:45:07.450694546 +0900
+@@ -1,4 +1,4 @@
+-#! /usr/bin/python -u
++#! /usr/bin/python2 -u
+ # -*- coding: utf-8 -*-
+ # vim: set fileencoding=utf-8 :#
+ #
+diff -aur syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa.pristine/test/log2html.py syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa.new/test/log2html.py
+--- syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa.pristine/test/log2html.py 2014-04-25 16:55:47.000000000 +0900
++++ syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa.new/test/log2html.py 2016-10-03 16:45:03.740651639 +0900
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/python2
+
+ """
+ Converts the .log output for a client-test test into HTML, with
+diff -aur syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa.pristine/test/syncevo-http-server.py syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa.new/test/syncevo-http-server.py
+--- syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa.pristine/test/syncevo-http-server.py 2016-09-26 20:20:05.000000000 +0900
++++ syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa.new/test/syncevo-http-server.py 2016-10-03 16:45:02.883975069 +0900
+@@ -1,4 +1,4 @@
+-#! /usr/bin/python
++#! /usr/bin/python2
+
+ '''Usage: syncevo-http-server.py <URL>
+ Runs a SyncML HTTP server under the given base URL.'''
+diff -aur syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa.pristine/test/syncevo-phone-config.py syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa.new/test/syncevo-phone-config.py
+--- syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa.pristine/test/syncevo-phone-config.py 2014-04-25 16:55:48.000000000 +0900
++++ syncevolution-1.5.1+20160926+SE+8fccc44+unclean+SYSYNC+59b55aa.new/test/syncevo-phone-config.py 2016-10-03 16:45:02.223967440 +0900
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/python2
+ #
+ # Copyright (C) 2010 Intel Corporation
+ #
diff --git a/syncevolution-1.5.1-casts.patch b/syncevolution-1.5.1-casts.patch
deleted file mode 100644
index e99a5f3f5539..000000000000
--- a/syncevolution-1.5.1-casts.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -aur syncevolution-1.5.1.pristine/src/syncevo/Logging.h syncevolution-1.5.1.new/src/syncevo/Logging.h
---- syncevolution-1.5.1.pristine/src/syncevo/Logging.h 2014-04-25 09:55:47.000000000 +0200
-+++ syncevolution-1.5.1.new/src/syncevo/Logging.h 2016-06-18 14:27:00.536255709 +0200
-@@ -255,7 +255,7 @@
- Handle &operator = (const Handle &other) throw ();
- ~Handle() throw ();
-
-- operator bool () const { return m_logger; }
-+ operator bool () const { return (bool)m_logger; }
- bool operator == (Logger *logger) const { return m_logger.get() == logger; }
- Logger *get() const { return m_logger.get(); }
-
-diff -aur syncevolution-1.5.1.pristine/src/synthesis/src/sysync/itemfield.cpp syncevolution-1.5.1.new/src/synthesis/src/sysync/itemfield.cpp
---- syncevolution-1.5.1.pristine/src/synthesis/src/sysync/itemfield.cpp 2015-03-03 09:06:40.000000000 +0100
-+++ syncevolution-1.5.1.new/src/synthesis/src/sysync/itemfield.cpp 2016-06-18 11:59:31.504138508 +0200
-@@ -1488,7 +1488,7 @@
- " %c%02hd%02hd",
- moffs>=0 ? '+' : '-',
- (uInt16)(abs(moffs) / MinsPerHour),
-- (uInt16)(abs(moffs) % MinsPerHour)
-+ (uInt16)(abs((int)moffs) % MinsPerHour)
- );
- }
- } // TTimestampField::getAsRFC822date
diff --git a/syncevolution-1.5.1-libical2.patch b/syncevolution-1.5.1-libical2.patch
deleted file mode 100644
index f0d918c23510..000000000000
--- a/syncevolution-1.5.1-libical2.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -aur syncevolution-1.5.1.pristine/src/syncevo/icaltz-util.c syncevolution-1.5.1.new/src/syncevo/icaltz-util.c
---- syncevolution-1.5.1.pristine/src/syncevo/icaltz-util.c 2014-04-28 11:55:52.000000000 +0200
-+++ syncevolution-1.5.1.new/src/syncevo/icaltz-util.c 2016-06-18 11:43:50.107173288 +0200
-@@ -162,7 +162,7 @@
- } leap;
-
- #ifndef EVOLUTION_ICAL_COMPATIBILITY
--extern const char *ical_tzid_prefix;
-+const char *ical_tzid_prefix = "/freeassociation.sourceforge.net/";
- #endif
-
- static int
diff --git a/syncevolution-1.5.1-python2.patch b/syncevolution-1.5.1-python2.patch
deleted file mode 100644
index e4d982c8aedf..000000000000
--- a/syncevolution-1.5.1-python2.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-diff -aur syncevolution-1.5.1.pristine/Makefile.in syncevolution-1.5.1.new/Makefile.in
---- syncevolution-1.5.1.pristine/Makefile.in 2015-06-05 15:50:50.000000000 +0200
-+++ syncevolution-1.5.1.new/Makefile.in 2016-06-18 11:43:14.163743670 +0200
-@@ -11946,7 +11946,7 @@
- fi; \
- done
- src/ClientTest.cpp.html: build/source2html.py test/ClientTest.cpp
-- $(AM_V_GEN)python $+ >$@
-+ $(AM_V_GEN)python2 $+ >$@
-
- # copy base test files
- $(filter-out %.tem, $(filter src/testcases/%, $(subst $(top_srcdir)/test/,src/,$(CLIENT_LIB_TEST_FILES)))) : src/% : $(top_srcdir)/test/%
-diff -aur syncevolution-1.5.1.pristine/test/log2html.py syncevolution-1.5.1.new/test/log2html.py
---- syncevolution-1.5.1.pristine/test/log2html.py 2014-04-25 09:55:47.000000000 +0200
-+++ syncevolution-1.5.1.new/test/log2html.py 2016-06-18 12:43:42.570003467 +0200
-@@ -1,4 +1,4 @@
--#!/usr/bin/python
-+#!/usr/bin/python2
-
- """
- Converts the .log output for a client-test test into HTML, with
-diff -aur syncevolution-1.5.1.pristine/test/syncevo-http-server.py syncevolution-1.5.1.new/test/syncevo-http-server.py
---- syncevolution-1.5.1.pristine/test/syncevo-http-server.py 2015-06-05 15:50:15.000000000 +0200
-+++ syncevolution-1.5.1.new/test/syncevo-http-server.py 2016-06-18 12:54:34.426457910 +0200
-@@ -1,4 +1,4 @@
--#! /usr/bin/python
-+#! /usr/bin/python2
-
- '''Usage: syncevo-http-server.py <URL>
- Runs a SyncML HTTP server under the given base URL.'''
-diff -aur syncevolution-1.5.1.pristine/test/syncevo-phone-config.py syncevolution-1.5.1.new/test/syncevo-phone-config.py
---- syncevolution-1.5.1.pristine/test/syncevo-phone-config.py 2014-04-25 09:55:48.000000000 +0200
-+++ syncevolution-1.5.1.new/test/syncevo-phone-config.py 2016-06-18 12:39:53.882242126 +0200
-@@ -1,4 +1,4 @@
--#!/usr/bin/python
-+#!/usr/bin/python2
- #
- # Copyright (C) 2010 Intel Corporation
- #