summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustus Piater2018-03-31 15:43:02 +0200
committerJustus Piater2018-03-31 15:43:02 +0200
commitf65285e5a8cf402d9204e74890bc475de4d9f0f4 (patch)
treed1c990beddb9fd748c9fc8d59f8c276bdcccea63
parentb6313d1544015e99f71cb5be1446cada7df6fb41 (diff)
downloadaur-f65285e5a8cf402d9204e74890bc475de4d9f0f4.tar.gz
changes for version 1.5.3
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD16
-rw-r--r--syncevolution-1.5.2-libical3.patch125
-rw-r--r--syncevolution-1.5.2-python2.patch87
-rw-r--r--syncevolution-1.5.3-python2.patch87
-rw-r--r--syncevolution-1.5.3-sslcert.patch16
6 files changed, 119 insertions, 229 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bc39f0e9e28c..45f213b02977 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = syncevolution
pkgdesc = Synchronize PIM data via various protocols
- pkgver = 1.5.2
- pkgrel = 6
+ pkgver = 1.5.3
+ pkgrel = 1
url = https://syncevolution.org/
- arch = i686
arch = x86_64
license = LGPL
makedepends = intltool
@@ -15,12 +14,12 @@ pkgbase = syncevolution
depends = openobex
depends = python2
depends = libunique
- source = https://download.01.org/syncevolution/syncevolution/sources/syncevolution-1.5.2.tar.gz
- source = syncevolution-1.5.2-libical3.patch
- source = syncevolution-1.5.2-python2.patch
- sha256sums = 8b692bd549a63d2259ed7519afb74fc9cab5be10c7a6f51868b66fc98fb48128
- sha256sums = 36165fd651a2edc088dbf868214bace3d7f52f61dce051af4657ab1eafbe2ac9
- sha256sums = 88e5deab491e40e932e9d6d3240fd97ca68550800cc1ae22eba8679092e770df
+ source = https://download.01.org/syncevolution/syncevolution/sources/syncevolution-1.5.3.tar.gz
+ source = syncevolution-1.5.3-sslcert.patch
+ source = syncevolution-1.5.3-python2.patch
+ sha256sums = e1195fda09bc7782eb8a55674e9e69d69da4780a9aa4a54d37d84da67ee863c0
+ sha256sums = 6904cd9eb9ed4e3eb888bad187315960de9d8a23d69c3c5587e011441cca1494
+ sha256sums = 704cbbf11289c5fd82b8c7228661f8cddaa40714598c56b2154783a35630128e
pkgname = syncevolution
diff --git a/PKGBUILD b/PKGBUILD
index 7e9ce15d62a3..0883dae88922 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
# Maintainer: Justus Piater <Justus-dev at Piater dot name>
pkgname=('syncevolution' 'syncevolution-http')
-pkgver=1.5.2
-pkgrel=6
+pkgver=1.5.3
+pkgrel=1
pkgdesc="Synchronize PIM data via various protocols"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://syncevolution.org/"
license=('LGPL')
depends=('evolution-data-server' 'libgnome-keyring' 'neon' 'openobex' 'python2' 'libunique')
makedepends=('intltool' 'boost' 'python')
#changelog=
source=("https://download.01.org/syncevolution/syncevolution/sources/syncevolution-$pkgver.tar.gz"
- "$pkgname-$pkgver-libical3.patch"
+ "$pkgname-$pkgver-sslcert.patch"
"$pkgname-$pkgver-python2.patch")
-sha256sums=('8b692bd549a63d2259ed7519afb74fc9cab5be10c7a6f51868b66fc98fb48128'
- '36165fd651a2edc088dbf868214bace3d7f52f61dce051af4657ab1eafbe2ac9'
- '88e5deab491e40e932e9d6d3240fd97ca68550800cc1ae22eba8679092e770df')
+sha256sums=('e1195fda09bc7782eb8a55674e9e69d69da4780a9aa4a54d37d84da67ee863c0'
+ '6904cd9eb9ed4e3eb888bad187315960de9d8a23d69c3c5587e011441cca1494'
+ '704cbbf11289c5fd82b8c7228661f8cddaa40714598c56b2154783a35630128e')
prepare() {
cd "$pkgname-$pkgver"
- for patch in libical3 python2; do
+ for patch in sslcert python2; do
patch -p1 -i "$srcdir/$pkgname-$pkgver-$patch.patch"
done
autoreconf -fiv
diff --git a/syncevolution-1.5.2-libical3.patch b/syncevolution-1.5.2-libical3.patch
deleted file mode 100644
index d2de4801dafc..000000000000
--- a/syncevolution-1.5.2-libical3.patch
+++ /dev/null
@@ -1,125 +0,0 @@
-diff -aur syncevolution-1.5.2.pristine/src/backends/webdav/CalDAVSource.cpp syncevolution-1.5.2.new/src/backends/webdav/CalDAVSource.cpp
---- syncevolution-1.5.2.pristine/src/backends/webdav/CalDAVSource.cpp 2014-07-14 13:42:44.000000000 +0200
-+++ syncevolution-1.5.2.new/src/backends/webdav/CalDAVSource.cpp 2017-12-16 10:45:51.611051290 +0100
-@@ -721,8 +721,8 @@
- eptr<icalcomponent> fullcal = event.m_calendar;
- loadItem(event);
- event.m_sequence++;
-- lastmodtime = icaltime_from_timet(event.m_lastmodtime, false);
-- lastmodtime.is_utc = 1;
-+ lastmodtime = icaltime_from_timet_with_zone(event.m_lastmodtime, false, NULL);
-+ lastmodtime.zone = icaltimezone_get_utc_timezone();
- event.m_calendar = fullcal;
- for (icalcomponent *comp = icalcomponent_get_first_component(event.m_calendar, ICAL_VEVENT_COMPONENT);
- comp;
-diff -aur syncevolution-1.5.2.pristine/src/syncevo/icaltz-util.c syncevolution-1.5.2.new/src/syncevo/icaltz-util.c
---- syncevolution-1.5.2.pristine/src/syncevo/icaltz-util.c 2016-09-26 13:20:05.000000000 +0200
-+++ syncevolution-1.5.2.new/src/syncevo/icaltz-util.c 2017-12-16 10:45:51.611051290 +0100
-@@ -224,7 +224,7 @@
- struct icaltimetype itime;
-
- now = time (NULL);
-- itime = icaltime_from_timet (now, 0);
-+ itime = icaltime_from_timet_with_zone (now, 0, NULL);
- itime.month = itime.day = 1;
- itime.hour = itime.minute = itime.second = 0;
- year_start = icaltime_as_timet(itime);
-@@ -304,13 +304,13 @@
- icalrecur_iterator *iter;
-
- now = time (NULL);
-- itime = icaltime_from_timet (now, 0);
-+ itime = icaltime_from_timet_with_zone (now, 0, NULL);
- itime.month = itime.day = 1;
- itime.hour = itime.minute = itime.second = 0;
- year_start = icaltime_as_timet(itime);
-
- comp_start = icalcomponent_get_dtstart (comp);
-- start = icaltime_from_timet (year_start, 0);
-+ start = icaltime_from_timet_with_zone (year_start, 0, NULL);
-
- iter = icalrecur_iterator_new (rule, start);
- iter_start = icalrecur_iterator_next (iter);
-@@ -478,7 +478,7 @@
- trans = transitions [stdidx] + types [zp_idx].gmtoff;
- else
- trans = types [zp_idx].gmtoff;
-- icaltime = icaltime_from_timet (trans, 0);
-+ icaltime = icaltime_from_timet_with_zone (trans, 0, NULL);
- dtstart = icaltime;
- dtstart.year = 1970;
- dtstart.minute = dtstart.second = 0;
-@@ -520,7 +520,7 @@
- trans = transitions [dstidx] + types [zp_idx].gmtoff;
- else
- trans = types [zp_idx].gmtoff;
-- icaltime = icaltime_from_timet (trans, 0);
-+ icaltime = icaltime_from_timet_with_zone (trans, 0, NULL);
- dtstart = icaltime;
- dtstart.year = 1970;
- dtstart.minute = dtstart.second = 0;
-diff -aur syncevolution-1.5.2.pristine/src/synthesis/configure.in syncevolution-1.5.2.new/src/synthesis/configure.in
---- syncevolution-1.5.2.pristine/src/synthesis/configure.in 2016-10-06 16:40:43.000000000 +0200
-+++ syncevolution-1.5.2.new/src/synthesis/configure.in 2017-12-16 10:45:51.611051290 +0100
-@@ -101,9 +101,14 @@
- if test "$enable_libical" == "yes"; then
- PKG_CHECK_MODULES(LIBICAL, libical,
- [AC_DEFINE(HAVE_LIBICAL, 1, "libical available")
-- PKG_CHECK_MODULES(LIBICAL2, libical >= 2,
-- [AC_DEFINE(USE_ICALTZUTIL_SET_EXACT_VTIMEZONES_SUPPORT, 1, "Use icaltzutil_set_exact_vtimezones_support() to enable interoperable timezone definitions.")],
-- [true])],
-+ PKG_CHECK_MODULES(LIBICAL3, libical >= 3,
-+ [have_libical3="yes"],
-+ [have_libical3="no"])
-+ if test "$have_libical3" == "no"; then
-+ PKG_CHECK_MODULES(LIBICAL2, libical >= 2,
-+ [AC_DEFINE(USE_ICALTZUTIL_SET_EXACT_VTIMEZONES_SUPPORT, 1, "Use icaltzutil_set_exact_vtimezones_support() to enable interoperable timezone definitions.")],
-+ [true])
-+ fi],
- [AC_ERROR([libical not found, required for --enable-libical])])
- fi
-
-diff -aur syncevolution-1.5.2.pristine/src/synthesis/src/platform_adapters/linux/platform_timezones.cpp syncevolution-1.5.2.new/src/synthesis/src/platform_adapters/linux/platform_timezones.cpp
---- syncevolution-1.5.2.pristine/src/synthesis/src/platform_adapters/linux/platform_timezones.cpp 2016-10-06 16:40:43.000000000 +0200
-+++ syncevolution-1.5.2.new/src/synthesis/src/platform_adapters/linux/platform_timezones.cpp 2017-12-16 10:45:51.611051290 +0100
-@@ -59,6 +59,7 @@
- icalcomponent *(* icaltimezone_get_component_p)(icaltimezone *zone);
- char *(* icalcomponent_as_ical_string_p)(icalcomponent *comp);
- void (* icaltzutil_set_exact_vtimezones_support)(int on);
-+ int (* icalrecur_iterator_set_start)(icalrecur_iterator *impl, struct icaltimetype start);
- bool must_free_strings;
- } icalcontext;
-
-@@ -89,6 +90,8 @@
- }
- icalcontext.icaltzutil_set_exact_vtimezones_support =
- (typeof(icalcontext.icaltzutil_set_exact_vtimezones_support))dlsym(RTLD_DEFAULT, "icaltzutil_set_exact_vtimezones_support");
-+ icalcontext.icalrecur_iterator_set_start =
-+ (typeof(icalcontext.icalrecur_iterator_set_start))dlsym(RTLD_DEFAULT, "icalrecur_iterator_set_start");
-
- return icalcontext.icaltimezone_get_builtin_timezones_p ?
- icalcontext.icaltimezone_get_builtin_timezones_p() :
-@@ -121,8 +124,8 @@
- };
- // distinguish between v2 and older based on
- // icaltzutil_set_exact_vtimezones_support, which was introduced in
-- // v2
-- return icalcontext.icaltzutil_set_exact_vtimezones_support ?
-+ // v2, or icalrecur_iterator_set_start, which was introduced in v3
-+ return (icalcontext.icaltzutil_set_exact_vtimezones_support || icalcontext.icalrecur_iterator_set_start) ?
- reinterpret_cast<icalarray_v2 *>(array)->num_elements :
- reinterpret_cast<icalarray_traditional *>(array)->num_elements;
- }
-@@ -193,9 +196,10 @@
- icalarray *builtin = ICALTIMEZONE_GET_BUILTIN_TIMEZONES();
- #ifdef ICAL_COMPATIBILITY
- PLOGDEBUGPRINTFX(aGZones->getDbgLogger, DBG_PARSE+DBG_EXOTIC,
-- ("runtime check: libical %s, %s icaltzutil_set_exact_vtimezones_support",
-+ ("runtime check: libical %s, %s icaltzutil_set_exact_vtimezones_support, %s icalrecur_iterator_set_start",
- icalcontext.icaltimezone_get_builtin_timezones_p ? "available" : "unavailable",
-- icalcontext.icaltzutil_set_exact_vtimezones_support ? "with" : "without"));
-+ icalcontext.icaltzutil_set_exact_vtimezones_support ? "with" : "without",
-+ icalcontext.icalrecur_iterator_set_start ? "with" : "without"));
- // If we end up using the libical code (and not some replacement
- // provided by SyncEvolution, which is the solution for distros with
- // a libical that doesn't have the API), then enable timezones in the
diff --git a/syncevolution-1.5.2-python2.patch b/syncevolution-1.5.2-python2.patch
deleted file mode 100644
index 5cea56366486..000000000000
--- a/syncevolution-1.5.2-python2.patch
+++ /dev/null
@@ -1,87 +0,0 @@
-diff -aur syncevolution-1.5.2.orig/build/source2html.py syncevolution-1.5.2.new/build/source2html.py
---- syncevolution-1.5.2.orig/build/source2html.py 2014-04-25 09:55:47.000000000 +0200
-+++ syncevolution-1.5.2.new/build/source2html.py 2017-12-16 13:46:11.102228551 +0100
-@@ -1,4 +1,4 @@
--#!/usr/bin/python
-+#!/usr/bin/python2
-
- """
- Converts source code (first parameter, can be - for stdin) to HTML
-diff -aur syncevolution-1.5.2.orig/Makefile.in syncevolution-1.5.2.new/Makefile.in
---- syncevolution-1.5.2.orig/Makefile.in 2016-11-08 18:13:27.000000000 +0100
-+++ syncevolution-1.5.2.new/Makefile.in 2017-12-16 13:46:06.608877880 +0100
-@@ -12859,7 +12859,7 @@
- fi; \
- done
- src/ClientTest.cpp.html: build/source2html.py test/ClientTest.cpp
-- $(AM_V_GEN)python $+ >$@
-+ $(AM_V_GEN)python2 $+ >$@
-
- # copy base test files
- $(filter-out %.tem, $(filter src/testcases/%, $(subst $(top_srcdir)/test/,src/,$(CLIENT_LIB_TEST_FILES)))) : src/% : $(top_srcdir)/test/%
-diff -aur syncevolution-1.5.2.orig/src/dbus/server/pim/examples/search.py syncevolution-1.5.2.new/src/dbus/server/pim/examples/search.py
---- syncevolution-1.5.2.orig/src/dbus/server/pim/examples/search.py 2014-10-30 17:54:09.000000000 +0100
-+++ syncevolution-1.5.2.new/src/dbus/server/pim/examples/search.py 2017-12-16 13:46:10.455559391 +0100
-@@ -1,4 +1,4 @@
--#! /usr/bin/python -u
-+#! /usr/bin/python2 -u
- # -*- coding: utf-8 -*-
- # vim: set fileencoding=utf-8 :#
- #
-diff -aur syncevolution-1.5.2.orig/src/dbus/server/pim/examples/sync.py syncevolution-1.5.2.new/src/dbus/server/pim/examples/sync.py
---- syncevolution-1.5.2.orig/src/dbus/server/pim/examples/sync.py 2014-10-30 17:54:09.000000000 +0100
-+++ syncevolution-1.5.2.new/src/dbus/server/pim/examples/sync.py 2017-12-16 13:46:09.958890807 +0100
-@@ -1,4 +1,4 @@
--#! /usr/bin/python -u
-+#! /usr/bin/python2 -u
- # -*- coding: utf-8 -*-
- # vim: set fileencoding=utf-8 :#
- #
-diff -aur syncevolution-1.5.2.orig/src/dbus/server/pim/testpim.py syncevolution-1.5.2.new/src/dbus/server/pim/testpim.py
---- syncevolution-1.5.2.orig/src/dbus/server/pim/testpim.py 2014-10-30 17:54:09.000000000 +0100
-+++ syncevolution-1.5.2.new/src/dbus/server/pim/testpim.py 2017-12-16 13:46:09.358888493 +0100
-@@ -1,4 +1,4 @@
--#! /usr/bin/python -u
-+#! /usr/bin/python2 -u
- # -*- coding: utf-8 -*-
- # vim: set fileencoding=utf-8 :#
- #
-diff -aur syncevolution-1.5.2.orig/src/src.am syncevolution-1.5.2.new/src/src.am
---- syncevolution-1.5.2.orig/src/src.am 2016-09-26 13:20:05.000000000 +0200
-+++ syncevolution-1.5.2.new/src/src.am 2017-12-16 13:46:08.662219136 +0100
-@@ -366,7 +366,7 @@
- nodist_noinst_DATA += src/ClientTest.cpp.html
- CLEANFILES += src/ClientTest.cpp.html
- src/ClientTest.cpp.html: build/source2html.py test/ClientTest.cpp
-- $(AM_V_GEN)python $+ >$@
-+ $(AM_V_GEN)python2 $+ >$@
-
- # copy base test files
- $(filter-out %.tem, $(filter src/testcases/%, $(subst $(top_srcdir)/test/,src/,$(CLIENT_LIB_TEST_FILES)))) : src/% : $(top_srcdir)/test/%
-diff -aur syncevolution-1.5.2.orig/test/log2html.py syncevolution-1.5.2.new/test/log2html.py
---- syncevolution-1.5.2.orig/test/log2html.py 2014-04-25 09:55:47.000000000 +0200
-+++ syncevolution-1.5.2.new/test/log2html.py 2017-12-16 13:46:07.095546420 +0100
-@@ -1,4 +1,4 @@
--#!/usr/bin/python
-+#!/usr/bin/python2
-
- """
- Converts the .log output for a client-test test into HTML, with
-diff -aur syncevolution-1.5.2.orig/test/syncevo-http-server.py syncevolution-1.5.2.new/test/syncevo-http-server.py
---- syncevolution-1.5.2.orig/test/syncevo-http-server.py 2016-09-26 13:20:05.000000000 +0200
-+++ syncevolution-1.5.2.new/test/syncevo-http-server.py 2017-12-16 13:46:08.088883590 +0100
-@@ -1,4 +1,4 @@
--#! /usr/bin/python
-+#! /usr/bin/python2
-
- '''Usage: syncevo-http-server.py <URL>
- Runs a SyncML HTTP server under the given base URL.'''
-diff -aur syncevolution-1.5.2.orig/test/syncevo-phone-config.py syncevolution-1.5.2.new/test/syncevo-phone-config.py
---- syncevolution-1.5.2.orig/test/syncevo-phone-config.py 2014-04-25 09:55:48.000000000 +0200
-+++ syncevolution-1.5.2.new/test/syncevo-phone-config.py 2017-12-16 13:46:07.602215045 +0100
-@@ -1,4 +1,4 @@
--#!/usr/bin/python
-+#!/usr/bin/python2
- #
- # Copyright (C) 2010 Intel Corporation
- #
diff --git a/syncevolution-1.5.3-python2.patch b/syncevolution-1.5.3-python2.patch
new file mode 100644
index 000000000000..21bd7fa57cc6
--- /dev/null
+++ b/syncevolution-1.5.3-python2.patch
@@ -0,0 +1,87 @@
+diff -ura syncevolution-1.5.3.orig/build/source2html.py syncevolution-1.5.3.new/build/source2html.py
+--- syncevolution-1.5.3.orig/build/source2html.py 2014-04-25 09:55:47.000000000 +0200
++++ syncevolution-1.5.3.new/build/source2html.py 2018-03-31 15:07:19.024561185 +0200
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/python2
+
+ """
+ Converts source code (first parameter, can be - for stdin) to HTML
+diff -ura syncevolution-1.5.3.orig/Makefile.in syncevolution-1.5.3.new/Makefile.in
+--- syncevolution-1.5.3.orig/Makefile.in 2018-01-09 16:54:29.000000000 +0100
++++ syncevolution-1.5.3.new/Makefile.in 2018-03-31 15:07:15.649581388 +0200
+@@ -12881,7 +12881,7 @@
+ fi; \
+ done
+ src/ClientTest.cpp.html: build/source2html.py test/ClientTest.cpp
+- $(AM_V_GEN)python $+ >$@
++ $(AM_V_GEN)python2 $+ >$@
+
+ # copy base test files
+ $(filter-out %.tem, $(filter src/testcases/%, $(subst $(top_srcdir)/test/,src/,$(CLIENT_LIB_TEST_FILES)))) : src/% : $(top_srcdir)/test/%
+diff -ura syncevolution-1.5.3.orig/src/dbus/server/pim/examples/search.py syncevolution-1.5.3.new/src/dbus/server/pim/examples/search.py
+--- syncevolution-1.5.3.orig/src/dbus/server/pim/examples/search.py 2014-10-30 17:54:09.000000000 +0100
++++ syncevolution-1.5.3.new/src/dbus/server/pim/examples/search.py 2018-03-31 15:07:18.447564681 +0200
+@@ -1,4 +1,4 @@
+-#! /usr/bin/python -u
++#! /usr/bin/python2 -u
+ # -*- coding: utf-8 -*-
+ # vim: set fileencoding=utf-8 :#
+ #
+diff -ura syncevolution-1.5.3.orig/src/dbus/server/pim/examples/sync.py syncevolution-1.5.3.new/src/dbus/server/pim/examples/sync.py
+--- syncevolution-1.5.3.orig/src/dbus/server/pim/examples/sync.py 2014-10-30 17:54:09.000000000 +0100
++++ syncevolution-1.5.3.new/src/dbus/server/pim/examples/sync.py 2018-03-31 15:07:18.022567255 +0200
+@@ -1,4 +1,4 @@
+-#! /usr/bin/python -u
++#! /usr/bin/python2 -u
+ # -*- coding: utf-8 -*-
+ # vim: set fileencoding=utf-8 :#
+ #
+diff -ura syncevolution-1.5.3.orig/src/dbus/server/pim/testpim.py syncevolution-1.5.3.new/src/dbus/server/pim/testpim.py
+--- syncevolution-1.5.3.orig/src/dbus/server/pim/testpim.py 2014-10-30 17:54:09.000000000 +0100
++++ syncevolution-1.5.3.new/src/dbus/server/pim/testpim.py 2018-03-31 15:07:17.623569650 +0200
+@@ -1,4 +1,4 @@
+-#! /usr/bin/python -u
++#! /usr/bin/python2 -u
+ # -*- coding: utf-8 -*-
+ # vim: set fileencoding=utf-8 :#
+ #
+diff -ura syncevolution-1.5.3.orig/src/src.am syncevolution-1.5.3.new/src/src.am
+--- syncevolution-1.5.3.orig/src/src.am 2018-01-05 16:10:27.000000000 +0100
++++ syncevolution-1.5.3.new/src/src.am 2018-03-31 15:07:17.214572102 +0200
+@@ -367,7 +367,7 @@
+ nodist_noinst_DATA += src/ClientTest.cpp.html
+ CLEANFILES += src/ClientTest.cpp.html
+ src/ClientTest.cpp.html: build/source2html.py test/ClientTest.cpp
+- $(AM_V_GEN)python $+ >$@
++ $(AM_V_GEN)python2 $+ >$@
+
+ # copy base test files
+ $(filter-out %.tem, $(filter src/testcases/%, $(subst $(top_srcdir)/test/,src/,$(CLIENT_LIB_TEST_FILES)))) : src/% : $(top_srcdir)/test/%
+diff -ura syncevolution-1.5.3.orig/test/log2html.py syncevolution-1.5.3.new/test/log2html.py
+--- syncevolution-1.5.3.orig/test/log2html.py 2014-04-25 09:55:47.000000000 +0200
++++ syncevolution-1.5.3.new/test/log2html.py 2018-03-31 15:07:16.178578268 +0200
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/python2
+
+ """
+ Converts the .log output for a client-test test into HTML, with
+diff -ura syncevolution-1.5.3.orig/test/syncevo-http-server.py syncevolution-1.5.3.new/test/syncevo-http-server.py
+--- syncevolution-1.5.3.orig/test/syncevo-http-server.py 2016-09-26 13:20:05.000000000 +0200
++++ syncevolution-1.5.3.new/test/syncevo-http-server.py 2018-03-31 15:07:16.902573965 +0200
+@@ -1,4 +1,4 @@
+-#! /usr/bin/python
++#! /usr/bin/python2
+
+ '''Usage: syncevo-http-server.py <URL>
+ Runs a SyncML HTTP server under the given base URL.'''
+diff -ura syncevolution-1.5.3.orig/test/syncevo-phone-config.py syncevolution-1.5.3.new/test/syncevo-phone-config.py
+--- syncevolution-1.5.3.orig/test/syncevo-phone-config.py 2014-04-25 09:55:48.000000000 +0200
++++ syncevolution-1.5.3.new/test/syncevo-phone-config.py 2018-03-31 15:07:16.575575908 +0200
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/python2
+ #
+ # Copyright (C) 2010 Intel Corporation
+ #
diff --git a/syncevolution-1.5.3-sslcert.patch b/syncevolution-1.5.3-sslcert.patch
new file mode 100644
index 000000000000..44ff97758e7d
--- /dev/null
+++ b/syncevolution-1.5.3-sslcert.patch
@@ -0,0 +1,16 @@
+diff -ura syncevolution-1.5.3.orig/src/syncevo/SoupTransportAgent.cpp syncevolution-1.5.3.new/src/syncevo/SoupTransportAgent.cpp
+--- syncevolution-1.5.3.orig/src/syncevo/SoupTransportAgent.cpp 2018-01-09 16:53:27.000000000 +0100
++++ syncevolution-1.5.3.new/src/syncevo/SoupTransportAgent.cpp 2018-03-31 14:58:19.151329884 +0200
+@@ -134,6 +134,11 @@
+ g_object_set(m_session.get(), SOUP_SESSION_SSL_CA_FILE, m_cacerts.c_str(), NULL);
+ }
+ }
++ else {
++ // https://lists.syncevolution.org/pipermail/syncevolution/2018-January/005602.html
++ // Checking enabled by default, disable it.
++ g_object_set(m_session.get(), SOUP_SESSION_SSL_STRICT, false, NULL);
++ }
+
+ soup_message_set_request(message.get(), m_contentType.c_str(),
+ SOUP_MEMORY_TEMPORARY, data, len);
+Only in syncevolution-1.5.3.new/src/syncevo: SoupTransportAgent.cpp~