summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Luna2015-06-08 16:12:22 -0500
committerChristopher Luna2015-06-08 16:12:22 -0500
commit8144a7319acae13f860862d9b5ac8a9114c3c91d (patch)
treeea5445d5b65f6fb4553786e49c510d31e3502333
downloadaur-8144a7319acae13f860862d9b5ac8a9114c3c91d.tar.gz
First commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..47ecc97193fb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = syncterm
+ pkgdesc = A BBS terminal program, Supports ANSI music and the IBM charset when possible. Will run from a console, under X11 using XLib, or using SDL.
+ pkgver = 0.9.5b20140603
+ pkgrel = 1
+ epoch = 1
+ url = http://syncterm.bbsdev.net
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = ncurses
+ depends = sdl
+ options = !buildflags
+ source = http://iweb.dl.sourceforge.net/project/syncterm/syncterm/syncterm-0.9.5/syncterm-src-20140603.tgz
+ md5sums = 7bf1ed92ccaff591a91e528507a5f09a
+
+pkgname = syncterm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e3e431aea3b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer chrisl echo archlinux@c2h0r1i2s4t5o6p7h8e9r-l3u4n1a.com|sed 's/[0-9]//g'
+# Contributor: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+
+pkgname=syncterm
+pkgver=0.9.5b20140603
+pkgrel=1
+epoch=1
+pkgdesc="A BBS terminal program, Supports ANSI music and the IBM charset when possible. Will run from a console, under X11 using XLib, or using SDL."
+url="http://syncterm.bbsdev.net"
+license='GPL'
+depends=('ncurses' 'sdl')
+options=(!buildflags)
+arch=('i686' 'x86_64')
+source=(http://iweb.dl.sourceforge.net/project/syncterm/syncterm/syncterm-0.9.5/syncterm-src-20140603.tgz)
+md5sums=('7bf1ed92ccaff591a91e528507a5f09a')
+
+
+build() {
+ cd "$srcdir/syncterm-20140603"
+ cd "src/syncterm/"
+ make SRC_ROOT="$(realpath ..)" PREFIX="/usr" || true
+}
+
+package() {
+ cd "$srcdir/syncterm-20140603"
+ cd "src/syncterm/"
+ make SRC_ROOT="$(realpath ..)" PREFIX="$pkgdir/usr" install
+}
+