summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorthisirs2021-04-18 17:29:00 +0200
committerthisirs2021-04-18 17:29:00 +0200
commit36cf30f0c236937c4188aa16962e8120b47fad92 (patch)
tree31136d5339660cf53a88be96db195a26ab42a908
parentb52ce835a855e8614fab7133bb9dc9d8d6b580fb (diff)
downloadaur-synology-cloud-station-drive.tar.gz
Add Wayland compatibility (thanks @evybongers)
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD8
-rw-r--r--force-x11.patch14
4 files changed, 25 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe76dbe4406e..124db642b197 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,15 @@
pkgbase = synology-cloud-station-drive
pkgdesc = An application which sync files between your computers and Synology NAS
pkgver = 4.3.3.4469
- pkgrel = 1
+ pkgrel = 2
url = https://www.synology.com/en-global/releaseNote/CloudStationDrive
arch = i686
arch = x86_64
license = custom
optdepends = nautilus: Nautilus integration
+ optdepends = xorg-xwayland: Support running under Wayland
+ source = force-x11.patch
+ md5sums = a276cb536c6cbe1f39c88c8ee469f9c7
source_i686 = https://global.download.synology.com/download/Tools/CloudStationDrive/4.3.3-4469/Ubuntu/Installer/i686/synology-cloud-station-drive-4469.i686.deb
md5sums_i686 = 650cffb6a925d79e350e0ae52d94b718
source_x86_64 = https://global.download.synology.com/download/Tools/CloudStationDrive/4.3.3-4469/Ubuntu/Installer/x86_64/synology-cloud-station-drive-4469.x86_64.deb
diff --git a/.gitignore b/.gitignore
index eeeab02e9c18..a4fe39ba4c83 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,4 @@
!.SRCINFO
!*.install
!.gitignore
+!*.patch
diff --git a/PKGBUILD b/PKGBUILD
index d6a890422849..02ac32bbbdc8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,12 +6,15 @@ pkgname=synology-cloud-station-drive
_iver=4469
_rver=4.3.3
pkgver=$_rver.$_iver
-pkgrel=1
+pkgrel=2
pkgdesc='An application which sync files between your computers and Synology NAS'
arch=('i686' 'x86_64')
url='https://www.synology.com/en-global/releaseNote/CloudStationDrive'
license=('custom')
-optdepends=('nautilus: Nautilus integration')
+optdepends=('nautilus: Nautilus integration'
+ 'xorg-xwayland: Support running under Wayland')
+source=("force-x11.patch")
+md5sums=('a276cb536c6cbe1f39c88c8ee469f9c7')
source_i686=("https://global.download.synology.com/download/Tools/CloudStationDrive/$_rver-$_iver/Ubuntu/Installer/i686/synology-cloud-station-drive-$_iver.i686.deb")
md5sums_i686=('650cffb6a925d79e350e0ae52d94b718')
source_x86_64=("https://global.download.synology.com/download/Tools/CloudStationDrive/$_rver-$_iver/Ubuntu/Installer/x86_64/synology-cloud-station-drive-$_iver.x86_64.deb")
@@ -20,6 +23,7 @@ md5sums_x86_64=('2abfd45014589f1818c87050f70ea90e')
prepare() {
cd "$srcdir"
tar -xJf "$srcdir"/data.tar.xz
+ patch -p1 < force-x11.patch
}
package() {
diff --git a/force-x11.patch b/force-x11.patch
new file mode 100644
index 000000000000..e509d2973a2b
--- /dev/null
+++ b/force-x11.patch
@@ -0,0 +1,14 @@
+diff --git a/synology-cloud-station-drive b/synology-cloud-station-drive
+index cdf04b7..9c291d3 100755
+--- a/usr/bin/synology-cloud-station-drive
++++ b/usr/bin/synology-cloud-station-drive
+@@ -59,7 +59,7 @@ gracefull_stop_service()
+
+ start()
+ {
+- env "LD_LIBRARY_PATH=$LIB_PATH" "$BIN_PATH" &
++ env QT_QPA_PLATFORM=xcb "LD_LIBRARY_PATH=$LIB_PATH" "$BIN_PATH" &
+ }
+
+ stop()
+