summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWu Zhenyu2022-10-07 16:51:40 +0800
committerWu Zhenyu2022-10-07 17:11:44 +0800
commit21d2406d700eaae6a66682565cbed17f31dd634c (patch)
tree0824558f1fcb9b75e5dbe9600ce47bc6fc370447
downloadaur-syntest.tar.gz
Initial
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD22
3 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..76047207bfd9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = syntest
+ pkgdesc = Rust library for syntax highlighting using Sublime Text syntax definitions.
+ pkgver = 5.0.0
+ pkgrel = 1
+ url = https://github.com/trishume/syntect
+ arch = x86_64
+ license = MIT
+ source = https://github.com/trishume/syntect/archive/v5.0.0.tar.gz
+ sha256sums = 84c21f8321ebaa794fd740a53a3691daaf3a91fb1be6a04edaf2638855a15fe6
+
+pkgname = syntest
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8a5cafba2b8e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/*
+!/.gitignore
+!/PKGBUILD
+!/.SRCINFO
+!/*.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d1b53716c183
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Wu Zhenyu <wuzy01@qq.com>
+# https://aur.archlinux.org/packages/updaurpkg-git
+# $ updaurpkg --apply
+_repo=trishume/syntect
+_source_type=github-releases
+_upstreamver='v5.0.0'
+
+pkgname=syntest
+pkgver=${_upstreamver##v}
+pkgrel=1
+pkgdesc="Rust library for syntax highlighting using Sublime Text syntax definitions."
+arch=(x86_64)
+url=https://github.com/$_repo
+license=(MIT)
+source=("$url/archive/$_upstreamver.tar.gz")
+sha256sums=(84c21f8321ebaa794fd740a53a3691daaf3a91fb1be6a04edaf2638855a15fe6)
+
+package() {
+ cd "$srcdir/${url##*/}-$pkgver"
+ cargo build --release --example syntest
+ install -D "target/release/examples/$pkgname" -t "$pkgdir/usr/bin"
+}