summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancisco Soto2018-09-12 20:57:22 -0700
committerFrancisco Soto2018-09-12 20:57:22 -0700
commit0300e9d658d54018170170b69e98b72863cba9ba (patch)
tree56b22aea95406df83e370763e49ee16f9f458bc8
parent616dd5f2a088172cd569d228371088a9e3692ed9 (diff)
downloadaur-0300e9d658d54018170170b69e98b72863cba9ba.tar.gz
Update to version 100-1.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
-rw-r--r--graphics.patch44
3 files changed, 32 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 66c17afb4032..91d57d54b2fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = system76-power
pkgdesc = System76 Power Management
- pkgver = 97
+ pkgver = 100
pkgrel = 1
url = https://github.com/pop-os/system76-power
install = system76-power.install
@@ -10,12 +10,10 @@ pkgbase = system76-power
depends = dbus
depends = systemd
depends = system76-dkms
- source = system76::git+https://github.com/pop-os/system76-power.git#commit=d7925643457fb7e0b27b7204d29f95704581759c
+ source = system76::git+https://github.com/pop-os/system76-power.git#commit=ad63c6302c5b5c77a2d9aa2fe4d96f93aac3e563
source = graphics.patch
- source = nvidia-fallback.service
sha1sums = SKIP
- sha1sums = 171ba625717bb419e830a1275f8ba313915d3045
- sha1sums = 5a81fb98c76cab0cd6e958d6776fca852c5ee4e2
+ sha1sums = e486644709099b6348dc96d5f468ae289840dade
pkgname = system76-power
diff --git a/PKGBUILD b/PKGBUILD
index cb7dff937439..f6cc8b12c4c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=system76
_pkgbase=system76-power
pkgname=system76-power
-pkgver=97
+pkgver=100
pkgrel=1
pkgdesc="System76 Power Management"
arch=('any')
@@ -17,14 +17,12 @@ depends=(
)
makedepends=('rust')
source=(
- 'system76::git+https://github.com/pop-os/system76-power.git#commit=d7925643457fb7e0b27b7204d29f95704581759c'
+ 'system76::git+https://github.com/pop-os/system76-power.git#commit=ad63c6302c5b5c77a2d9aa2fe4d96f93aac3e563'
'graphics.patch'
- 'nvidia-fallback.service'
)
sha1sums=(
'SKIP'
- '171ba625717bb419e830a1275f8ba313915d3045'
- '5a81fb98c76cab0cd6e958d6776fca852c5ee4e2'
+ 'e486644709099b6348dc96d5f468ae289840dade'
)
pkgver() {
@@ -43,8 +41,6 @@ build() {
}
package() {
- install -Dm644 ${srcdir}/nvidia-fallback.service ${pkgdir}/usr/lib/systemd/system/nvidia-fallback.service
-
# Install daemons
install -Dm755 ${srcdir}/${_pkgname}/target/release/system76-power ${pkgdir}/usr/bin/system76-power
diff --git a/graphics.patch b/graphics.patch
index dbcff95157b2..8937050a20de 100644
--- a/graphics.patch
+++ b/graphics.patch
@@ -1,25 +1,33 @@
---- src/system76/src/graphics.rs 2018-08-25 00:37:50.963144090 -0700
-+++ src/system76/src/graphics.rs.new 2018-08-24 15:57:13.563144181 -0700
-@@ -135,14 +135,14 @@
+--- src/system76/src/graphics.rs 2018-09-11 20:08:40.269995504 -0700
++++ src/system76/src/graphics.rs.new 2018-09-11 20:10:14.403327798 -0700
+@@ -12,10 +12,10 @@
+ blacklist nvidia
+ blacklist nvidia-drm
+ blacklist nvidia-modeset
+-alias nouveau off
+-alias nvidia off
+-alias nvidia-drm off
+-alias nvidia-modeset off
++#alias nouveau off
++#alias nvidia off
++#alias nvidia-drm off
++#alias nvidia-modeset off
+ "#;
+
+ pub struct Graphics {
+@@ -135,12 +135,12 @@
}
}
- info!("Updating initramfs");
- let status = process::Command::new("update-initramfs").arg("-u").status()?;
-- if ! status.success() {
-- return Err(io::Error::new(
-- io::ErrorKind::Other,
++ info!("Updating mkinitcpio");
++ let status = process::Command::new("mkinitcpio").arg("-P").status()?;
+ if ! status.success() {
+ return Err(io::Error::new(
+ io::ErrorKind::Other,
- format!("update-initramfs: failed with {}", status)
-- ));
-- }
-+ // info!("Updating initramfs");
-+ // let status = process::Command::new("update-initramfs").arg("-u").status()?;
-+ // if ! status.success() {
-+ // return Err(io::Error::new(
-+ // io::ErrorKind::Other,
-+ // format!("update-initramfs: failed with {}", status)
-+ // ));
-+ // }
++ format!("mkinitcpio: failed with {}", status)
+ ));
+ }
- Ok(())
- } else {