summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorshironeko2021-09-19 14:11:26 -0400
committershironeko2021-09-19 14:11:26 -0400
commit19be1b60c8d227fe66e62fe94e30d606f86d80b6 (patch)
treebf6da25594e2bd86dd4b4a6bfe39d15112a3931d
parenta9c8e7b2efb25b661cd1260985b4d8fb1ad2a3e8 (diff)
downloadaur-19be1b60c8d227fe66e62fe94e30d606f86d80b6.tar.gz
update to 1.1.18
-rw-r--r--PKGBUILD15
-rw-r--r--rust-toolchain1
2 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1b4eeac4b07d..9b743af2d4db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: tleydxdy <shironeko(at)waifu(dot)club>
pkgname=system76-power
-pkgver=1.1.17
+pkgver=1.1.18
pkgrel=1
pkgdesc="System76 Power Management"
arch=('any')
@@ -12,7 +12,6 @@ depends=(
'dbus'
'libusb'
'polkit'
-'systemd'
)
optdepends=(
'system76-acpi-dkms: some systems might need this driver'
@@ -24,12 +23,12 @@ source=(
"https://github.com/pop-os/${pkgname}/archive/${pkgver}.tar.gz"
'use-mkinitcpio.patch'
'makefile.patch'
+'rust-toolchain'
)
-sha256sums=(
-'d817e22047e41110ce2520f792ee5eae55220ba6d5fc4138a73040ebeb06e9b5'
-'2ead269c71919c220a7880b0036c6d62aadeae3d6cde769029784d3565686539'
-'97deb1f9cf6a312e8378bb96a4a83dae2498a4936c130e2ef5b125d13b92bb65'
-)
+sha256sums=('7a6b8b18b28948808b3c51f732c42e72797f8eddd79fa57f4285689087d781cd'
+ '2ead269c71919c220a7880b0036c6d62aadeae3d6cde769029784d3565686539'
+ '97deb1f9cf6a312e8378bb96a4a83dae2498a4936c130e2ef5b125d13b92bb65'
+ 'f6a0b9759d1af128dd09bb3f49812c052c89168e7b159e6d269036a2faba3260')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -38,6 +37,8 @@ prepare() {
patch --no-backup-if-mismatch -Np1 -i "${srcdir}"/use-mkinitcpio.patch
# fix makefile
patch --no-backup-if-mismatch -Np1 -i "${srcdir}"/makefile.patch
+
+ cp "${srcdir}"/rust-toolchain .
}
build() {
diff --git a/rust-toolchain b/rust-toolchain
new file mode 100644
index 000000000000..ba0a719118ce
--- /dev/null
+++ b/rust-toolchain
@@ -0,0 +1 @@
+1.51.0