summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortleydxdy2021-06-20 16:09:44 +0800
committertleydxdy2021-06-20 16:10:10 +0800
commit236de49a9ff44bd486597c5890292485288a152c (patch)
tree7052bab123960259c4c69cbfd462aadb75f02d68
parent6268c8f69862b64b5f17a3a9de54310fe3793a86 (diff)
downloadaur-236de49a9ff44bd486597c5890292485288a152c.tar.gz
makefile needs patch :(
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--makefile.patch11
3 files changed, 19 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 08dfce591889..e9caaec98b2a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = system76-power
pkgdesc = System76 Power Management
pkgver = 1.1.16
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/pop-os/system76-power
install = system76-power.install
arch = any
@@ -16,7 +16,9 @@ pkgbase = system76-power
optdepends = system76-io-dkms: some systems might need this driver
source = https://github.com/pop-os/system76-power/archive/1.1.16.tar.gz
source = use-mkinitcpio.patch
+ source = makefile.patch
sha256sums = 56b33e6d41dd07892b73aca8d1da32a552bf644e986c657abbddd83e2071ea79
sha256sums = 6d59cb091858b65a0ad6682dda29ec1d970066f67a7b50430960989f6c428891
+ sha256sums = 97deb1f9cf6a312e8378bb96a4a83dae2498a4936c130e2ef5b125d13b92bb65
pkgname = system76-power
diff --git a/PKGBUILD b/PKGBUILD
index 2697b1754795..094d4042eb19 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=system76-power
pkgver=1.1.16
-pkgrel=4
+pkgrel=5
pkgdesc="System76 Power Management"
arch=('any')
url="https://github.com/pop-os/system76-power"
@@ -23,10 +23,12 @@ makedepends=('rust')
source=(
"https://github.com/pop-os/${pkgname}/archive/${pkgver}.tar.gz"
'use-mkinitcpio.patch'
+'makefile.patch'
)
sha256sums=(
'56b33e6d41dd07892b73aca8d1da32a552bf644e986c657abbddd83e2071ea79'
'6d59cb091858b65a0ad6682dda29ec1d970066f67a7b50430960989f6c428891'
+'97deb1f9cf6a312e8378bb96a4a83dae2498a4936c130e2ef5b125d13b92bb65'
)
prepare() {
@@ -34,6 +36,8 @@ prepare() {
# use mkinitcpio -P inplace of update-initramfs -u
patch --no-backup-if-mismatch -Np1 -i "${srcdir}"/use-mkinitcpio.patch
+ # fix makefile
+ patch --no-backup-if-mismatch -Np1 -i "${srcdir}"/makefile.patch
}
build() {
diff --git a/makefile.patch b/makefile.patch
new file mode 100644
index 000000000000..c60736d50d62
--- /dev/null
+++ b/makefile.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -35,7 +35,7 @@ distclean:
+
+ install: all
+ install -D -m 0755 "target/release/$(BIN)" "$(DESTDIR)$(bindir)/$(BIN)"
+- install -D -m 0644 "data/$(BIN).conf" "$(DESTDIR)$(sysconfdir)/dbus-1/system.d/$(BIN).conf"
++ install -D -m 0644 "data/$(BIN).conf" "$(DESTDIR)$(datadir)/dbus-1/system.d/$(BIN).conf"
+ install -D -m 0644 "debian/$(BIN).service" "$(DESTDIR)$(sysconfdir)/systemd/system/$(BIN).service"
+ install -D -m 0644 "data/$(POLICY).policy" $(DESTDIR)$(datadir)/polkit-1/actions/$(POLICY).policy
+