summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortleydxdy2021-04-09 08:08:52 +0800
committertleydxdy2021-04-09 08:08:52 +0800
commit2dd1e066e9450a08a4742103a0cbd311333f2844 (patch)
tree6c1d11626d12e34e535ee3912e339140d88f8e2e
parent19f025d6562f97ba0777736bc9a89fa0c340e8f6 (diff)
downloadaur-2dd1e066e9450a08a4742103a0cbd311333f2844.tar.gz
update to 1.1.5
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD24
3 files changed, 16 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 027c39ea3011..3f2cac4dbdd3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = system76-power
pkgdesc = System76 Power Management
- pkgver = 1.1.4
+ pkgver = 1.1.5
pkgrel = 1
url = https://github.com/pop-os/system76-power
install = system76-power.install
@@ -10,9 +10,9 @@ pkgbase = system76-power
depends = dbus
depends = systemd
depends = system76-dkms
- source = https://github.com/pop-os/system76-power/archive/1.1.4.tar.gz
+ source = https://github.com/pop-os/system76-power/archive/1.1.5.tar.gz
source = use-mkinitcpio.patch
- sha256sums = d227117563d3a25c8ab7e0549e9b6245955568bb30f95c35f8f503ccb6142e53
+ sha256sums = 3e95ea9935f3c8efdb425d9993c56684b05c8eb9eb2d302b32b8301220f56be3
sha256sums = 6d59cb091858b65a0ad6682dda29ec1d970066f67a7b50430960989f6c428891
pkgname = system76-power
diff --git a/.gitignore b/.gitignore
index ee56d8c1098d..cdd6b0f23e74 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,3 @@
-*.tar.zst
-*.tar.xz
-*.tar.gz
-/system76
+*.tar.*
/pkg
/src
diff --git a/PKGBUILD b/PKGBUILD
index 2609ba571dff..2df10cbb33b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: tleydxdy <shironeko(at)waifu(dot)club>
pkgname=system76-power
-pkgver=1.1.4
+pkgver=1.1.5
pkgrel=1
pkgdesc="System76 Power Management"
arch=('any')
@@ -9,9 +9,9 @@ url="https://github.com/pop-os/system76-power"
license=('GPL')
install="${pkgname}.install"
depends=(
- 'dbus'
- 'systemd'
- 'system76-dkms'
+'dbus'
+'systemd'
+'system76-dkms'
)
makedepends=('rust')
source=(
@@ -19,33 +19,33 @@ source=(
'use-mkinitcpio.patch'
)
sha256sums=(
-'d227117563d3a25c8ab7e0549e9b6245955568bb30f95c35f8f503ccb6142e53'
+'3e95ea9935f3c8efdb425d9993c56684b05c8eb9eb2d302b32b8301220f56be3'
'6d59cb091858b65a0ad6682dda29ec1d970066f67a7b50430960989f6c428891'
)
prepare() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd "${srcdir}/${pkgname}-${pkgver}"
# use mkinitcpio -P inplace of update-initramfs -u
- patch --no-backup-if-mismatch -Np1 -i ${srcdir}/use-mkinitcpio.patch
+ patch --no-backup-if-mismatch -Np1 -i "${srcdir}"/use-mkinitcpio.patch
}
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd "${srcdir}/${pkgname}-${pkgver}"
# Build and install base package
cargo build --release
}
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd "${srcdir}/${pkgname}-${pkgver}"
# Install daemons
- install -Dm755 target/release/system76-power ${pkgdir}/usr/bin/system76-power
+ install -Dm755 target/release/system76-power "${pkgdir}/usr/bin/system76-power"
# Install systemd unit files
- install -Dm644 debian/system76-power.service ${pkgdir}/usr/lib/systemd/system/system76-power.service
+ install -Dm644 debian/system76-power.service "${pkgdir}/usr/lib/systemd/system/system76-power.service"
# Install scripts and configuration
- install -Dm755 data/system76-power.conf ${pkgdir}/usr/share/dbus-1/system.d/system76-power.conf
+ install -Dm755 data/system76-power.conf "${pkgdir}/usr/share/dbus-1/system.d/system76-power.conf"
}