summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancisco Soto2018-09-21 21:48:36 -0700
committerFrancisco Soto2018-09-21 21:48:36 -0700
commit7770949f0707d469ad6eda65df387c06e2fb9822 (patch)
tree4773c334cfcb5a79dc187a122d89a25c6b01812b
parent0300e9d658d54018170170b69e98b72863cba9ba (diff)
downloadaur-7770949f0707d469ad6eda65df387c06e2fb9822.tar.gz
Update to version 111-2.
Daemon args are broken. Submitted patch upstream, added patch here while it gets addressed.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
-rw-r--r--main.patch38
-rw-r--r--nvidia-fallback.service10
4 files changed, 49 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91d57d54b2fc..aaa087ca168c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = system76-power
pkgdesc = System76 Power Management
- pkgver = 100
- pkgrel = 1
+ pkgver = 111
+ pkgrel = 2
url = https://github.com/pop-os/system76-power
install = system76-power.install
arch = any
@@ -10,10 +10,12 @@ pkgbase = system76-power
depends = dbus
depends = systemd
depends = system76-dkms
- source = system76::git+https://github.com/pop-os/system76-power.git#commit=ad63c6302c5b5c77a2d9aa2fe4d96f93aac3e563
+ source = system76::git+https://github.com/pop-os/system76-power.git#commit=7f5de18038c1deb40416e365fd2078ca957ca579
source = graphics.patch
+ source = main.patch
sha1sums = SKIP
sha1sums = e486644709099b6348dc96d5f468ae289840dade
+ sha1sums = 84d590e0f15ac601a74ab09ac7206a62c81edb84
pkgname = system76-power
diff --git a/PKGBUILD b/PKGBUILD
index f6cc8b12c4c6..4bd514f175e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_pkgname=system76
_pkgbase=system76-power
pkgname=system76-power
-pkgver=100
-pkgrel=1
+pkgver=111
+pkgrel=2
pkgdesc="System76 Power Management"
arch=('any')
url="https://github.com/pop-os/system76-power"
@@ -17,12 +17,14 @@ depends=(
)
makedepends=('rust')
source=(
- 'system76::git+https://github.com/pop-os/system76-power.git#commit=ad63c6302c5b5c77a2d9aa2fe4d96f93aac3e563'
+ 'system76::git+https://github.com/pop-os/system76-power.git#commit=7f5de18038c1deb40416e365fd2078ca957ca579'
'graphics.patch'
+ 'main.patch'
)
sha1sums=(
'SKIP'
'e486644709099b6348dc96d5f468ae289840dade'
+ '84d590e0f15ac601a74ab09ac7206a62c81edb84'
)
pkgver() {
@@ -33,6 +35,7 @@ pkgver() {
build() {
cd ${startdir}
patch -p0 < ${startdir}/graphics.patch
+ patch -p0 < ${startdir}/main.patch
cd ${srcdir}/${_pkgname}
diff --git a/main.patch b/main.patch
new file mode 100644
index 000000000000..fda09c86b85e
--- /dev/null
+++ b/main.patch
@@ -0,0 +1,38 @@
+--- src/system76/src/main.rs 2018-09-21 21:38:37.639982440 -0700
++++ src/system76/src/main.rs.new 2018-09-21 21:38:34.933315808 -0700
+@@ -110,22 +110,21 @@
+ )
+ )
+ .get_matches();
+-
+- if let Err(why) = logging::setup_logging(
+- if matches.is_present("verbose") {
+- LevelFilter::Debug
+- } else if matches.is_present("quiet") {
+- LevelFilter::Off
+- } else {
+- LevelFilter::Info
+- }
+- ) {
+- eprintln!("failed to set up logging: {}", why);
+- process::exit(1);
+- }
+
+ let res = match matches.subcommand() {
+- ("daemon", Some(_matches)) => {
++ ("daemon", Some(matches)) => {
++ if let Err(why) = logging::setup_logging(
++ if matches.is_present("verbose") {
++ LevelFilter::Debug
++ } else if matches.is_present("quiet") {
++ LevelFilter::Off
++ } else {
++ LevelFilter::Info
++ }
++ ) {
++ eprintln!("failed to set up logging: {}", why);
++ process::exit(1);
++ }
+ if unsafe { libc::geteuid() } == 0 {
+ daemon::daemon(matches.is_present("experimental"))
+ } else {
diff --git a/nvidia-fallback.service b/nvidia-fallback.service
deleted file mode 100644
index 14cf6e884bd6..000000000000
--- a/nvidia-fallback.service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=Dummy service required by system76-power
-
-[Service]
-Type=oneshot
-RemainAfterExit=yes
-ExecStart=/bin/sh -c "echo 'Luke, I am your father' > /dev/null"
-
-[Install]
-WantedBy=multi-user.target