summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancisco Soto2018-08-02 15:44:11 -0700
committerFrancisco Soto2018-08-02 15:44:11 -0700
commit88d1cfd368b45306fbaa8ddeba0db8f21677f1cf (patch)
tree06ce4242e1e48843610abe3a7d0eac1e2b2af428
parent68a4e4b9173ab5529dde3c53c327c9075983f4ec (diff)
downloadaur-88d1cfd368b45306fbaa8ddeba0db8f21677f1cf.tar.gz
v75-2 arch doesn't really need to recreate initramfs for this.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--graphics.patch30
3 files changed, 26 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 719a68dc7c81..dca0504709d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = system76-power
pkgdesc = System76 Power Management
pkgver = 75
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/pop-os/system76-power
install = system76-power.install
arch = any
@@ -14,7 +14,7 @@ pkgbase = system76-power
source = graphics.patch
source = nvidia-fallback.service
sha1sums = SKIP
- sha1sums = 81feb9123571447e5cd66fc0265798ed14137cee
+ sha1sums = da260fc98072a5eabb0adea71674337c55044b1d
sha1sums = 5a81fb98c76cab0cd6e958d6776fca852c5ee4e2
pkgname = system76-power
diff --git a/PKGBUILD b/PKGBUILD
index e9e335ff84bf..578c72116a2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _pkgname=system76
_pkgbase=system76-power
pkgname=system76-power
pkgver=75
-pkgrel=1
+pkgrel=2
pkgdesc="System76 Power Management"
arch=('any')
url="https://github.com/pop-os/system76-power"
@@ -23,7 +23,7 @@ source=(
)
sha1sums=(
'SKIP'
- '81feb9123571447e5cd66fc0265798ed14137cee'
+ 'da260fc98072a5eabb0adea71674337c55044b1d'
'5a81fb98c76cab0cd6e958d6776fca852c5ee4e2'
)
diff --git a/graphics.patch b/graphics.patch
index 01c3e45e477c..22d3ddec75be 100644
--- a/graphics.patch
+++ b/graphics.patch
@@ -1,5 +1,5 @@
---- src/system76/src/graphics.rs 2018-07-14 17:12:09.993043915 -0700
-+++ src/system76/src/graphics.rs.new 2018-07-14 17:12:06.843043959 -0700
+--- src/system76/src/graphics.rs 2018-08-02 15:35:01.827659700 -0700
++++ src/system76/src/graphics.rs.new 2018-08-02 15:34:54.020993125 -0700
@@ -12,10 +12,10 @@
blacklist nvidia
blacklist nvidia-drm
@@ -15,12 +15,26 @@
"#;
pub struct Graphics {
-@@ -136,7 +136,7 @@
+@@ -135,14 +135,14 @@
+ }
}
- eprintln!("Updating initramfs");
+- eprintln!("Updating initramfs");
- let status = process::Command::new("update-initramfs").arg("-u").status()?;
-+ let status = process::Command::new("mkinitcpio").arg("-p").arg("linux").status()?;
- if ! status.success() {
- return Err(io::Error::new(
- io::ErrorKind::Other,
+- if ! status.success() {
+- return Err(io::Error::new(
+- io::ErrorKind::Other,
+- format!("update-initramfs: failed with {}", status)
+- ));
+- }
++ // eprintln!("Updating initramfs");
++ // let status = process::Command::new("update-initramfs").arg("-u").status()?;
++ // if ! status.success() {
++ // return Err(io::Error::new(
++ // io::ErrorKind::Other,
++ // format!("update-initramfs: failed with {}", status)
++ // ));
++ // }
+
+ Ok(())
+ } else {