summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorshironeko2021-11-02 18:41:40 -0400
committershironeko2021-11-02 18:41:40 -0400
commit8d32936320b1468dd2afb8308cc4b31aabb826ab (patch)
treebab2a8888991f61ef766a1bd440bfe3563213a06
parent3c42262998387cfcd47f49130053f3aae1f93149 (diff)
downloadaur-8d32936320b1468dd2afb8308cc4b31aabb826ab.tar.gz
update to 1.1.19
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
-rw-r--r--makefile.patch8
-rw-r--r--rust-toolchain1
-rw-r--r--use-mkinitcpio.patch10
5 files changed, 20 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1deaac086c0..daa3caba05e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = system76-power
pkgdesc = System76 Power Management
- pkgver = 1.1.18
+ pkgver = 1.1.19
pkgrel = 1
url = https://github.com/pop-os/system76-power
install = system76-power.install
@@ -13,13 +13,11 @@ pkgbase = system76-power
optdepends = system76-acpi-dkms: some systems might need this driver
optdepends = system76-dkms: some systems might need this driver
optdepends = system76-io-dkms: some systems might need this driver
- source = https://github.com/pop-os/system76-power/archive/1.1.18.tar.gz
+ source = https://github.com/pop-os/system76-power/archive/1.1.19.tar.gz
source = use-mkinitcpio.patch
source = makefile.patch
- source = rust-toolchain
- sha256sums = 7a6b8b18b28948808b3c51f732c42e72797f8eddd79fa57f4285689087d781cd
- sha256sums = 2ead269c71919c220a7880b0036c6d62aadeae3d6cde769029784d3565686539
- sha256sums = 97deb1f9cf6a312e8378bb96a4a83dae2498a4936c130e2ef5b125d13b92bb65
- sha256sums = f6a0b9759d1af128dd09bb3f49812c052c89168e7b159e6d269036a2faba3260
+ sha256sums = eb369011f45dd0b8869f032d8b6aad56e290329f312a7ad602adf2a133baa709
+ sha256sums = a6f45126461f22b47ac9671280e2cf2fbd52e389642d8dd865844bf2b7d43715
+ sha256sums = 61f8a26463527404b55bb7ee5dc18d909ad44bf56ac743ec8b081324c0def1e5
pkgname = system76-power
diff --git a/PKGBUILD b/PKGBUILD
index 9b743af2d4db..8f16b22561e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: tleydxdy <shironeko(at)waifu(dot)club>
pkgname=system76-power
-pkgver=1.1.18
+pkgver=1.1.19
pkgrel=1
pkgdesc="System76 Power Management"
arch=('any')
@@ -23,12 +23,10 @@ source=(
"https://github.com/pop-os/${pkgname}/archive/${pkgver}.tar.gz"
'use-mkinitcpio.patch'
'makefile.patch'
-'rust-toolchain'
)
-sha256sums=('7a6b8b18b28948808b3c51f732c42e72797f8eddd79fa57f4285689087d781cd'
- '2ead269c71919c220a7880b0036c6d62aadeae3d6cde769029784d3565686539'
- '97deb1f9cf6a312e8378bb96a4a83dae2498a4936c130e2ef5b125d13b92bb65'
- 'f6a0b9759d1af128dd09bb3f49812c052c89168e7b159e6d269036a2faba3260')
+sha256sums=('eb369011f45dd0b8869f032d8b6aad56e290329f312a7ad602adf2a133baa709'
+ 'a6f45126461f22b47ac9671280e2cf2fbd52e389642d8dd865844bf2b7d43715'
+ '61f8a26463527404b55bb7ee5dc18d909ad44bf56ac743ec8b081324c0def1e5')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -37,8 +35,6 @@ prepare() {
patch --no-backup-if-mismatch -Np1 -i "${srcdir}"/use-mkinitcpio.patch
# fix makefile
patch --no-backup-if-mismatch -Np1 -i "${srcdir}"/makefile.patch
-
- cp "${srcdir}"/rust-toolchain .
}
build() {
diff --git a/makefile.patch b/makefile.patch
index c60736d50d62..2cc2bd6d94b1 100644
--- a/makefile.patch
+++ b/makefile.patch
@@ -1,11 +1,15 @@
--- a/Makefile
+++ b/Makefile
-@@ -35,7 +35,7 @@ distclean:
+@@ -36,7 +36,7 @@ distclean:
install: all
install -D -m 0755 "target/release/$(BIN)" "$(DESTDIR)$(bindir)/$(BIN)"
+- install -D -m 0644 "data/$(RDD).xml" "$(DESTDIR)$(sysconfdir)/dbus-1/interfaces/$(RDD).xml"
- install -D -m 0644 "data/$(BIN).conf" "$(DESTDIR)$(sysconfdir)/dbus-1/system.d/$(BIN).conf"
+- install -D -m 0644 "debian/$(BIN).service" "$(DESTDIR)$(sysconfdir)/systemd/system/$(BIN).service"
++ install -D -m 0644 "data/$(RDD).xml" "$(DESTDIR)$(datadir)/dbus-1/interfaces/$(RDD).xml"
+ install -D -m 0644 "data/$(BIN).conf" "$(DESTDIR)$(datadir)/dbus-1/system.d/$(BIN).conf"
- install -D -m 0644 "debian/$(BIN).service" "$(DESTDIR)$(sysconfdir)/systemd/system/$(BIN).service"
++ install -D -m 0644 "debian/$(BIN).service" "$(DESTDIR)$(libdir)/systemd/system/$(BIN).service"
install -D -m 0644 "data/$(POLICY).policy" $(DESTDIR)$(datadir)/polkit-1/actions/$(POLICY).policy
+ uninstall:
diff --git a/rust-toolchain b/rust-toolchain
deleted file mode 100644
index ba0a719118ce..000000000000
--- a/rust-toolchain
+++ /dev/null
@@ -1 +0,0 @@
-1.51.0
diff --git a/use-mkinitcpio.patch b/use-mkinitcpio.patch
index fee4a47c8677..f40cd0416cb7 100644
--- a/use-mkinitcpio.patch
+++ b/use-mkinitcpio.patch
@@ -1,15 +1,15 @@
--- a/src/graphics.rs
+++ b/src/graphics.rs
-@@ -76,7 +76,7 @@ pub enum GraphicsDeviceError {
+@@ -80,7 +80,7 @@ pub enum GraphicsDeviceError {
SysFs(io::Error),
- #[error(display = "failed to unbind {} on PCI driver {}: {}", func, driver, why)]
+ #[error("failed to unbind {} on PCI driver {}: {}", func, driver, why)]
Unbind { func: String, driver: String, why: io::Error },
-- #[error(display = "update-initramfs failed with {} status", _0)]
-+ #[error(display = "failed to update initramfs: exit status {}", _0)]
+- #[error("update-initramfs failed with {} status", _0)]
++ #[error("failed to update initramfs: exit status {}", _0)]
UpdateInitramfs(ExitStatus),
}
-@@ -423,9 +423,9 @@ impl Graphics {
+@@ -427,9 +427,9 @@ impl Graphics {
}
log::info!("Updating initramfs");