summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortleydxdy2021-07-14 15:50:08 -0400
committertleydxdy2021-07-14 15:50:08 -0400
commita9c8e7b2efb25b661cd1260985b4d8fb1ad2a3e8 (patch)
tree309607a46baa24a401f5ef2214986196213a1171
parent236de49a9ff44bd486597c5890292485288a152c (diff)
downloadaur-a9c8e7b2efb25b661cd1260985b4d8fb1ad2a3e8.tar.gz
update to 1.1.17
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
-rw-r--r--use-mkinitcpio.patch10
3 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9caaec98b2a..ba06c6689614 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = system76-power
pkgdesc = System76 Power Management
- pkgver = 1.1.16
- pkgrel = 5
+ pkgver = 1.1.17
+ pkgrel = 1
url = https://github.com/pop-os/system76-power
install = system76-power.install
arch = any
@@ -14,11 +14,11 @@ pkgbase = system76-power
optdepends = system76-acpi-dkms: some systems might need this driver
optdepends = system76-dkms: some systems might need this driver
optdepends = system76-io-dkms: some systems might need this driver
- source = https://github.com/pop-os/system76-power/archive/1.1.16.tar.gz
+ source = https://github.com/pop-os/system76-power/archive/1.1.17.tar.gz
source = use-mkinitcpio.patch
source = makefile.patch
- sha256sums = 56b33e6d41dd07892b73aca8d1da32a552bf644e986c657abbddd83e2071ea79
- sha256sums = 6d59cb091858b65a0ad6682dda29ec1d970066f67a7b50430960989f6c428891
+ sha256sums = d817e22047e41110ce2520f792ee5eae55220ba6d5fc4138a73040ebeb06e9b5
+ sha256sums = 2ead269c71919c220a7880b0036c6d62aadeae3d6cde769029784d3565686539
sha256sums = 97deb1f9cf6a312e8378bb96a4a83dae2498a4936c130e2ef5b125d13b92bb65
pkgname = system76-power
diff --git a/PKGBUILD b/PKGBUILD
index 094d4042eb19..1b4eeac4b07d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: tleydxdy <shironeko(at)waifu(dot)club>
pkgname=system76-power
-pkgver=1.1.16
-pkgrel=5
+pkgver=1.1.17
+pkgrel=1
pkgdesc="System76 Power Management"
arch=('any')
url="https://github.com/pop-os/system76-power"
@@ -26,8 +26,8 @@ source=(
'makefile.patch'
)
sha256sums=(
-'56b33e6d41dd07892b73aca8d1da32a552bf644e986c657abbddd83e2071ea79'
-'6d59cb091858b65a0ad6682dda29ec1d970066f67a7b50430960989f6c428891'
+'d817e22047e41110ce2520f792ee5eae55220ba6d5fc4138a73040ebeb06e9b5'
+'2ead269c71919c220a7880b0036c6d62aadeae3d6cde769029784d3565686539'
'97deb1f9cf6a312e8378bb96a4a83dae2498a4936c130e2ef5b125d13b92bb65'
)
diff --git a/use-mkinitcpio.patch b/use-mkinitcpio.patch
index 68eac9504b5d..fee4a47c8677 100644
--- a/use-mkinitcpio.patch
+++ b/use-mkinitcpio.patch
@@ -1,18 +1,18 @@
--- a/src/graphics.rs
+++ b/src/graphics.rs
-@@ -58,7 +58,7 @@ pub enum GraphicsDeviceError {
- Rescan(io::Error),
+@@ -76,7 +76,7 @@ pub enum GraphicsDeviceError {
+ SysFs(io::Error),
#[error(display = "failed to unbind {} on PCI driver {}: {}", func, driver, why)]
Unbind { func: String, driver: String, why: io::Error },
- #[error(display = "update-initramfs failed with {} status", _0)]
-+ #[error(display = "mkinitcpio failed with {} status", _0)]
++ #[error(display = "failed to update initramfs: exit status {}", _0)]
UpdateInitramfs(ExitStatus),
}
-@@ -295,9 +295,9 @@ impl Graphics {
+@@ -423,9 +423,9 @@ impl Graphics {
}
- info!("Updating initramfs");
+ log::info!("Updating initramfs");
- const UPDATE_INITRAMFS_CMD: &str = "update-initramfs";
+ const UPDATE_INITRAMFS_CMD: &str = "mkinitcpio";
let status = process::Command::new(UPDATE_INITRAMFS_CMD)