summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancisco Soto2018-07-06 08:49:41 -0700
committerFrancisco Soto2018-07-06 08:49:41 -0700
commitba418374e592d0c31ab7a6db95dd330830c6171e (patch)
tree524cd24c506648d25ce74c58bcee960895a38c01
parentcceb5b182a7b8483a417c17af56ffbacfccdd2c4 (diff)
downloadaur-ba418374e592d0c31ab7a6db95dd330830c6171e.tar.gz
Use new system76-dkms package.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--system76-power.install14
3 files changed, 15 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b4f264a6e11..cba797ed7461 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = system76-power
pkgdesc = System76 Power Management
pkgver = 72
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/pop-os/system76-power
install = system76-power.install
arch = any
@@ -9,7 +9,7 @@ pkgbase = system76-power
makedepends = rust
depends = dbus
depends = systemd
- depends = system76-dkms-git
+ depends = system76-dkms
source = system76::git+https://github.com/pop-os/system76-power.git#commit=038f0991aa4f351dcab55e06fc979fd929a833cc
source = graphics.patch
source = nvidia-fallback.service
diff --git a/PKGBUILD b/PKGBUILD
index bde07bfbe62b..c986ae457eb8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _pkgname=system76
_pkgbase=system76-power
pkgname=system76-power
pkgver=72
-pkgrel=1
+pkgrel=2
pkgdesc="System76 Power Management"
arch=('any')
url="https://github.com/pop-os/system76-power"
@@ -13,7 +13,7 @@ install="${pkgname}.install"
depends=(
'dbus'
'systemd'
- 'system76-dkms-git'
+ 'system76-dkms'
)
makedepends=('rust')
source=(
diff --git a/system76-power.install b/system76-power.install
index a9f9da66f5aa..2cfa37c14edd 100644
--- a/system76-power.install
+++ b/system76-power.install
@@ -1,12 +1,20 @@
_services="system76-power.service nvidia-fallback.service"
_stop_services() {
- /usr/bin/systemctl stop $_services >/dev/null 2>&1
+ for service in $_services; do
+ if /usr/bin/systemctl -q is-active $service >/dev/null 2>&1; then
+ /usr/bin/systemctl stop $service >/dev/null 2>&1
+ fi
+ done
}
_disable_services() {
- /usr/bin/systemctl disable $_services >/dev/null 2>&1
- /usr/bin/systemctl reset-failed $_services >/dev/null 2>&1
+ for service in $_services; do
+ if /usr/bin/systemctl -q is-enabled $service >/dev/null 2>&1; then
+ /usr/bin/systemctl disable $service >/dev/null 2>&1
+ /usr/bin/systemctl reset-failed $service >/dev/null 2>&1
+ fi
+ done
}
_restore_services() {