summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortleydxdy2021-04-09 08:02:15 +0800
committertleydxdy2021-04-09 08:03:45 +0800
commitd9f743b058eb5bb91062ae4d7f3163a9aecd8e65 (patch)
treedb52ee6b29289860bd448b5562eab1de1249f3bb
parent9e8c2c22d948e50df9c2463ae1c575338de65a16 (diff)
downloadaur-d9f743b058eb5bb91062ae4d7f3163a9aecd8e65.tar.gz
update to 1.0.1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
-rw-r--r--graphics.patch33
-rw-r--r--system76-power.install2
4 files changed, 6 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f43a25712fdd..713dc37be618 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = system76-power
pkgdesc = System76 Power Management
- pkgver = 135
+ pkgver = 1.0.1
pkgrel = 1
url = https://github.com/pop-os/system76-power
install = system76-power.install
@@ -10,10 +10,7 @@ pkgbase = system76-power
depends = dbus
depends = systemd
depends = system76-dkms
- source = system76::git+https://github.com/pop-os/system76-power.git#commit=d861dfd6553e68d214d9cbade99b334e347d0d16
- source = graphics.patch
+ source = system76::git+https://github.com/pop-os/system76-power.git#commit=de596615d3d1037f2377f3736a371b922e9bf0e7
sha1sums = SKIP
- sha1sums = e486644709099b6348dc96d5f468ae289840dade
pkgname = system76-power
-
diff --git a/PKGBUILD b/PKGBUILD
index 243558539df8..31495df6002b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: Francisco Soto <ebobby(at)ebobby(dot)org>
+# Maintainer: tleydxdy <shironeko(at)waifu(dot)club>
_pkgname=system76
_pkgbase=system76-power
pkgname=system76-power
-pkgver=135
+pkgver=1.0.1
pkgrel=1
pkgdesc="System76 Power Management"
arch=('any')
@@ -17,23 +17,13 @@ depends=(
)
makedepends=('rust')
source=(
- 'system76::git+https://github.com/pop-os/system76-power.git#commit=d861dfd6553e68d214d9cbade99b334e347d0d16'
- 'graphics.patch'
+ 'system76::git+https://github.com/pop-os/system76-power.git#commit=de596615d3d1037f2377f3736a371b922e9bf0e7'
)
sha1sums=(
'SKIP'
- 'e486644709099b6348dc96d5f468ae289840dade'
)
-pkgver() {
- cd ${srcdir}/${_pkgname}
- git rev-list --count HEAD
-}
-
build() {
- cd ${startdir}
- patch -p0 < ${startdir}/graphics.patch
-
cd ${srcdir}/${_pkgname}
# Build and install base package
diff --git a/graphics.patch b/graphics.patch
deleted file mode 100644
index 8937050a20de..000000000000
--- a/graphics.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- src/system76/src/graphics.rs 2018-09-11 20:08:40.269995504 -0700
-+++ src/system76/src/graphics.rs.new 2018-09-11 20:10:14.403327798 -0700
-@@ -12,10 +12,10 @@
- blacklist nvidia
- blacklist nvidia-drm
- blacklist nvidia-modeset
--alias nouveau off
--alias nvidia off
--alias nvidia-drm off
--alias nvidia-modeset off
-+#alias nouveau off
-+#alias nvidia off
-+#alias nvidia-drm off
-+#alias nvidia-modeset off
- "#;
-
- pub struct Graphics {
-@@ -135,12 +135,12 @@
- }
- }
-
-- info!("Updating initramfs");
-- let status = process::Command::new("update-initramfs").arg("-u").status()?;
-+ info!("Updating mkinitcpio");
-+ let status = process::Command::new("mkinitcpio").arg("-P").status()?;
- if ! status.success() {
- return Err(io::Error::new(
- io::ErrorKind::Other,
-- format!("update-initramfs: failed with {}", status)
-+ format!("mkinitcpio: failed with {}", status)
- ));
- }
-
diff --git a/system76-power.install b/system76-power.install
index 2cfa37c14edd..20d9b7467ca9 100644
--- a/system76-power.install
+++ b/system76-power.install
@@ -1,4 +1,4 @@
-_services="system76-power.service nvidia-fallback.service"
+_services="system76-power.service"
_stop_services() {
for service in $_services; do