summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmytro Kostiuchenko2015-07-06 17:12:07 +0200
committerDmytro Kostiuchenko2015-07-06 17:12:07 +0200
commit4e66052b63033ad787026477dc86ff0cbf0e694d (patch)
treeb1e99f1f289a533c8f3b5b2b6d9ad15298551f83
downloadaur-systemd-kdemodules-git.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rwxr-xr-xPKGBUILD40
-rw-r--r--systemd-kdemodules.install18
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f581fa6da7ff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = systemd-kdemodules-git
+ pkgdesc = systemd units to load KDE modules in your custom environment
+ pkgver = 20130310
+ pkgrel = 1
+ url = https://github.com/edio/systemd-kdemodules
+ install = systemd-kdemodules.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = systemd
+ depends = dbus
+ depends = kdebase-runtime
+
+pkgname = systemd-kdemodules-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..cfed9c5bc881
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: edio <edio at archlinux dot us>
+
+pkgname=systemd-kdemodules-git
+pkgver=20130310
+pkgrel=1
+pkgdesc="systemd units to load KDE modules in your custom environment"
+arch=('any')
+url="https://github.com/edio/systemd-kdemodules"
+license=('GPL3')
+depends=('systemd' 'dbus' 'kdebase-runtime')
+makedepends=('git')
+install='systemd-kdemodules.install'
+
+_gitroot="https://github.com/edio/systemd-kdemodules.git"
+_gitname="systemd-kdemodules"
+
+build () {
+ cd "${srcdir}"
+
+ msg "Connecting to the GIT server..."
+ if [ -d ${_gitname} ] ; then
+ cd ${_gitname}
+ git pull origin
+ msg "The local files are updated..."
+ else
+ git clone ${_gitroot} ${_gitname}
+ cd ${_gitname}
+ fi
+ msg "GIT checkout done."
+}
+
+
+package() {
+ cd "${srcdir}"/${_gitname}
+ install -d ${pkgdir}/usr/lib/systemd/user
+ cp *.service ${pkgdir}/usr/lib/systemd/user/
+ cp *.target ${pkgdir}/usr/lib/systemd/user/
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/systemd-kdemodules.install b/systemd-kdemodules.install
new file mode 100644
index 000000000000..055183f65108
--- /dev/null
+++ b/systemd-kdemodules.install
@@ -0,0 +1,18 @@
+post_install() {
+ usage
+}
+post_upgrade() {
+ usage
+}
+
+usage() {
+ echo -n "========================"
+ echo -e "\nAdd to your ~/.xinitrc\n"
+ echo -e "\tkcminit kcmkded"
+ echo -e "\t/usr/lib/systemd/systemd --user &"
+ echo -e "\nAdd to your default target\n"
+ echo -e "\tWants=kcm.target"
+ echo -e "\nEnable kcm modules\n"
+ echo -e "\tsystemctl --user enable kcm@keyboard"
+ echo ""
+}