summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorideal2019-02-10 16:21:21 +0800
committerideal2019-02-10 16:25:25 +0800
commit47dac5cd10ad3eb56b19102a5ad110bbc2ffb948 (patch)
treec3c4594481eba26c4b7dac28caf25c86bb328d4c
parentdcd4ed140e1f8a30659c9d2e447dccc3206b9dde (diff)
downloadaur-47dac5cd10ad3eb56b19102a5ad110bbc2ffb948.tar.gz
remove patch as it is not needed now.
see https://sourceware.org/git/?p=systemtap.git;a=commit;h=f90ca30963e167973d59ce71a0af79ac8a33f18f
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--remove-install-exec-hook.patch76
3 files changed, 4 insertions, 89 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e80842f01a69..dad524704ce5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = systemtap-git
pkgdesc = provides infrastructure to simplify the gathering of information about the running Linux system.
- pkgver = 4.0.88.g905865da1
+ pkgver = 4.0.102.g1832b8f51
pkgrel = 1
url = https://sourceware.org/systemtap/
install = systemtap.install
@@ -22,9 +22,7 @@ pkgbase = systemtap-git
provides = systemtap=4.0
conflicts = systemtap
source = git+https://sourceware.org/git/systemtap.git
- source = remove-install-exec-hook.patch
md5sums = SKIP
- md5sums = 6db56245ab316134c9a487e16ea52084
pkgname = systemtap-git
diff --git a/PKGBUILD b/PKGBUILD
index a0c0b637d6af..4036ab914422 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Shang Yuanchun <idealities@gmail.com>
pkgname=systemtap-git
-pkgver=4.0.88.g905865da1
+pkgver=4.0.102.g1832b8f51
pkgrel=1
pkgdesc="provides infrastructure to simplify the gathering of information about the running Linux system."
url="https://sourceware.org/systemtap/"
@@ -15,10 +15,8 @@ provides=(systemtap=4.0)
conflicts=(systemtap)
_gitroot=https://sourceware.org/git/systemtap.git
_gitname=systemtap
-source=("git+$_gitroot"
- remove-install-exec-hook.patch)
-md5sums=('SKIP'
- '6db56245ab316134c9a487e16ea52084')
+source=("git+$_gitroot")
+md5sums=('SKIP')
install=systemtap.install
pkgver() {
@@ -26,11 +24,6 @@ pkgver() {
git describe | sed 's/release-//;s/-/./g'
}
-prepare() {
- cd "$srcdir/$_gitname"
- patch -p1 -i "$srcdir"/remove-install-exec-hook.patch
-}
-
build() {
cd "$srcdir/$_gitname"
msg "Starting make..."
diff --git a/remove-install-exec-hook.patch b/remove-install-exec-hook.patch
deleted file mode 100644
index 84534b3a50e6..000000000000
--- a/remove-install-exec-hook.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-diff --git a/stapbpf/Makefile.am b/stapbpf/Makefile.am
-index fa2035dab..43dc35ab3 100644
---- a/stapbpf/Makefile.am
-+++ b/stapbpf/Makefile.am
-@@ -39,13 +39,4 @@ BUILT_SOURCES += git_version.stamp
- git_version.stamp ../git_version.h:
- $(MAKE) -C .. $(notdir $@)
-
--# Why the "id -u" condition? This way, an unprivileged user can run
--# make install, and have "sudo stap ...." or "sudo stapbpf ...." work later.
--install-exec-hook:
-- if [ `id -u` -eq 0 ]; then \
-- getent group stapusr >/dev/null || groupadd -g 156 -r stapusr 2>/dev/null || groupadd -r stapusr; \
-- getent group stapusr >/dev/null \
-- && chgrp stapusr "$(DESTDIR)$(bindir)/stapbpf" \
-- && chmod 04110 "$(DESTDIR)$(bindir)/stapbpf"; \
-- fi
- endif
-diff --git a/stapbpf/Makefile.in b/stapbpf/Makefile.in
-index f7f20b6ee..e00b239b6 100644
---- a/stapbpf/Makefile.in
-+++ b/stapbpf/Makefile.in
-@@ -845,16 +845,6 @@ uninstall-man: uninstall-man8
- @HAVE_BPF_DECLS_TRUE@git_version.stamp ../git_version.h:
- @HAVE_BPF_DECLS_TRUE@ $(MAKE) -C .. $(notdir $@)
-
--# Why the "id -u" condition? This way, an unprivileged user can run
--# make install, and have "sudo stap ...." or "sudo stapbpf ...." work later.
--@HAVE_BPF_DECLS_TRUE@install-exec-hook:
--@HAVE_BPF_DECLS_TRUE@ if [ `id -u` -eq 0 ]; then \
--@HAVE_BPF_DECLS_TRUE@ getent group stapusr >/dev/null || groupadd -g 156 -r stapusr 2>/dev/null || groupadd -r stapusr; \
--@HAVE_BPF_DECLS_TRUE@ getent group stapusr >/dev/null \
--@HAVE_BPF_DECLS_TRUE@ && chgrp stapusr "$(DESTDIR)$(bindir)/stapbpf" \
--@HAVE_BPF_DECLS_TRUE@ && chmod 04110 "$(DESTDIR)$(bindir)/stapbpf"; \
--@HAVE_BPF_DECLS_TRUE@ fi
--
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
- .NOEXPORT:
-diff --git a/staprun/Makefile.am b/staprun/Makefile.am
-index 73ddc41ff..d8779f634 100644
---- a/staprun/Makefile.am
-+++ b/staprun/Makefile.am
-@@ -73,12 +73,3 @@ BUILT_SOURCES += git_version.stamp
- git_version.stamp ../git_version.h:
- $(MAKE) -C .. $(notdir $@)
-
--
--# Why the "id -u" condition? This way, an unprivileged user can run
--# make install, and have "sudo stap ...." or "sudo staprun ...." work later.
--install-exec-hook:
-- if [ `id -u` -eq 0 ]; then \
-- getent group stapusr >/dev/null || groupadd -g 156 -r stapusr 2>/dev/null || groupadd -r stapusr; \
-- getent group stapusr >/dev/null && chgrp stapusr "$(DESTDIR)$(bindir)/staprun"; \
-- chmod 04110 "$(DESTDIR)$(bindir)/staprun"; \
-- fi
-diff --git a/staprun/Makefile.in b/staprun/Makefile.in
-index 6cb3966a5..f9da649d4 100644
---- a/staprun/Makefile.in
-+++ b/staprun/Makefile.in
-@@ -1158,15 +1158,6 @@ uninstall-man: uninstall-man8
- git_version.stamp ../git_version.h:
- $(MAKE) -C .. $(notdir $@)
-
--# Why the "id -u" condition? This way, an unprivileged user can run
--# make install, and have "sudo stap ...." or "sudo staprun ...." work later.
--install-exec-hook:
-- if [ `id -u` -eq 0 ]; then \
-- getent group stapusr >/dev/null || groupadd -g 156 -r stapusr 2>/dev/null || groupadd -r stapusr; \
-- getent group stapusr >/dev/null && chgrp stapusr "$(DESTDIR)$(bindir)/staprun"; \
-- chmod 04110 "$(DESTDIR)$(bindir)/staprun"; \
-- fi
--
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
- .NOEXPORT: