summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilydjwg2016-09-10 11:06:36 +0800
committerlilydjwg2016-09-10 11:07:31 +0800
commitda741bc52c6492a66abccbed8f11e85a3f4ede8c (patch)
tree8f8b2d40e359270ecbf85f9ea42d2573a7dc2ef9
parent0cdb80d68de4e9832db12b52895221db5f741b5f (diff)
downloadaur-da741bc52c6492a66abccbed8f11e85a3f4ede8c.tar.gz
create groups; use python instead of python2; other updates
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD21
-rw-r--r--systemtap.install19
3 files changed, 38 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa1b2e584820..d5b18fd249fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,23 @@
# Generated by mksrcinfo v8
-# Sun Aug 21 02:32:33 UTC 2016
+# Sat Sep 10 03:07:28 UTC 2016
pkgbase = systemtap-git
pkgdesc = SystemTap provides free software (GPL) infrastructure to simplify the gathering of information about the running Linux system.
- pkgver = 3.0.213.gcc72c6a
+ pkgver = 3.0.240.g2c58b79
pkgrel = 1
url = http://sourceware.org/systemtap/
+ install = systemtap.install
arch = i686
arch = x86_64
license = GPL
makedepends = git
depends = elfutils
depends = nss
- depends = python2
+ depends = python
depends = avahi
optdepends = sqlite3
optdepends = linux-fedora: for debug enabled kernel
optdepends = linux-lily-debug: for debug enabled kernel
- provides = systemtap=2.3
+ provides = systemtap=3.0
conflicts = systemtap
source = git+git://sourceware.org/git/systemtap.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 9c4bb18340b0..21a0c0c8c1d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
# Maintainer: lilydjwg <lilydjwg@gmail.com>
pkgname=systemtap-git
-pkgver=3.0.213.gcc72c6a
+pkgver=3.0.240.g2c58b79
pkgrel=1
pkgdesc="SystemTap provides free software (GPL) infrastructure to simplify the gathering of information about the running Linux system."
url="http://sourceware.org/systemtap/"
arch=('i686' 'x86_64')
license=('GPL')
-depends=('elfutils' 'nss' 'python2' 'avahi')
+depends=('elfutils' 'nss' 'python' 'avahi')
makedepends=('git')
optdepends=('sqlite3' 'linux-fedora: for debug enabled kernel' 'linux-lily-debug: for debug enabled kernel')
-provides=(systemtap=2.3)
+provides=(systemtap=3.0)
conflicts=(systemtap)
_gitroot=git://sourceware.org/git/systemtap.git
_gitname=systemtap
source=("git+$_gitroot")
-md5sums=(SKIP)
+md5sums=('SKIP')
+install=systemtap.install
pkgver() {
cd "$srcdir/$_gitname"
@@ -25,14 +26,20 @@ build() {
cd "$srcdir/$_gitname"
msg "Starting make..."
+ # docs failed to build
./configure --prefix=/usr --sysconfdir=/etc \
- --localstatedir=/var --libexecdir=/usr/lib
+ --localstatedir=/var --libexecdir=/usr/lib \
+ --with-python3 \
+ --disable-docs
make
}
package() {
cd "$srcdir/$_gitname"
make DESTDIR="${pkgdir}" install
- mv "${pkgdir}"/var/run "${pkgdir}"
- sed -i 's=#!/usr/bin/python.*=#!/usr/bin/python2=' "${pkgdir}/usr/bin/dtrace"
+ cd "${pkgdir}"
+ pushd var >/dev/null
+ rmdir -p run/stap-server log
+ popd >/dev/null
+ rmdir var
}
diff --git a/systemtap.install b/systemtap.install
new file mode 100644
index 000000000000..e9e6e982e2e6
--- /dev/null
+++ b/systemtap.install
@@ -0,0 +1,19 @@
+post_install() {
+ for _g in stapusr stapsys stapdev; do
+ getent group $_g >/dev/null || groupadd -r $_g
+ done
+ chgrp stapusr usr/bin/staprun
+ chmod 04110 usr/bin/staprun
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ userdel -rf archsocks
+ for _g in stapusr stapsys stapdev; do
+ groupdel $_g
+ done
+}
+