summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Kuc2020-05-24 13:09:33 +0100
committerMichael Kuc2020-05-24 13:09:33 +0100
commitdfe558d83278ff983dec14f2fd5d3c3e0d9cc5e7 (patch)
tree7a90f74f4357ecbe8472cf26ba3dd7d63d4261c6
downloadaur-t2b-git.tar.gz
Initial build from one-off-head.
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--CMakeLists.txt.patch14
-rw-r--r--PKGBUILD43
4 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7795175e623a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = t2b-git
+ pkgdesc = A wicked-powerful text macro language for building binary files.
+ pkgver = 1.0.0.r26.g2aa5c32
+ pkgrel = 1
+ epoch = 1
+ url = https://thosakwe.github.io/t2b/index.html
+ arch = x86_64
+ makedepends = cmake
+ provides = t2b
+ source = t2b::git+https://github.com/thosakwe/t2b.git#commit=2aa5c328dfe48dacdd97e4a09ce35783552b2476
+ source = CMakeLists.txt.patch
+ sha256sums = SKIP
+ sha256sums = 4879b124e17eb49dfc1944a41affb4c27676adfebdb7f183a433dcb7318b7795
+
+pkgname = t2b-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1bed2927b79c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/src
+/t2b
+/pkg
+/*.pkg.*
+
diff --git a/CMakeLists.txt.patch b/CMakeLists.txt.patch
new file mode 100644
index 000000000000..c11039d08742
--- /dev/null
+++ b/CMakeLists.txt.patch
@@ -0,0 +1,14 @@
+*** CMakeLists.txt 2020-05-24 11:52:04.720213445 +0100
+--- oCJU4.EDIT/CMakeLists.txt 2020-05-24 13:07:35.738432521 +0100
+***************
+*** 19,22 ****
+ RUNTIME DESTINATION bin
+ LIBRARY DESTINATION lib
+ ARCHIVE DESTINATION lib)
+! install(DIRECTORY include DESTINATION include)
+\ No newline at end of file
+--- 19,22 ----
+ RUNTIME DESTINATION bin
+ LIBRARY DESTINATION lib
+ ARCHIVE DESTINATION lib)
+! install(DIRECTORY include/ DESTINATION include)
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a13aa9c82b8d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Michael Kuc <michaelkuc6 at gmail dot com>
+_pkgname=t2b
+pkgname=${_pkgname}-git
+pkgver=1.0.0.r26.g2aa5c32
+pkgrel=1
+pkgdesc="A wicked-powerful text macro language for building binary files."
+arch=('x86_64')
+url="https://thosakwe.github.io/t2b/index.html"
+license=()
+depends=()
+makedepends=('cmake')
+provides=("${_pkgname}")
+conflicts=()
+epoch=1
+source=("${_pkgname}::git+https://github.com/thosakwe/t2b.git#commit=2aa5c328dfe48dacdd97e4a09ce35783552b2476" # HEAD breaks compilation.
+ 'CMakeLists.txt.patch')
+sha256sums=('SKIP'
+ '4879b124e17eb49dfc1944a41affb4c27676adfebdb7f183a433dcb7318b7795')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${srcdir}"
+ (cd "${_pkgname}" && patch -p0 < ../CMakeLists.txt.patch)
+ mkdir -p build
+ cd build
+ cmake -G 'Unix Makefiles' -DCMAKE_INSTALL_PREFIX=/usr "../${_pkgname}"
+}
+
+build() {
+ cd "${srcdir}/build"
+ cmake --build .
+}
+
+package() {
+ cd "${srcdir}/build"
+ make PREFIX=/usr DESTDIR="${pkgdir}/" install
+ install -m644 -D "${srcdir}/${_pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -m644 -D "${srcdir}/${_pkgname}/README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+}