diff options
author | Eric Berquist | 2016-02-17 16:31:04 -0500 |
---|---|---|
committer | Eric Berquist | 2016-02-17 16:31:04 -0500 |
commit | 9be310c5be899c62b23720bab120f847092801b9 (patch) | |
tree | 3eb5ef344b88efe1c35faac70eda45acf2663862 | |
parent | 37d4fb3b7246635cbb749868a9f3531278d31ff4 (diff) | |
download | aur-tachyon-opengl.tar.gz |
Add .gitignore and patch for OpenGL/X11 Makefile, even though it's redundant.
-rw-r--r-- | .SRCINFO | 6 | ||||
-rw-r--r-- | .gitignore | 7 | ||||
-rw-r--r-- | PKGBUILD | 10 | ||||
-rw-r--r-- | make_gl.patch | 26 |
4 files changed, 45 insertions, 4 deletions
@@ -1,7 +1,9 @@ +# Generated by mksrcinfo v8 +# Wed Feb 17 21:26:57 UTC 2016 pkgbase = tachyon-opengl pkgdesc = Parallel ray tracer (used as part of Visual Molecular Dynamics), OpenGL-enabled pkgver = 0.99b6 - pkgrel = 2 + pkgrel = 3 url = http://jedi.ks.uiuc.edu/~johns/raytracer/ arch = i686 arch = x86_64 @@ -14,9 +16,11 @@ pkgbase = tachyon-opengl source = http://jedi.ks.uiuc.edu/~johns/raytracer/files/0.99b6/tachyon-0.99b6.tar.gz source = make_arch.patch source = make_config.patch + source = make_gl.patch sha256sums = f4dcaf9c76a4f49310f56254390f9611c22e353947a1745a8c623e8bc8119b97 sha256sums = 935553f4a0553505dc4db9c22635072d9cf238988e1dbeee2df52a01e0953a1a sha256sums = c016bb5b0bc422c11bf53e93f7f9001fd742a53ab3d49affd1354bc3990391b3 + sha256sums = 0060bd52bad05e98a9709af4a84e758d17b376b4f7ab71e627f0aeeaf9e5f0e0 pkgname = tachyon-opengl diff --git a/.gitignore b/.gitignore new file mode 100644 index 000000000000..3effb6d1f312 --- /dev/null +++ b/.gitignore @@ -0,0 +1,7 @@ +# makepkg files +pkg/ +src/ +*.xz + +# source files +*.tar.gz @@ -5,7 +5,7 @@ pkgname=tachyon-opengl _pkgname=tachyon pkgver=0.99b6 -pkgrel=2 +pkgrel=3 pkgdesc="Parallel ray tracer (used as part of Visual Molecular Dynamics), OpenGL-enabled" arch=('i686' 'x86_64') url="http://jedi.ks.uiuc.edu/~johns/raytracer/" @@ -15,10 +15,12 @@ conflicts=('tachyon') options=(staticlibs) source=("http://jedi.ks.uiuc.edu/~johns/raytracer/files/${pkgver}/${_pkgname}-${pkgver}.tar.gz" "make_arch.patch" - "make_config.patch") + "make_config.patch" + "make_gl.patch") sha256sums=('f4dcaf9c76a4f49310f56254390f9611c22e353947a1745a8c623e8bc8119b97' '935553f4a0553505dc4db9c22635072d9cf238988e1dbeee2df52a01e0953a1a' - 'c016bb5b0bc422c11bf53e93f7f9001fd742a53ab3d49affd1354bc3990391b3') + 'c016bb5b0bc422c11bf53e93f7f9001fd742a53ab3d49affd1354bc3990391b3' + '0060bd52bad05e98a9709af4a84e758d17b376b4f7ab71e627f0aeeaf9e5f0e0') case "$CARCH" in "i686") _buildtype=linux-thr-ogl ;; @@ -31,6 +33,8 @@ prepare() { patch -i "${srcdir}/make_arch.patch" # enable JPEG and PNG support, plus GCC atomics patch -i "${srcdir}/make_config.patch" + # fix location of OpenGL and X11 headers/libraries + patch -i "${srcdir}/make_gl.patch" } build() { diff --git a/make_gl.patch b/make_gl.patch new file mode 100644 index 000000000000..29a7091c515a --- /dev/null +++ b/make_gl.patch @@ -0,0 +1,26 @@ +diff --git a/unix/Make-opengl b/unix/Make-opengl +index d9bd5b9..3b2eccb 100644 +--- a/unix/Make-opengl ++++ b/unix/Make-opengl +@@ -9,8 +9,8 @@ + # + # Generic Mesa OpenGL / GLX include and link specs, for most platforms + # +-MESA_GLX_INCS = -I/usr/local/include +-MESA_GLX_LIBS = -L/usr/local/lib -lMesaGL ++MESA_GLX_INCS = -I/usr/include ++MESA_GLX_LIBS = -L/usr/lib -L/usr/lib/mesa -lMesaGL + + + # +@@ -37,8 +37,8 @@ HP_GLX_LIBS = -L/usr/lib/X11R6 -L/opt/graphics/OpenGL/lib -lGL -lX11 -lXext + # + # Linux OpenGL / GLX include and link specs + # +-LINUX_GLX_INCS = -I/usr/X11R6/include +-LINUX_GLX_LIBS = -L/usr/X11R6/lib -lGL -lX11 ++LINUX_GLX_INCS = -I/usr/include ++LINUX_GLX_LIBS = -L/usr/lib -lGL -lX11 + + + # |