summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-01-29 09:00:31 -0700
committerMark Wagie2024-01-29 09:00:31 -0700
commit99d4b5a34e34c6af0c758e09be8a1735dd43fe24 (patch)
tree3ba426a0aa601d48c916cfaf490372aa7038e855
parent29bb3235d4ecb9582f7a20c9c3aa3a02c818511e (diff)
downloadaur-99d4b5a34e34c6af0c758e09be8a1735dd43fe24.tar.gz
5.7.4
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD23
-rw-r--r--tagspaces.sh2
3 files changed, 17 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 78828492257c..0e7395f924a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tagspaces
pkgdesc = An offline, open source, document manager with tagging support
- pkgver = 5.6.2
+ pkgver = 5.7.4
pkgrel = 1
url = https://www.tagspaces.org
arch = x86_64
@@ -8,14 +8,14 @@ pkgbase = tagspaces
makedepends = git
makedepends = libxcrypt-compat
makedepends = npm
- depends = electron26
+ depends = electron27
depends = libnotify
depends = libsecret
depends = xdg-utils
- source = tagspaces-5.6.2.tar.gz::https://github.com/tagspaces/tagspaces/archive/refs/tags/v5.6.2.tar.gz
+ source = tagspaces-5.7.4.tar.gz::https://github.com/tagspaces/tagspaces/archive/refs/tags/v5.7.4.tar.gz
source = tagspaces.desktop
source = tagspaces.sh
- sha256sums = 2f881eac0f5de2e69ae2ef364e8f927c25f9b0f3f1ac7e321bfce7e2beedfa39
+ sha256sums = acd2cf9fdd730428179f2ee8fb9d619b0652a5b18efcb92997ff57b833b93967
sha256sums = a548e2b62a61a93d80482ebe43ef11e33e2c2bfef9db641fc583bd5539ac6948
sha256sums = 9337f82424a160a0b44684209fffff0a047e96ce0449134d75e67d81f409805b
diff --git a/PKGBUILD b/PKGBUILD
index 4f31f2a31fe2..e606e956d543 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
# Contributor: syntheit <daniel@matv.io>
pkgname=tagspaces
-pkgver=5.6.2
+pkgver=5.7.4
pkgrel=1
-_electronversion=26
+_electronversion=27
pkgdesc="An offline, open source, document manager with tagging support"
arch=('x86_64')
url="https://www.tagspaces.org"
@@ -13,7 +13,7 @@ makedepends=('git' 'libxcrypt-compat' 'npm')
source=("$pkgname-$pkgver.tar.gz::https://github.com/tagspaces/tagspaces/archive/refs/tags/v$pkgver.tar.gz"
"$pkgname.desktop"
"$pkgname.sh")
-sha256sums=('2f881eac0f5de2e69ae2ef364e8f927c25f9b0f3f1ac7e321bfce7e2beedfa39'
+sha256sums=('acd2cf9fdd730428179f2ee8fb9d619b0652a5b18efcb92997ff57b833b93967'
'a548e2b62a61a93d80482ebe43ef11e33e2c2bfef9db641fc583bd5539ac6948'
'9337f82424a160a0b44684209fffff0a047e96ce0449134d75e67d81f409805b')
@@ -32,7 +32,7 @@ prepare() {
npm run install-ext-node
# A key is required in order for the main application to communicate with the web server
- cd app
+ cd release/app
touch .env
generated_key=$(tr -dc A-Za-z0-9 </dev/urandom | head -c 128)
echo "KEY=${generated_key}" > .env
@@ -46,8 +46,9 @@ build() {
electronDist="/usr/lib/electron${_electronversion}"
electronVer="$(sed s/^v// /usr/lib/electron${_electronversion}/version)"
export ELECTRON_SKIP_BINARY_DOWNLOAD=1
- npm run build
npm run install-ext-node-linux
+ npm exec -c "ts-node ./.erb/scripts/clean.js"
+ npm run build
npm exec -c "electron-builder --linux --config resources/builder.json \
${dist} -c.electronDist=${electronDist} -c.electronVersion=${electronVer}"
}
@@ -57,12 +58,12 @@ package() {
"$pkgdir/usr/lib/$pkgname/"
cp -r builds/linux-unpacked/resources/app.asar.unpacked -t \
"$pkgdir/usr/lib/$pkgname/"
- for i in 16 32 48 64 128 256; do
- install -Dm644 "builds/.icon-set/icon_${i}x${i}.png" \
- "$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/$pkgname.png"
- install -Dm644 builds/.icon-set/icon_512.png \
- "$pkgdir/usr/share/icons/hicolor/512x512/apps/$pkgname.png"
- done
install -Dm755 "$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
install -Dm644 "$pkgname.desktop" -t "$pkgdir/usr/share/applications/"
+
+ cd "$pkgname-$pkgver"
+ install -Dm644 assets/icons/256x256.png \
+ "$pkgdir/usr/share/icons/hicolor/256x256/apps/$pkgname.png"
+ install -Dm644 assets/icon.png \
+ "$pkgdir/usr/share/icons/hicolor/512x512/apps/$pkgname.png"
}
diff --git a/tagspaces.sh b/tagspaces.sh
index 932906d4ac97..252a3697a262 100644
--- a/tagspaces.sh
+++ b/tagspaces.sh
@@ -1,3 +1,3 @@
#!/bin/bash
-exec electron@ELECTRONVERSION@ /usr/lib/tagspaces/app.asar --no-sandbox "$@"
+exec electron27 /usr/lib/tagspaces/app.asar --no-sandbox "$@"