summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsyntheit2022-08-17 19:17:06 -0500
committersyntheit2022-08-17 19:17:06 -0500
commite6296d13e34982dd1e18ba5e50b51c8a27515c3b (patch)
tree8148c1c85d9fd2dc443742e83c0b11c93d773888
parentc5d64e198925c279d32969464cd3c388e7a18f85 (diff)
downloadaur-e6296d13e34982dd1e18ba5e50b51c8a27515c3b.tar.gz
Updated to 4.4.3
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb7d00572d41..11a24a42e237 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tagspaces
pkgdesc = Offline file organizer and browser with tagging support
- pkgver = 4.0.9
+ pkgver = 4.4.3
pkgrel = 1
url = https://www.tagspaces.org
arch = i686
@@ -16,9 +16,10 @@ pkgbase = tagspaces
depends = util-linux-libs
depends = ffmpeg
depends = libvips
- source = https://github.com/tagspaces/tagspaces/archive/v4.0.9.tar.gz
+ depends = libxcrypt-compat
+ source = https://github.com/tagspaces/tagspaces/archive/v4.4.3.tar.gz
source = tagspaces.desktop
- sha512sums = 31f873c53ee5505f54b43dfe95eff254756a7e0e337fba15ceeadf89f2cbba6e2ca51745befb2b68aed1f3372b50acad61c32886392acc1440a50f44ef94c885
+ sha512sums = 6480f30467bc5131ad06af9fd4563d5a7b0b820655c9289956cb22a5c9dd0ca9f0320ec6812f4ef45335967c26b222254b5e57d87d19103b09064cb0128dd554
sha512sums = cb241109c6a2d721bb629014062b59fdb6c55408c02de4c3decb0e83ddfb3fdb6d0eaac8c7ce0492e3a38ded352a9868335caf1cd75355bcda15f73ac8e2cdc7
pkgname = tagspaces
diff --git a/PKGBUILD b/PKGBUILD
index aa32e924b8f9..40c5f3e87878 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
# Maintainer: syntheit <daniel@matv.io>
-
pkgname=tagspaces
-pkgver=4.1.3
+pkgver=4.4.3
pkgrel=1
-pkgdesc='Offline file organizer and browser with tagging support'
+pkgdesc='An offline, open source, document manager with tagging support'
arch=('i686' 'x86_64')
url='https://www.tagspaces.org'
license=('AGPL3')
-depends=('gtk3' 'nss' 'libxtst' 'at-spi2-core' 'util-linux-libs' 'ffmpeg' 'libvips')
+depends=('gtk3' 'nss' 'libxtst' 'at-spi2-core' 'util-linux-libs' 'ffmpeg' 'libvips' 'libxcrypt-compat')
makedepends=('git' 'yarn' 'python')
source=("https://github.com/tagspaces/tagspaces/archive/v${pkgver}.tar.gz" "tagspaces.desktop")
-sha512sums=('5d41ca763034a8bdcf2a68ea5fc62737baa395f69bf6923769564f7b70b556c5533b1f816f38c89b2aa8c8c89274a3f5a97e72ba7a51986b9dae2042dbb8812c' 'cb241109c6a2d721bb629014062b59fdb6c55408c02de4c3decb0e83ddfb3fdb6d0eaac8c7ce0492e3a38ded352a9868335caf1cd75355bcda15f73ac8e2cdc7')
+sha512sums=('6480f30467bc5131ad06af9fd4563d5a7b0b820655c9289956cb22a5c9dd0ca9f0320ec6812f4ef45335967c26b222254b5e57d87d19103b09064cb0128dd554' 'cb241109c6a2d721bb629014062b59fdb6c55408c02de4c3decb0e83ddfb3fdb6d0eaac8c7ce0492e3a38ded352a9868335caf1cd75355bcda15f73ac8e2cdc7')
prepare() {
cd ${srcdir}/${pkgname}-${pkgver}
mkdir -p ${srcdir}/yarn_cache
+ # Make .git directory because husky must be run in the same directory as .git
+ mkdir -p .git
yarn --cache-folder=${srcdir}/yarn_cache install
yarn --cache-folder=${srcdir}/yarn_cache install-ext-node
yarn --cache-folder=${srcdir}/yarn_cache global add node-gyp
- # export PATH="$PATH:/home/daniel/.local/bin"
cd app
touch .env
generated_key=$(tr -dc A-Za-z0-9 </dev/urandom | head -c 128)