summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTopik2021-11-27 12:18:56 -0700
committerTopik2021-11-27 12:18:56 -0700
commitea35b8eb2fcd36d162ad9ce6fca638c517492eaa (patch)
tree84a23b81887ea42ef88ff3d3ec0a55b6b42b82cc
parent35ce78d2a49bd847c252ddf1812107bedec2d218 (diff)
downloadaur-ea35b8eb2fcd36d162ad9ce6fca638c517492eaa.tar.gz
Updated to version 4.0.9
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD29
2 files changed, 29 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cbaf026cd4b9..90a55b0b9427 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,24 @@
pkgbase = tagspaces
- pkgdesc = An offline, open source, document manager with tagging support
- pkgver = 3.7.7
+ pkgdesc = Offline file organizer and browser with tagging support
+ pkgver = 4.0.9
pkgrel = 1
- url = http://tagspaces.org
+ url = https://tagspaces.org
arch = i686
arch = x86_64
license = AGPL3
+ makedepends = git
makedepends = yarn
- makedepends = gendesk
+ makedepends = python
depends = gtk3
depends = nss
- depends = libxss
- source = tagspaces-3.7.7.tar.gz::https://github.com/tagspaces/tagspaces/archive/v3.7.7.tar.gz
- sha256sums = c854388270b1a6591fe4896b4dcff9f492a84d63e4a28aa55350ef0cf67fd7d9
+ depends = libxtst
+ depends = at-spi2-core
+ depends = util-linux-libs
+ depends = ffmpeg
+ depends = libvips
+ source = https://github.com/tagspaces/tagspaces/archive/v4.0.9.tar.gz
+ source = tagspaces.desktop
+ sha512sums = 31f873c53ee5505f54b43dfe95eff254756a7e0e337fba15ceeadf89f2cbba6e2ca51745befb2b68aed1f3372b50acad61c32886392acc1440a50f44ef94c885
+ sha512sums = cb241109c6a2d721bb629014062b59fdb6c55408c02de4c3decb0e83ddfb3fdb6d0eaac8c7ce0492e3a38ded352a9868335caf1cd75355bcda15f73ac8e2cdc7
pkgname = tagspaces
-
diff --git a/PKGBUILD b/PKGBUILD
index 38de8605c287..c6c64bd44f97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,33 @@
-# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
-# Contributor: Samuel Walladge <samuel at swalladge dot id dot au>
+# Maintainer: Topik topik@topik.tech
pkgname=tagspaces
-pkgver=3.7.7
+pkgver=4.0.9
pkgrel=1
-pkgdesc='An offline, open source, document manager with tagging support'
+pkgdesc='Offline file organizer and browser with tagging support'
arch=('i686' 'x86_64')
-url='http://tagspaces.org'
+url='https://tagspaces.org'
license=('AGPL3')
-depends=('gtk3'
- 'nss'
- 'libxss')
-makedepends=('yarn' 'gendesk')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/tagspaces/tagspaces/archive/v${pkgver}.tar.gz")
-sha256sums=('c854388270b1a6591fe4896b4dcff9f492a84d63e4a28aa55350ef0cf67fd7d9')
+depends=('gtk3' 'nss' 'libxtst' 'at-spi2-core' 'util-linux-libs' 'ffmpeg' 'libvips')
+makedepends=('git' 'yarn' 'python')
+source=("https://github.com/tagspaces/tagspaces/archive/v${pkgver}.tar.gz" "tagspaces.desktop")
+sha512sums=('31f873c53ee5505f54b43dfe95eff254756a7e0e337fba15ceeadf89f2cbba6e2ca51745befb2b68aed1f3372b50acad61c32886392acc1440a50f44ef94c885' 'cb241109c6a2d721bb629014062b59fdb6c55408c02de4c3decb0e83ddfb3fdb6d0eaac8c7ce0492e3a38ded352a9868335caf1cd75355bcda15f73ac8e2cdc7')
prepare() {
cd ${srcdir}/${pkgname}-${pkgver}
mkdir -p ${srcdir}/yarn_cache
yarn --cache-folder=${srcdir}/yarn_cache install
- yarn --cache-folder=${srcdir}/yarn_cache install-ext
- gendesk -f -n --pkgname "${pkgname}" --pkgdesc "${pkgdesc}" --exec="${pkgname}" --categories=Utility\;Graphics
+ yarn --cache-folder=${srcdir}/yarn_cache install-ext-node
+ cd app
+ touch .env
+ generated_key=$(tr -dc A-Za-z0-9 </dev/urandom | head -c 128)
+ echo "KEY=${generated_key}" > .env
}
build() {
cd ${srcdir}/${pkgname}-${pkgver}
yarn --cache-folder=${srcdir}/yarn_cache build
yarn --cache-folder=${srcdir}/yarn_cache package-linux
+ cd ${srcdir}/${pkgname}-${pkgver}
}
package() {
@@ -35,6 +36,6 @@ package() {
cp -R "${srcdir}/builds/linux-unpacked"/* "${pkgdir}/opt/${pkgname}"
chmod 755 "${pkgdir}/opt/${pkgname}/tagspaces"
ln -s "/opt/${pkgname}/tagspaces" "${pkgdir}/usr/bin/tagspaces"
- install -Dm644 "${srcdir}/${pkgname}-${pkgver}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
install -Dm644 "${srcdir}/${pkgname}-${pkgver}/resources/icons/256x256.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
}