summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-08-28 09:52:33 -0600
committerMark Wagie2023-08-28 09:52:33 -0600
commitb4bfa61b7fea3ecd1b25a785984bd6c5860cd5be (patch)
tree85de609cd0652cb42d9e50efefb2588179282680
parentc08b00fec2b577a6d79f6170de738d19a0cbcb65 (diff)
downloadaur-b4bfa61b7fea3ecd1b25a785984bd6c5860cd5be.tar.gz
add missing deps
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD28
3 files changed, 33 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd0fcf7ffd78..b6eb97d889d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,20 @@
pkgbase = tagspaces-bin
- pkgdesc = TagSpaces is an open source personal data manager. It helps you organize files with tags on every platform.
+ pkgdesc = An offline, open source, document manager with tagging support
pkgver = 5.4.6
- pkgrel = 1
- url = http://tagspaces.org
+ pkgrel = 2
+ url = https://www.tagspaces.org
arch = x86_64
- license = AGPL
+ license = AGPL3
+ depends = alsa-lib
+ depends = gtk3
+ depends = libnotify
+ depends = libsecret
+ depends = nss
+ depends = xdg-utils
+ optdepends = libappindicator-gtk3: Tray icon
provides = tagspaces
conflicts = tagspaces
- source = tagspaces-5.4.6.deb::https://github.com/tagspaces/tagspaces/releases/download/v5.4.6/tagspaces-linux-amd64-5.4.6.deb
+ source = https://github.com/tagspaces/tagspaces/releases/download/v5.4.6/tagspaces-linux-amd64-5.4.6.deb
sha256sums = effb214cffea3d128f69fbd57c0161741dcb69a7b8825160d2756e0bdeb8d4e5
pkgname = tagspaces-bin
diff --git a/.gitignore b/.gitignore
index 617dfda4f7aa..4dab8d6386e3 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,7 @@
-tagspaces-*
-pkg/
-src/
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index dfba56e11fae..71a20f2c6e02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
# Maintainer: Ali Molaei <ali dot molaei at protonmail dot com>
+# Co-Maintainer: Mark Wagie <mark dot wagie at proton dot me>
# Contributor: Samuel Walladge <samuel at swalladge dot net>
-
pkgname=tagspaces-bin
-_pkgname=tagspaces
pkgver=5.4.6
-pkgrel=1
-pkgdesc="TagSpaces is an open source personal data manager. It helps you organize files with tags on every platform."
-arch=("x86_64")
-url="http://tagspaces.org"
-license=("AGPL")
-provides=("tagspaces")
-conflicts=("tagspaces")
+pkgrel=2
+pkgdesc="An offline, open source, document manager with tagging support"
+arch=('x86_64')
+url="https://www.tagspaces.org"
+license=('AGPL3')
+depends=('alsa-lib' 'gtk3' 'libnotify' 'libsecret' 'nss' 'xdg-utils')
+optdepends=('libappindicator-gtk3: Tray icon')
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname%-bin}")
+source=("https://github.com/tagspaces/tagspaces/releases/download/v$pkgver/${pkgname%-bin}-linux-amd64-$pkgver.deb")
sha256sums=('effb214cffea3d128f69fbd57c0161741dcb69a7b8825160d2756e0bdeb8d4e5')
-source=("${_pkgname}-${pkgver}.deb::https://github.com/${_pkgname}/${_pkgname}/releases/download/v${pkgver}/${_pkgname}-linux-amd64-${pkgver}.deb")
package() {
- bsdtar -xv -C "${pkgdir}" -f "${srcdir}/data.tar.xz"
+ bsdtar -xvf data.tar.xz -C "$pkgdir/"
- # symlink the main binary to a better location
- mkdir -p ${pkgdir}/usr/bin/
- ln -s /opt/TagSpaces/${_pkgname} ${pkgdir}/usr/bin/${_pkgname}
+ install -d "$pkgdir/usr/bin"
+ ln -s "/opt/TagSpaces/${pkgname%-bin}" "$pkgdir/usr/bin/"
}