summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Walladge2018-06-28 10:24:17 +0930
committerSamuel Walladge2018-06-28 10:24:17 +0930
commitd0d492faf4e929b1eb1750f52a29eaf45a602d65 (patch)
tree3657ab5034af37d898420beb88c3b13937d81198
downloadaur-d0d492faf4e929b1eb1750f52a29eaf45a602d65.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c7ed811906e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = tagspaces-bin
+ pkgdesc = TagSpaces is an open source personal data manager. It helps you organize files with tags on every platform.
+ pkgver = 3.0.0_beta.12
+ pkgrel = 1
+ url = http://tagspaces.org
+ arch = x86_64
+ license = AGPL
+ makedepends = bower
+ makedepends = gendesk
+ provides = tagspaces
+ conflicts = tagspaces
+ source = tagspaces-3.0.0-beta.12.deb::https://github.com/tagspaces/tagspaces/releases/download/v3.0.0-beta.12/tagspaces-linux-amd64-3.0.0-beta.12.deb
+ sha256sums = e1f29188815c231c4ff9cd75c61ead0df9b6d0268c5071ba026832cc6b716f8a
+
+pkgname = tagspaces-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..76cf240622e9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Samuel Walladge <samuel at swalladge dot id dot au>
+
+pkgname=tagspaces-bin
+_pkgname=tagspaces
+pkgver=3.0.0_beta.12
+# upstream pkgver - has a hyphen which is not allowed
+_pkgver="3.0.0-beta.12"
+pkgrel=1
+pkgdesc="TagSpaces is an open source personal data manager. It helps you organize files with tags on every platform."
+arch=("x86_64")
+url="http://tagspaces.org"
+license=("AGPL")
+makedepends=("bower" "gendesk")
+provides=("tagspaces")
+conflicts=("tagspaces")
+sha256sums=('e1f29188815c231c4ff9cd75c61ead0df9b6d0268c5071ba026832cc6b716f8a')
+source=("${_pkgname}-${_pkgver}.deb::https://github.com/${_pkgname}/${_pkgname}/releases/download/v${_pkgver}/${_pkgname}-linux-amd64-${_pkgver}.deb")
+
+package() {
+ bsdtar -xv -C "${pkgdir}" -f "${srcdir}/data.tar.xz"
+
+ # symlink the main binary to a better location
+ mkdir -p ${pkgdir}/usr/bin/
+ ln -s /opt/TagSpaces/${_pkgname} ${pkgdir}/usr/bin/${_pkgname}
+}