summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2023-04-01 19:41:23 +0200
committerAntonio Rojas2023-04-01 19:41:23 +0200
commit92c55afd70ccd0a7641097601ded15c50a763e0d (patch)
tree01da2064c45323f16425096e3729d3239f4f35eb
downloadaur-tamsyn-font.tar.gz
import from community
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD28
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e64b91804d85
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = tamsyn-font
+ pkgdesc = A monospaced bitmap font for the console and X11
+ pkgver = 1.11
+ pkgrel = 6
+ url = https://www.fial.com/~scott/tamsyn-font
+ arch = any
+ license = custom
+ depends = xorg-fonts-encodings
+ source = https://web.archive.org/web/20200616131205if_/http://www.fial.com/~scott/tamsyn-font/download/tamsyn-font-1.11.tar.gz
+ md5sums = 6ec13672d2f0d6a829f2403cdeebd980
+ sha256sums = 97be1b604441b725548c454a92603993eb96e493f508845638a86c8d64fbf24e
+
+pkgname = tamsyn-font
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a5a961bff6e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Contributor: Scott Fial <scott at fial dot com>
+
+pkgname=tamsyn-font
+pkgver=1.11
+pkgrel=6
+pkgdesc="A monospaced bitmap font for the console and X11"
+arch=('any')
+url="https://www.fial.com/~scott/tamsyn-font"
+license=('custom')
+depends=('xorg-fonts-encodings')
+#source=("https://www.fial.com/~scott/$pkgname/download/$pkgname-$pkgver.tar.gz")
+source=("https://web.archive.org/web/20200616131205if_/http://www.fial.com/~scott/tamsyn-font/download/tamsyn-font-1.11.tar.gz")
+md5sums=('6ec13672d2f0d6a829f2403cdeebd980')
+sha256sums=('97be1b604441b725548c454a92603993eb96e493f508845638a86c8d64fbf24e')
+
+package () {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ install -d "$pkgdir/usr/share/fonts/misc"
+ install -d "$pkgdir/usr/share/kbd/consolefonts"
+ install -d "$pkgdir/usr/share/doc/$pkgname"
+
+ install -m644 *.pcf "$pkgdir/usr/share/fonts/misc/"
+ install -m644 *.psf.gz "$pkgdir/usr/share/kbd/consolefonts/"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 README "$pkgdir/usr/share/doc/$pkgname/"
+}