summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlan Moore2016-02-17 20:05:50 -0600
committerAlan Moore2016-02-17 20:05:50 -0600
commitf9df90ab0e065a974acd15c15c8889415e59a22b (patch)
tree0d2f248e907341492e953d83a61dc04860b47d50
downloadaur-tap-plugins-lv2-git.tar.gz
first pkgbuild version
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..30904616912b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by makepkg 5.0.0
+# Thu Feb 18 02:05:26 UTC 2016
+pkgbase = tap-plugins-lv2-git
+ pkgdesc = LV2 port for the TAP (Tom's Audio Processing) plugins
+ pkgver = r95.de26a3c
+ pkgrel = 1
+ url = https://github.com/moddevices/tap-lv2
+ arch = i686
+ arch = x86_64
+ groups = lv2-plugins
+ license = GPL
+ makedepends = git
+ makedepends = lv2
+ depends = glibc
+ source = git+https://github.com/moddevices/tap-lv2.git
+ md5sums = SKIP
+
+pkgname = tap-plugins-lv2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35cc73962c7a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: lykwydchykyn <me at alan d moore dot com>
+pkgname=tap-plugins-lv2-git
+pkgver=r95.de26a3c
+pkgrel=1
+pkgdesc="LV2 port for the TAP (Tom's Audio Processing) plugins"
+arch=('i686' 'x86_64')
+url="https://github.com/moddevices/tap-lv2"
+license=('GPL')
+groups=('lv2-plugins')
+depends=("glibc")
+makedepends=("git" "lv2")
+source=("git+https://github.com/moddevices/tap-lv2.git")
+md5sums=('SKIP')
+_reponame="tap-lv2"
+
+
+pkgver() {
+
+ cd "${srcdir}"/"${_reponame}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+
+}
+
+build() {
+ cd "$srcdir/${_reponame}"
+
+ make INSTALL_PATH=/usr/lib/lv2
+}
+
+package() {
+ cd "$srcdir/${_reponame}"
+
+ make INSTALL_PATH=/usr/lib/lv2 DESTDIR="$pkgdir/" install
+}
+