summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-03-27 10:18:16 +0100
committerAlexander F. Rødseth2019-03-27 10:18:16 +0100
commitb28dd472baedfe6e6037e9c1b11ec22f791f1e88 (patch)
tree467cd0b37c5be806c8339ce61af13adb4fc7f3f8
downloadaur-tasque.tar.gz
Move from [community] to AUR in connection with the spring cleaning
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD41
-rw-r--r--dbus-sharp-2-porting.patch22
-rw-r--r--tasque.appdata.xml21
-rw-r--r--use_dbussharp_2.patch32
5 files changed, 139 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4346c4ac8091
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Wed Mar 27 09:16:01 UTC 2019
+pkgbase = tasque
+ pkgdesc = Easy quick task management app written in C Sharp
+ pkgver = 0.1.12
+ pkgrel = 6
+ url = https://wiki.gnome.org/Attic/Tasque
+ arch = any
+ license = MIT
+ makedepends = intltool
+ depends = notify-sharp
+ depends = sqlite
+ source = https://download.gnome.org/sources/tasque/0.1/tasque-0.1.12.tar.xz
+ source = tasque.appdata.xml
+ source = dbus-sharp-2-porting.patch
+ source = use_dbussharp_2.patch
+ sha256sums = db4d4a822cfa87ce8cf311189e17fa8fbda37e7c943874b6bf62c6a84b2d824d
+ sha256sums = f5d76db752d95eedde81857cfa9a46caa21e9d7528f8992e0b3d9a992a8ca624
+ sha256sums = 9bcd0f2e854ade96203a44ca7e322d20e0a197057ea2c2271099720a211006b1
+ sha256sums = b75cdba593bcd28beef7e55212511f5ebedda38a25c210b16226d9db4b180ef6
+
+pkgname = tasque
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f822d86d0e11
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer:
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
+
+pkgname=tasque
+pkgver=0.1.12
+pkgrel=6
+pkgdesc="Easy quick task management app written in C Sharp"
+arch=('any')
+url="https://wiki.gnome.org/Attic/Tasque"
+license=('MIT')
+depends=('notify-sharp' 'sqlite')
+makedepends=('intltool')
+source=(https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz
+ tasque.appdata.xml
+ dbus-sharp-2-porting.patch
+ use_dbussharp_2.patch)
+sha256sums=('db4d4a822cfa87ce8cf311189e17fa8fbda37e7c943874b6bf62c6a84b2d824d'
+ 'f5d76db752d95eedde81857cfa9a46caa21e9d7528f8992e0b3d9a992a8ca624'
+ '9bcd0f2e854ade96203a44ca7e322d20e0a197057ea2c2271099720a211006b1'
+ 'b75cdba593bcd28beef7e55212511f5ebedda38a25c210b16226d9db4b180ef6')
+
+prepare() {
+ cd $pkgname-$pkgver
+ patch -Np1 -i ../dbus-sharp-2-porting.patch
+ patch -Np1 -i ../use_dbussharp_2.patch
+ autoreconf -fi
+}
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --disable-appindicator
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ install -Dm644 ../tasque.appdata.xml "$pkgdir/usr/share/metainfo/tasque.appdata.xml"
+ rm -r "$pkgdir/usr/share/pixmaps/"
+}
diff --git a/dbus-sharp-2-porting.patch b/dbus-sharp-2-porting.patch
new file mode 100644
index 000000000000..f1894afeb2be
--- /dev/null
+++ b/dbus-sharp-2-porting.patch
@@ -0,0 +1,22 @@
+Description: Port to dbus#2 API
+Forwarded: not-needed
+
+--- tasque-0.1.12.orig/src/Gtk.Tasque/RemoteControlProxy.cs
++++ tasque-0.1.12/src/Gtk.Tasque/RemoteControlProxy.cs
+@@ -22,8 +22,7 @@ namespace Tasque
+ BusG.Init ();
+
+ RemoteControl remote_control = new RemoteControl ();
+- Bus.Session.Register (Namespace,
+- new ObjectPath (Path),
++ Bus.Session.Register (new ObjectPath (Path),
+ remote_control);
+
+ if (Bus.Session.RequestName (Namespace)
+@@ -33,4 +32,4 @@ namespace Tasque
+ return remote_control;
+ }
+ }
+-}
+\ No newline at end of file
++}
diff --git a/tasque.appdata.xml b/tasque.appdata.xml
new file mode 100644
index 000000000000..4031ebe8f833
--- /dev/null
+++ b/tasque.appdata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<component type="desktop-application">
+ <id>org.gnome.tasque</id>
+ <launchable type="desktop-id">tasque.desktop</launchable>
+ <name>Tasque</name>
+ <summary>Easy quick task management</summary>
+ <metadata_license>CC0-1.0</metadata_license>
+ <project_license>MIT</project_license>
+ <description>
+ <p>Tasque is a simple task management app (TODO list). It supports syncing with the on-line service Remember the Milk or simply storing your tasks locally.</p>
+ </description>
+ <screenshots>
+ <screenshot type="default">
+ <image>https://people.gnome.org/~sharm/tasque-0.1.8.png</image>
+ </screenshot>
+ </screenshots>
+ <url type="bugtracker">https://gitlab.gnome.org/Archive/tasque/issues</url>
+ <url type="homepage">https://wiki.gnome.org/Attic/Tasque</url>
+ <update_contact>tasque-list@gnome.org</update_contact>
+ <translation type="gettext">tasque</translation>
+</component>
diff --git a/use_dbussharp_2.patch b/use_dbussharp_2.patch
new file mode 100644
index 000000000000..a17c572322c7
--- /dev/null
+++ b/use_dbussharp_2.patch
@@ -0,0 +1,32 @@
+Index: tasque/configure.ac
+===================================================================
+--- tasque.orig/configure.ac 2013-11-29 00:41:30.025341888 +0000
++++ tasque/configure.ac 2013-11-29 00:41:30.021341888 +0000
+@@ -65,8 +65,8 @@
+ PKG_CHECK_MODULES([GTK_SHARP_20], [gtk-sharp-2.0 >= 2.10.0])
+ PKG_CHECK_MODULES([GTK_SHARP_2_12], gtk-sharp-2.0 >= 2.12.0, GTK_2_12="yes", GTK_2_12="no")
+ AM_CONDITIONAL(GTK_2_12, test "$GTK_2_12" = "yes")
+-PKG_CHECK_MODULES([DBUS_SHARP_10], [dbus-sharp-1.0])
+-PKG_CHECK_MODULES([DBUS_SHARP_GLIB_10], [dbus-sharp-glib-1.0])
++PKG_CHECK_MODULES([DBUS_SHARP_10], [dbus-sharp-2.0])
++PKG_CHECK_MODULES([DBUS_SHARP_GLIB_10], [dbus-sharp-glib-2.0])
+
+ #
+ # Allow the project to build without notify-sharp
+Index: tasque/src/Gtk.Tasque/Gtk.Tasque.csproj
+===================================================================
+--- tasque.orig/src/Gtk.Tasque/Gtk.Tasque.csproj 2013-11-29 00:33:43.000000000 +0000
++++ tasque/src/Gtk.Tasque/Gtk.Tasque.csproj 2013-11-29 00:41:53.765341045 +0000
+@@ -63,10 +63,10 @@
+ <Reference Include="notify-sharp, Version=0.4.0.0, Culture=neutral, PublicKeyToken=2df29c54e245917a">
+ <Private>False</Private>
+ </Reference>
+- <Reference Include="dbus-sharp, Version=1.0.0.0, Culture=neutral, PublicKeyToken=5675b0c3093115b5">
++ <Reference Include="dbus-sharp, Version=2.0.0.0, Culture=neutral, PublicKeyToken=5675b0c3093115b5">
+ <Private>False</Private>
+ </Reference>
+- <Reference Include="dbus-sharp-glib, Version=1.0.0.0, Culture=neutral, PublicKeyToken=5675b0c3093115b5">
++ <Reference Include="dbus-sharp-glib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=5675b0c3093115b5">
+ <Private>False</Private>
+ </Reference>
+ </ItemGroup>