summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Gysin2021-04-27 14:24:06 +0300
committerChristoph Gysin2021-04-27 14:24:06 +0300
commit1b1d1a54e675aab140e8e69bdf70d574a05fc6f7 (patch)
treec64059a42d4bb3151109b4fc4190e0a47c59d3f0
parent23a8b671cafd48939417f4bc8d700d70cfbae72c (diff)
downloadaur-tcpick.tar.gz
Fix linker errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--fix-globals.patch22
3 files changed, 31 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd1aea2a95e4..5c4c54dcb8ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tcpick
pkgdesc = Tcp stream sniffer and connection tracker
pkgver = 0.2.1
- pkgrel = 2
+ pkgrel = 3
url = http://tcpick.sourceforge.net
arch = i686
arch = x86_64
@@ -13,12 +13,14 @@ pkgbase = tcpick
source = fix-double-free-error.patch
source = fix-infinite-loop-on-powerpc.patch
source = fix-man-invocation.patch
+ source = fix-globals.patch
md5sums = bb94f2f9ea81aeb645619fbe9b3b9a29
md5sums = 3efd250f8cb6a308dd07ae858562ccc3
md5sums = b6a7330a1a8b0b79a7d1db73712db0c2
md5sums = 391c336816f126ecbf7e6c219905340f
md5sums = 8c468789fb553f7d31ae48cfc260409d
md5sums = 3a2107306148df3d792aa796b04a3309
+ md5sums = 1e3d45fdb8accc66f6bb1a47503396ea
pkgname = tcpick
diff --git a/PKGBUILD b/PKGBUILD
index e70ef70f9673..3a5309ca05a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=tcpick
pkgver=0.2.1
-pkgrel=2
+pkgrel=3
pkgdesc='Tcp stream sniffer and connection tracker'
arch=('i686' 'x86_64')
depends=('libpcap')
@@ -13,13 +13,15 @@ source=(http://prdownloads.sourceforge.net/tcpick/$pkgname-$pkgver.tar.gz
fix-build-with-gcc5.patch
fix-double-free-error.patch
fix-infinite-loop-on-powerpc.patch
- fix-man-invocation.patch)
+ fix-man-invocation.patch
+ fix-globals.patch)
md5sums=('bb94f2f9ea81aeb645619fbe9b3b9a29'
'3efd250f8cb6a308dd07ae858562ccc3'
'b6a7330a1a8b0b79a7d1db73712db0c2'
'391c336816f126ecbf7e6c219905340f'
'8c468789fb553f7d31ae48cfc260409d'
- '3a2107306148df3d792aa796b04a3309')
+ '3a2107306148df3d792aa796b04a3309'
+ '1e3d45fdb8accc66f6bb1a47503396ea')
prepare() {
cd $srcdir/$pkgname-$pkgver
@@ -28,6 +30,7 @@ prepare() {
patch -Np1 -i ../fix-double-free-error.patch
patch -Np1 -i ../fix-infinite-loop-on-powerpc.patch
patch -Np1 -i ../fix-man-invocation.patch
+ patch -Np1 -i ../fix-globals.patch
}
build() {
diff --git a/fix-globals.patch b/fix-globals.patch
new file mode 100644
index 000000000000..dde90f08c8de
--- /dev/null
+++ b/fix-globals.patch
@@ -0,0 +1,22 @@
+diff --color -ur src/tcpick-0.2.1/src/conn.h src/tcpick-0.2.1-fixed/src/conn.h
+--- a/src/conn.h 2004-12-31 15:53:30.000000000 +0200
++++ b/src/conn.h 2021-04-27 14:16:35.892878266 +0300
+@@ -80,5 +80,3 @@
+ };
+
+
+-struct ip * ip_last_header; /* FIXME: check */
+-struct tcphdr * tcp_last_header;
+diff --color -ur src/tcpick-0.2.1/src/tracker.c src/tcpick-0.2.1-fixed/src/tracker.c
+--- a/src/tracker.c 2021-04-27 14:18:30.868244206 +0300
++++ b/src/tracker.c 2021-04-27 14:17:27.041848456 +0300
+@@ -28,9 +28,6 @@
+ #include "tcpick.h"
+ #include "extern.h"
+
+-struct CONN * first_conn = NULL; /*all connections, ends on a 0*/
+-struct CONN * last_conn = NULL;
+-
+ int
+ status_switch(struct CONN * prev, enum STATUS status)
+ {