summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaypam2016-02-20 21:59:02 +0000
committerNaypam2016-02-20 21:59:02 +0000
commit370fa624d8f6a7b1c488d867449d750a54b22c5a (patch)
treec699225ff452af0d29b3c3f15ade00fceef88fcf
downloadaur-tea-git.tar.gz
Initial
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD33
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5894a798e749
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sat Feb 20 21:48:56 UTC 2016
+pkgbase = tea-git
+ pkgdesc = Tea Daemon, alerts you when your tea is ready.
+ pkgver = 57
+ pkgrel = 1
+ url = https://github.com/x89/Tea
+ arch = i686
+ arch = x86_64
+ license = BSD 2-clause + tea ^ beer
+ optdepends = mplayer: Lightweight, non-gui
+ optdepends = mpv: Fancy new GUI-less-ish player
+ optdepends = vlc: All strings attached uber music player
+ provides = tea
+ provides = tead
+ source = git+https://github.com/x89/Tea.git
+ md5sums = SKIP
+
+pkgname = tea-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c10b1e877638
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: David Trail <napalm10@gmail.com>
+
+pkgname="tea-git"
+pkgver=57
+pkgrel=1
+pkgdesc="Tea Daemon, alerts you when your tea is ready."
+arch=('i686' 'x86_64')
+url="https://github.com/x89/Tea"
+license=('BSD 2-clause + tea ^ beer')
+optdepends=("mplayer: Lightweight, non-gui"
+ "mpv: Fancy new GUI-less-ish player"
+ "vlc: All strings attached uber music player")
+requires=('git')
+provides=('tea' 'tead')
+md5sums=('SKIP')
+source=('git+https://github.com/x89/Tea.git')
+
+build() {
+ cd "$srcdir/Tea"
+ sed -i 's/tea.flac/\/usr\/share\/tea\/tea.flac/' tea.sh
+ sed -i 's/tea.mp3/\/usr\/share\/tea\/tea.mp3/' tea.sh
+}
+
+package() {
+ cd "$srcdir/Tea"
+ install -D -m755 "${srcdir}/Tea/tea.sh" "${pkgdir}/usr/bin/tea"
+ install -D -m644 "${srcdir}/Tea/tea.flac" "${pkgdir}/usr/share/tea/tea.flac"
+ install -D -m644 "${srcdir}/Tea/tea.mp3" "${pkgdir}/usr/share/tea/tea.mp3"
+ install -D -m644 "${srcdir}/Tea/LICENSE" "${pkgdir}/usr/share/licenses/tea/LICENSE"
+ install -D -m644 "${srcdir}/Tea/service/tead.service" "${pkgdir}/usr/lib/systemd/system/tead.service"
+ install -D -m644 "${srcdir}/Tea/service/tead.socket" "${pkgdir}/usr/lib/systemd/system/tead.socket"
+}
+