summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordadosch2019-06-27 21:59:57 +0200
committerdadosch2019-06-27 21:59:57 +0200
commit6a459eb8249dcb821d862599fba3f1ecc8b297f5 (patch)
tree3240b96ffaabdd55d0ecdc348d32e25dccf33cff
parent28ae6355a706c066c8afcfad773e5a4fac43e072 (diff)
downloadaur-6a459eb8249dcb821d862599fba3f1ecc8b297f5.tar.gz
update
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD24
-rw-r--r--tea4cups.install2
3 files changed, 26 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13671f6dd2c3..e31321631a17 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tea4cups-py3-git
pkgdesc = A unofficial python3 fork of Tea4cups
- pkgver = r12.65b5c3a
- pkgrel = 2
+ pkgver = 3.1.5_alpha+65b5c3a
+ pkgrel = 1
url = https://gitlab.com/dadosch/tea4cups/tree/python3/
install = tea4cups.install
arch = any
@@ -9,9 +9,9 @@ pkgbase = tea4cups-py3-git
depends = cups
depends = python
depends = python-requests
- provides = tea4cups=r12.65b5c3a
- provides = tea4cups-py3=r12.65b5c3a
- provides = tea4cups-py3-doc=r12.65b5c3a
+ provides = tea4cups=3.1.5_alpha+65b5c3a
+ provides = tea4cups-py3=3.1.5_alpha+65b5c3a
+ provides = tea4cups-py3-doc=3.1.5_alpha+65b5c3a
conflicts = tea4cups-svn
backup = etc/cups/tea4cups.conf
source = tea4cups-py3::git+https://gitlab.com/dadosch/tea4cups#branch=python3
@@ -21,7 +21,7 @@ pkgbase = tea4cups-py3-git
sha256sums = SKIP
sha256sums = 6221890bbd1ab3806efeec8624161c80742d1c5fce24c9094e4f8f8466ba2923
sha256sums = SKIP
- sha256sums = ef3106de3e751109dcad9f3261fe608aff09fc6dea18451dfca2a4841ffccf7a
+ sha256sums = 315c82e6e9d352ecb32d511c9290790ac2a52e60e82d4727bff350fcf03aacf0
pkgname = tea4cups-py3-git
diff --git a/PKGBUILD b/PKGBUILD
index 25a215ad571e..f35da430309e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
pkgname=tea4cups-py3-git
_pkgname=tea4cups-py3
-pkgver=r12.65b5c3a
+pkgver=3.1.5_alpha+65b5c3a
-pkgrel=2
+pkgrel=1
pkgdesc="A unofficial python3 fork of Tea4cups"
url="https://gitlab.com/dadosch/tea4cups/tree/python3/"
@@ -34,14 +34,26 @@ sha256sums=(
'SKIP' # svn+http://svn.pykota.com/tea4cups/trunk
'6221890bbd1ab3806efeec8624161c80742d1c5fce24c9094e4f8f8466ba2923' # doc_from_website.txt
'SKIP' # doc_debianwiki.html
- 'ef3106de3e751109dcad9f3261fe608aff09fc6dea18451dfca2a4841ffccf7a' # "${install}"
+ '315c82e6e9d352ecb32d511c9290790ac2a52e60e82d4727bff350fcf03aacf0' # "${install}"
)
+_tea4cups_spool='/var/spool/tea4cups' # Should match that which get's defined by applying "${srcdir}/tea4cups-spool-directory.patch".
+
pkgver() {
cd "${srcdir}/${_pkgname}"
+ _ver="$(cat tea4cups | sed -n -E 's|^[[:space:]]*__version__[[:space:]]*=[[:space:]]*(.*)$|\1|p' | tr -d \"\' | tr '-' '_')"
+ _git="$(git rev-parse --short HEAD)"
+ if [ -z ${_ver} ]; then
+ echo "Error: Could not determine software version. Aborting." >&2
+ exit 1
+ fi
+ if [ -z ${_git} ]; then
+ echo "Error: Could not determine Git revision. Aborting." >&2
+ exit 1
+ fi
# Get the version number.
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ echo "${_ver}+${_git}"
}
@@ -77,4 +89,8 @@ package() {
install -v -m 755 -D clean.sh "${pkgdir}/usr/share/doc/${_pkgname}/clean.sh"
install -v -m 644 -D "COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/GPL2.txt"
+
+ msg2 "Creating our own spool directory '${_tea4cups_spool}' ..."
+ install -v -d -m775 "${pkgdir}${_tea4cups_spool}"
+ chown cups:cups "${pkgdir}${_tea4cups_spool}"
}
diff --git a/tea4cups.install b/tea4cups.install
index 1fc929268daa..e932b640705e 100644
--- a/tea4cups.install
+++ b/tea4cups.install
@@ -2,6 +2,4 @@ post_install() {
echo ""
echo ">> Please see the documentation on how to set up printers with tea4cups."
echo ""
- echo ">> Please create the directoy /var/spool/tea4cups, chown it to cups
-user and chmod 740 it."
}