summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzulc22 (Scott)2022-02-05 03:08:00 -0800
committerzulc22 (Scott)2022-02-05 03:08:00 -0800
commitc98ecf81e5cb446d6923ddba6467528bce2f0312 (patch)
tree2b860b4a4643f37c9ea962f0f9a4580b6bd23310
parent7c87fa829aed63ac3b1236450f05dedf735ea016 (diff)
downloadaur-c98ecf81e5cb446d6923ddba6467528bce2f0312.tar.gz
Revert "first AUR package go easy on me"
This reverts commit 2f635652eacc9c88f13f8ed4df066cdfdc3172fc.
-rw-r--r--PKGBUILD101
1 files changed, 57 insertions, 44 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 05a50eb1a66a..ad106af6d359 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,57 +1,70 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
+#Maintainer: David A. Redick <david.a.redick@gmail.com>
+#Contributor: Frederic Bezies <fredbezies at gmail dot com>
+#Contributor: Simone Sclavi 'Ito' <darkhado@gmail.com>
-# Maintainer: KScott <kscott.db@gmail.com>
pkgname=tecnoballz
pkgver=0.93.1
-pkgrel=1
-epoch=
-pkgdesc="Addicting retro break-out game ported from the Amiga"
-arch=($CARCH)
-url="http://linux.tlk.fr/games/TecnoballZ"
+pkgrel=3
+arch=('i686' 'x86_64')
+pkgdesc='An exciting brick breaker game'
+url='http://linux.tlk.fr/games/TecnoballZ/'
+depends=('sdl_image' 'sdl_mixer' 'tinyxml' 'libmikmod')
license=('GPL3')
-groups=()
-depends=("sdl"
- "sdl_mixer"
- "sdl_image"
- "tinyxml"
- "libmikmod")
-makedepends=()
-checkdepends=()
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
+backup=('var/lib/tecnoballz/tecnoballz.hi')
source=(
- "$pkgname-$pkgver.tgz::http://linux.tlk.fr/games/TecnoballZ/download/tecnoballz-0.93.1.tgz"
+ "http://linux.tlk.fr/games/TecnoballZ/download/${pkgname}-${pkgver}.tgz"
+ "${pkgname}.xpm"
+ "${pkgname}.desktop"
+ games.dir.patch
+ 'tecnoballz.48.png'
+ 'tecnoballz.64.png'
)
-noextract=()
-md5sums=("7beeacb06fa841382f0ecbe73f64723a")
-validpgpkeys=()
-prepare() {
- cd "$pkgname-$pkgver"
-}
+md5sums=(
+ '7beeacb06fa841382f0ecbe73f64723a'
+ '5b8d94612523353b6d2eb32f840b58d8'
+ 'e6a50c9c6ec7fd3ecf21fd9738c8d6be'
+ '92793da20387db8c32646052a85e56d7'
+ 'de4554b57efe05c35ce7adeef597f798'
+ 'f4e4f0ff03728180f84cfa99970a117b'
+)
-build() {
- cd "$pkgname-$pkgver"
- ./bootstrap
- ./configure --prefix=/usr
- make CXXFLAGS="-O2 -Wno-error -pedantic -Wextra -std=gnu++98"
+prepare () {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -p1 < "${srcdir}/games.dir.patch"
}
-check() {
- cd "$pkgname-$pkgver"
- make check
+build () {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # The original submitter used this but the project docs say to use bootstrap
+ #autoreconf -fvi
+ ./bootstrap
+
+ ./configure --prefix=/usr
+
+ # Works out of the box for me but the original submitter did this.
+ ## -O3 breaks compilation!
+ #sed -i 's/CXXFLAGS=" -O3 -Wall"/CXXFLAGS=" -O2 -Wall"/' configure
+
+ make
}
-package() {
- cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
+package () {
+ mkdir -p "${pkgdir}/usr/share/applications"
+# mkdir -p "${pkgdir}/usr/share/icons/hicolor/scalable/apps"
+ mkdir -p "${pkgdir}/usr/share/icons/hicolor/64x64/apps"
+ mkdir -p "${pkgdir}/usr/share/icons/hicolor/48x48/apps"
+
+ install -m644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications"
+# install -m644 "${pkgname}.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps"
+ install -m644 "${pkgname}.64.png" "${pkgdir}/usr/share/icons/hicolor/64x64/apps/${pkgname}.png"
+ install -m644 "${pkgname}.48.png" "${pkgdir}/usr/share/icons/hicolor/48x48/apps/${pkgname}.png"
+
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="$pkgdir" install
+
+ # fix permissions
+ chgrp users "${pkgdir}/var/lib/${pkgname}/tecnoballz.hi"
+ chmod 755 "${pkgdir}/usr/bin/${pkgname}"
}