summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNiels Martignène2018-12-23 15:22:18 +0100
committerNiels Martignène2018-12-23 15:22:46 +0100
commit49c7c2514cd9f30fe1729dc367f85b317905d2d9 (patch)
tree071212cf3d50a977c48a17b447d546a937f7d054
parent9f5c6416c53687bf6b279a4346e4d1d234d3bc78 (diff)
downloadaur-49c7c2514cd9f30fe1729dc367f85b317905d2d9.tar.gz
Upgrade to Teensyduino 1.45, Arduino 1.8.8
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD22
-rwxr-xr-xteensyduino.sh26
3 files changed, 19 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3e5afcb4cbf..29afd127f4df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = teensyduino
pkgdesc = Arduino SDK with Teensyduino
- pkgver = 1.44
+ pkgver = 1.45
pkgrel = 1
url = http://www.pjrc.com/teensy/teensyduino.html
install = teensyduino.install
@@ -9,9 +9,6 @@ pkgbase = teensyduino
license = GPL
license = LGPL
license = custom
- makedepends = xorg-server-xvfb
- makedepends = libxft
- makedepends = xdotool
makedepends = git
depends = gtk2
depends = libusb-compat
@@ -28,25 +25,23 @@ pkgbase = teensyduino
options = !strip
options = staticlibs
source = arduino.xml
- source = teensyduino.sh
source = teensy-loader.desktop
source = git+https://github.com/PaulStoffregen/teensy_loader_cli.git#commit=d239f76f01f922e115c2661a6a3855dfc660a69c
source = http://www.pjrc.com/teensy/49-teensy.rules
source = LICENSE
sha256sums = 473b82156505e9bd903e4d8484e8d183f2e3bf3c1f7e29940b815929ae597b68
- sha256sums = 0ad3b85a1b5a9a0dc0cd64685742b66368a338777a80a0bff29d01ac26816173
sha256sums = 270b55353eb438d3790c7245e5ae16ff8bac9f98cfe927d6c9f2146a34499323
sha256sums = SKIP
sha256sums = 031de0b26991b5a3b19c497d9c0a17f86c40c55d925b9d07d19ab89f2286469d
sha256sums = 25980feb5927b8bea8b8e999f5002e110825b1bc3d546fa902c2db5c824d33f3
- source_i686 = http://downloads.arduino.cc/arduino-1.8.7-linux32.tar.xz
- source_i686 = http://www.pjrc.com/teensy/td_144/TeensyduinoInstall.linux32
- sha256sums_i686 = 8ef115816f912d7ce049a48d24987db03c9c86a2ef59d3edb5f840b10c813f74
- sha256sums_i686 = de7e38510be9e274861e25d63d4ec1ddde1797234a1d986c9a9905f5a2e86aee
- source_x86_64 = http://downloads.arduino.cc/arduino-1.8.7-linux64.tar.xz
- source_x86_64 = http://www.pjrc.com/teensy/td_144/TeensyduinoInstall.linux64
- sha256sums_x86_64 = eda4a5b989a317ab56b3700b1c5751308e62bfb8a29bf6829e4cdaaf15b62115
- sha256sums_x86_64 = e78440fb4091b62a9a244ab4cdee3b51741ffd45483d28d8fe839ed122db0e5c
+ source_i686 = http://downloads.arduino.cc/arduino-1.8.8-linux32.tar.xz
+ source_i686 = http://www.pjrc.com/teensy/td_145/TeensyduinoInstall.linux32
+ sha256sums_i686 = 84a0d2bbb1e60e1fc7566b87b016614f981fee90b5cbeaa92d9a4b2f731f1496
+ sha256sums_i686 = a7d0b185000b3a490d34abf0b27d1cfecb8e54f6c129a01268d36cf2d0cae4dc
+ source_x86_64 = http://downloads.arduino.cc/arduino-1.8.8-linux64.tar.xz
+ source_x86_64 = http://www.pjrc.com/teensy/td_145/TeensyduinoInstall.linux64
+ sha256sums_x86_64 = 7b261ffe4dea65a82a670afdd37c0e18a9e474154f17fbd480e90ddfd77ba3ea
+ sha256sums_x86_64 = ab67d725e0338278b2bbe5879175783dde224d26378811daf1db376ebf080859
pkgname = teensyduino
diff --git a/PKGBUILD b/PKGBUILD
index d2ea0056dd8d..6db5df371ab1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,9 @@
# Contributor: tty0 <vt.tty0[d0t]gmail.com>
pkgname=teensyduino
-pkgver=1.44
-_pkgver=1.44
-_arduino=1.8.7
+pkgver=1.45
+_pkgver=1.45
+_arduino=1.8.8
pkgrel=1
pkgdesc="Arduino SDK with Teensyduino"
arch=('i686' 'x86_64')
@@ -15,12 +15,11 @@ options=(!strip staticlibs)
license=('GPL' 'LGPL' 'custom')
depends=('gtk2' 'libusb-compat' 'libusb' 'java-runtime' 'libpng12' 'libsm'
'desktop-file-utils' 'giflib' 'avrdude')
-makedepends=('xorg-server-xvfb' 'libxft' 'xdotool' 'git')
+makedepends=('git')
provides=('arduino')
conflicts=('arduino' 'teensy-loader-cli')
install="teensyduino.install"
source=('arduino.xml'
- 'teensyduino.sh'
'teensy-loader.desktop'
"git+https://github.com/PaulStoffregen/teensy_loader_cli.git#commit=d239f76f01f922e115c2661a6a3855dfc660a69c"
"http://www.pjrc.com/teensy/49-teensy.rules"
@@ -30,15 +29,14 @@ source_i686+=("http://downloads.arduino.cc/arduino-${_arduino}-linux32.tar.xz"
source_x86_64+=("http://downloads.arduino.cc/arduino-${_arduino}-linux64.tar.xz"
"http://www.pjrc.com/teensy/td_${_pkgver//./}/TeensyduinoInstall.linux64")
sha256sums=('473b82156505e9bd903e4d8484e8d183f2e3bf3c1f7e29940b815929ae597b68'
- '0ad3b85a1b5a9a0dc0cd64685742b66368a338777a80a0bff29d01ac26816173'
'270b55353eb438d3790c7245e5ae16ff8bac9f98cfe927d6c9f2146a34499323'
'SKIP'
'031de0b26991b5a3b19c497d9c0a17f86c40c55d925b9d07d19ab89f2286469d'
'25980feb5927b8bea8b8e999f5002e110825b1bc3d546fa902c2db5c824d33f3')
-sha256sums_i686=('8ef115816f912d7ce049a48d24987db03c9c86a2ef59d3edb5f840b10c813f74'
- 'de7e38510be9e274861e25d63d4ec1ddde1797234a1d986c9a9905f5a2e86aee')
-sha256sums_x86_64=('eda4a5b989a317ab56b3700b1c5751308e62bfb8a29bf6829e4cdaaf15b62115'
- 'e78440fb4091b62a9a244ab4cdee3b51741ffd45483d28d8fe839ed122db0e5c')
+sha256sums_i686=('84a0d2bbb1e60e1fc7566b87b016614f981fee90b5cbeaa92d9a4b2f731f1496'
+ 'a7d0b185000b3a490d34abf0b27d1cfecb8e54f6c129a01268d36cf2d0cae4dc')
+sha256sums_x86_64=('7b261ffe4dea65a82a670afdd37c0e18a9e474154f17fbd480e90ddfd77ba3ea'
+ 'ab67d725e0338278b2bbe5879175783dde224d26378811daf1db376ebf080859')
if [ "$CARCH" == 'x86_64' ]; then
_bits=64
@@ -47,10 +45,10 @@ elif [ "$CARCH" == 'i686' ]; then
fi
build() {
- msg2 "Running Teensyduino installer (takes around 50 seconds)"
+ msg2 "Installing Teensyduino"
chmod +x "TeensyduinoInstall.linux${_bits}"
- xvfb-run ./teensyduino.sh "./TeensyduinoInstall.linux${_bits}" "${srcdir}/arduino-${_arduino}"
+ ./TeensyduinoInstall.linux${_bits} --dir="${srcdir}/arduino-${_arduino}"
msg2 "Building Teensy Loader command line"
diff --git a/teensyduino.sh b/teensyduino.sh
deleted file mode 100755
index b53d362911c9..000000000000
--- a/teensyduino.sh
+++ /dev/null
@@ -1,26 +0,0 @@
-#!/bin/bash
-
-sleep 2
-
-export HOME=$2
-$1 &
-
-sleep 5
-xdotool search --class "teensyduino" \
- windowfocus \
- key space sleep 1 \
- key Tab sleep 0.4 \
- key Tab sleep 0.4 \
- key Tab sleep 0.4 \
- key Tab sleep 0.4 \
- key space sleep 1 \
- key Tab sleep 0.4 \
- key Tab sleep 0.4 \
- key Tab sleep 0.4 \
- key Tab sleep 0.4 \
- key space sleep 1 \
- key Tab sleep 0.4 \
- key space sleep 35
-
-killall $(basename $1) >/dev/null || exit 1
-[ -d $2/hardware/teensy ] || exit 1