summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Ferreira2015-06-20 13:50:35 -0300
committerRafael Ferreira2015-06-20 13:50:35 -0300
commit2d3140e0484c880819dfcd0891146ccfc7bf4531 (patch)
tree9ff72d39b457af9d45de9b42652b13e24fd9fb85
downloadaur-2d3140e0484c880819dfcd0891146ccfc7bf4531.tar.gz
Initial import
-rw-r--r--.SRCINFO25
-rwxr-xr-xPKGBUILD64
-rw-r--r--license10
-rwxr-xr-xteighaviewer-qt5.install16
4 files changed, 115 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a2376eef6c66
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = teighaviewer-qt5
+ pkgdesc = Application for the visualization of CAD drawing files, QT5 version
+ pkgver = 4.00.1.0
+ pkgrel = 3
+ url = http://www.opendesign.com/guestfiles
+ install = teighaviewer-qt5.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = qt5-base
+ depends = libxfixes
+ depends = libgl
+ depends = libxkbcommon-x11
+ depends = bash
+ depends = hicolor-icon-theme
+ conflicts = teighaviewer-qt4
+ source = license
+ md5sums = 62b5539acd57c50855e29d1157c10697
+ source_i686 = http://www.opendesign.com/files/guestdownloads/TeighaViewer/TeighaViewer_QT5_lnxX86_4.7dll.deb
+ md5sums_i686 = dc13e90b7e43c0fa09b2a4bda70d29a2
+ source_x86_64 = http://www.opendesign.com/files/guestdownloads/TeighaViewer/TeighaViewer_QT5_lnxX64_4.7dll.deb
+ md5sums_x86_64 = ece1f92f224ad4e9b62adad16db9d263
+
+pkgname = teighaviewer-qt5
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..295429d5414a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Maintainer: josephgbr <rafael.f.f1@gmail.com>
+
+# NOTE about libgl dependency (same note applies to its 'lib32-' version)
+# if you have and use 'mesa', install 'mesa-libgl'
+# if you have and use 'nvidia', install 'nvidia-libgl'
+# if you have and use 'catalyst', install 'catalyst-libgl' (or catalyst-total)
+# p.s.: there is no 'libgl' pkg, instead it is provided by the above pkgs
+
+pkgname=teighaviewer-qt5
+_altname=teighaviewer
+pkgver=4.00.1.0
+pkgrel=3
+pkgdesc="Application for the visualization of CAD drawing files, QT5 version"
+arch=('i686' 'x86_64')
+url="http://www.opendesign.com/guestfiles"
+license=('custom')
+conflicts=('teighaviewer-qt4')
+depends=('qt5-base' 'libxfixes' 'libgl' 'libxkbcommon-x11' 'bash' 'hicolor-icon-theme')
+install=${pkgname}.install
+source=('license')
+source_i686=http://www.opendesign.com/files/guestdownloads/TeighaViewer/TeighaViewer_QT5_lnxX86_4.7dll.deb
+source_x86_64=(http://www.opendesign.com/files/guestdownloads/TeighaViewer/TeighaViewer_QT5_lnxX64_4.7dll.deb)
+md5sums=('62b5539acd57c50855e29d1157c10697')
+md5sums_i686=('dc13e90b7e43c0fa09b2a4bda70d29a2')
+md5sums_x86_64=('ece1f92f224ad4e9b62adad16db9d263')
+
+build() {
+ [ ! -d ${_altname}-${pkgver} ] && mkdir ${_altname}-${pkgver}
+ tar xf data.tar.gz -C ${_altname}-${pkgver}
+}
+
+package() {
+ cd ${_altname}-${pkgver}
+
+ for file in $(ls usr/bin/TeighaViewer_${pkgver}/); do
+ install -Dm755 usr/bin/TeighaViewer_${pkgver}/${file} \
+ "${pkgdir}/usr/lib/teighaviewer/${file}"
+ done
+
+ # binary
+ install -Dm755 usr/bin/TeighaViewer \
+ "${pkgdir}/usr/bin/teighaviewer"
+ sed -e "s#usr/bin/TeighaViewer_${pkgver}#usr/lib/teighaviewer#" \
+ -i "${pkgdir}/usr/bin/${_altname}"
+
+ # desktop item
+ install -Dm644 usr/share/applications/TeighaViewer_${pkgver}.desktop \
+ "${pkgdir}/usr/share/applications/teighaviewer.desktop"
+ sed -e "s#/TeighaViewer#/teighaviewer#" \
+ -i "${pkgdir}/usr/share/applications/teighaviewer.desktop"
+
+ # hicolor icons
+ for icon in $(find usr/share/icons -type f); do
+ install -Dm644 ${icon} \
+ "${pkgdir}/${icon}"
+ done
+
+ # copyright
+ install -Dm644 usr/share/doc/TeighaViewer/copyright \
+ "${pkgdir}/usr/share/licenses/${_altname}/COPYRIGHT"
+ install -Dm644 "$srcdir"/license \
+ "${pkgdir}/usr/share/licenses/${_altname}/license"
+
+}
diff --git a/license b/license
new file mode 100644
index 000000000000..b61a0c618ff5
--- /dev/null
+++ b/license
@@ -0,0 +1,10 @@
+COPYRIGHT AND TRADEMARK DISCLOSURE
+
+© 2011 Open Design Alliance. All rights reserved.
+
+"TEIGHA", the TEIGHA logo, "Open Design Alliance", and the Open Design Alliance logo are trademarks of the Open Design Alliance in the United States and/or other countries.
+All other trademarks, trade names or company names referenced herein are used for identification purposes only and are the property of their respective owners.
+
+DWG is the native and proprietary file format for AutoCAD® and a trademark of Autodesk, Inc. The Open Design Alliance is not associated with Autodesk.
+
+
diff --git a/teighaviewer-qt5.install b/teighaviewer-qt5.install
new file mode 100755
index 000000000000..1c505c876837
--- /dev/null
+++ b/teighaviewer-qt5.install
@@ -0,0 +1,16 @@
+## arg 1: the new package version
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ post_install
+}
+
+## arg 1: the old package version
+post_remove() {
+ post_install
+}
+