summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTamCore2015-07-10 17:05:43 +0200
committerTamCore2015-07-10 17:05:43 +0200
commit6470eb30a422e2f7085f83be2e5cd43fa8db28bf (patch)
tree85269874f84e7e245d55320690be564dc44549d2
downloadaur-tempsense-git.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b79616d174c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = tempsense-git
+ pkgdesc = command line client for the Diamex AVR Temp Sensor (DS18B20)
+ pkgver = LATEST
+ pkgrel = 1
+ url = https://git.tamcore.eu/philipp/tempsense
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ license = custom
+ makedepends = git
+ depends = hidapi
+ depends = libusb-compat
+ provides = tempsense
+ source = git+https://git.tamcore.eu/philipp/tempsense.git
+ sha256sums = SKIP
+
+pkgname = tempsense-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2141cffea907
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Philipp 'TamCore' B. <philipp [at] tamcore [dot] eu>
+
+pkgname=tempsense-git
+pkgver=LATEST
+pkgrel=1
+pkgdesc="command line client for the Diamex AVR Temp Sensor (DS18B20)"
+arch=(i686 x86_64 armv6h)
+url="https://git.tamcore.eu/philipp/tempsense"
+depends=('hidapi' 'libusb-compat')
+makedepends=('git')
+provides=('tempsense')
+license=('custom')
+source=(git+https://git.tamcore.eu/philipp/tempsense.git)
+sha256sums=('SKIP')
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ git submodule init
+ git submodule update
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -d -m0755 $pkgdir/usr/bin/
+ install -D -m4755 tempsense $pkgdir/usr/bin/tempsense
+ install -d -m0755 "${pkgdir}"/usr/share/licenses/${pkgname}/
+ install -D -m0644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}