summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornoprobelm2024-03-11 12:02:56 -0400
committernoprobelm2024-03-11 12:02:56 -0400
commit192c836d86e8a029da9503704d2a894e24f3086d (patch)
treeae65fea2050d02f0e72578e2dbc058c510398383
parent24bb787516cfe07d75ae7b0bd8858ab97ba575bc (diff)
downloadaur-tempy.tar.gz
Bumped version and improved some PKGBUILD functions
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f56d9a865dc2..fe493deffe07 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tempy
pkgdesc = Render visually pleasing weather reports as rich text to your terminal
- pkgver = 1.2.1.r69.03ae0fa
+ pkgver = 1.4.0.r192.22db47e
pkgrel = 1
url = https://github.com/noprobelm/tempy.git
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index bf847aa1b399..8f7fb6cb8228 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: noprobelm@protonmail.com
pkgname=tempy
-pkgver=1.2.1.r75.1a8d27f
+pkgver=1.4.0.r192.22db47e
pkgrel=1
pkgdesc="Render visually pleasing weather reports as rich text to your terminal"
arch=(any)
@@ -23,17 +23,17 @@ md5sums=('SKIP') #autofill using updpkgsums
pkgver() {
cd "$pkgname"
- printf "1.2.1.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "1.4.0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd tempy
- /usr/bin/python3 -m build --wheel --no-isolation
+ cd "$pkgname"
+ python -m build --wheel --no-isolation
}
package() {
- cd tempy
- python -m installer --destdir="$pkgdir" dist/*.whl
+ cd "$pkgname"
+ python -m installer --destdir="$pkgdir" --compile-bytecode=2 dist/*.whl
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
}