summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2021-08-18 17:29:17 +0200
committerFabioLolix2021-08-18 17:29:17 +0200
commit50f7ccacb009c9fb748ff80701be26c286efcfa4 (patch)
tree76b7b73bd94ec304515ea9864b20a84e957475b0
parent4e4a18033eb38d46611231e286ef78974e262c34 (diff)
downloadaur-50f7ccacb009c9fb748ff80701be26c286efcfa4.tar.gz
Fix build
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
-rw-r--r--tenacity.patch17
3 files changed, 24 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f2dcdf71f7a..5fd9955af702 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tenacity-git
pkgdesc = An easy-to-use multi-track audio editor and recorder, forked from Audacity
- pkgver = r13667.g4e877b8ae
- pkgrel = 1
+ pkgver = r13686.gdb0954787
+ pkgrel = 2
epoch = 1
url = https://tenacityaudio.org
arch = i686
@@ -18,13 +18,10 @@ pkgbase = tenacity-git
makedepends = gstreamer
makedepends = gst-plugins-bad-libs
makedepends = ffmpeg
- makedepends = jack
makedepends = nasm
- makedepends = conan
- makedepends = scdoc
- depends = gtk2
+ makedepends = chrpath
depends = gtk3
- depends = qt5-base
+ depends = wxgtk3-dev-opt
depends = libid3tag
depends = lilv
depends = lv2
@@ -35,12 +32,14 @@ pkgbase = tenacity-git
depends = vamp-plugin-sdk
depends = libsoxr
depends = soundtouch
+ depends = portaudio
+ depends = portmidi
+ depends = lame
+ depends = jack2
optdepends = ffmpeg: additional import/export capabilities
provides = tenacity
conflicts = tenacity
source = git+https://git.sr.ht/~tenacity/tenacity
- source = tenacity.patch
sha256sums = SKIP
- sha256sums = c06c60a9ae17b9265840fcd619d2c7a5668f26a94cec80c8785c7997afd4bc96
pkgname = tenacity-git
diff --git a/PKGBUILD b/PKGBUILD
index 8d44c3f3b9b1..6020927e7597 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,24 +6,23 @@
# Contributor: Eric BĂ©langer <eric@archlinux.org>
pkgname=tenacity-git
-pkgver=r13667.g4e877b8ae
-pkgrel=1
+pkgver=r13686.gdb0954787
+pkgrel=2
epoch=1
pkgdesc="An easy-to-use multi-track audio editor and recorder, forked from Audacity"
arch=(i686 x86_64)
url="https://tenacityaudio.org"
license=(GPL2 CCPL)
groups=(pro-audio)
-depends=(gtk2 gtk3 qt5-base libid3tag lilv lv2 portsmf suil libmad twolame vamp-plugin-sdk libsoxr soundtouch)
+depends=(gtk3 wxgtk3-dev-opt libid3tag lilv lv2 portsmf suil libmad twolame vamp-plugin-sdk libsoxr
+ soundtouch portaudio portmidi lame jack2)
makedepends=(git cmake clang sdl2 libsoup libnotify gstreamer gst-plugins-bad-libs
- ffmpeg jack nasm conan scdoc)
-# can't find system lame portmidi
+ ffmpeg nasm chrpath)
optdepends=('ffmpeg: additional import/export capabilities')
provides=(tenacity)
conflicts=(tenacity)
-source=("git+https://git.sr.ht/~tenacity/tenacity"
- "tenacity.patch")
-sha256sums=('SKIP' 'c06c60a9ae17b9265840fcd619d2c7a5668f26a94cec80c8785c7997afd4bc96')
+source=("git+https://git.sr.ht/~tenacity/tenacity")
+sha256sums=('SKIP')
pkgver() {
cd tenacity
@@ -39,17 +38,17 @@ prepare() {
cd ..
done
cd ../..
- patch --forward --strip=1 --input="${srcdir}/tenacity.patch"
mkdir -p build
}
build() {
cd tenacity/build
CC=clang CXX=clang++ cmake \
- -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DwxBUILD_TOOLKIT:STRING=gtk3 \
- -Daudacity_use_wxwidgets=local \
+ -DwxWidgets_CONFIG_EXECUTABLE=/opt/wxgtk-dev/bin/wx-config-gtk3 \
+ -DwxWidgets_INCLUDE_DIRS=/opt/wxgtk-dev/include/wx-3.1 \
+ -DwxWidgets_LIBRARIES=/opt/wxgtk-dev/lib \
audacity_use_ffmpeg:STRING=loaded \
..
cmake --build .
@@ -59,4 +58,9 @@ build() {
package() {
cd tenacity/build
make DESTDIR="${pkgdir}" install
+
+ chrpath --delete "${pkgdir}/usr/lib/tenacity/lib-strings.so"
+ chrpath --delete "${pkgdir}/usr/lib/tenacity/lib-string-utils.so"
+ chrpath --delete "${pkgdir}/usr/lib/tenacity/lib-utility.so"
+ chrpath --delete "${pkgdir}/usr/lib/tenacity/modules/mod-script-pipe.so"
}
diff --git a/tenacity.patch b/tenacity.patch
deleted file mode 100644
index 643a13bf61ee..000000000000
--- a/tenacity.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --unified --recursive --text audacity/lib-src/portaudio-v19/src/hostapi/alsa/pa_linux_alsa.c audacity.new/lib-src/portaudio-v19/src/hostapi/alsa/pa_linux_alsa.c
---- audacity/lib-src/portaudio-v19/src/hostapi/alsa/pa_linux_alsa.c 2021-07-02 00:17:06.606660728 +0800
-+++ audacity.new/lib-src/portaudio-v19/src/hostapi/alsa/pa_linux_alsa.c 2021-07-02 00:18:22.376662323 +0800
-@@ -4363,11 +4363,12 @@
- break;
- }
- }
-+
-+ pthread_cleanup_pop( 1 );
-
- end:
- ; /* Hack to fix "label at end of compound statement" error caused by pthread_cleanup_pop(1) macro. */
- /* Match pthread_cleanup_push */
-- pthread_cleanup_pop( 1 );
-
- PA_DEBUG(( "%s: Thread %d exiting\n ", __FUNCTION__, pthread_self() ));
- PaUnixThreading_EXIT( result );