summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2024-04-04 15:40:28 -0300
committerDaniel Bermond2024-04-04 15:40:28 -0300
commit1757541f2f0059a753f614652049dc48b7a8b70c (patch)
tree731da9c5afd36f17f493d703d8d9049752e908c8
parent0ae940cd4ad1cf31080436251e424dd6fbb65139 (diff)
downloadaur-tensorrt.tar.gz
Update to version 10.0.0.6
-rw-r--r--.SRCINFO22
-rw-r--r--020-tensorrt-fix-python.patch4
-rw-r--r--PKGBUILD26
3 files changed, 26 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 612955bc3dde..17f49cd35558 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = tensorrt
pkgdesc = A platform for high-performance deep learning inference on NVIDIA hardware
- pkgver = 9.3.0.1
+ pkgver = 10.0.0.6
pkgrel = 1
url = https://developer.nvidia.com/tensorrt/
arch = x86_64
- license = custom: NVIDIA TensorRT SLA
- license = Apache
+ license = LicenseRef-NVIDIA-TensorRT-SLA
+ license = Apache-2.0
makedepends = git
makedepends = cmake
makedepends = cuda
@@ -17,8 +17,8 @@ pkgbase = tensorrt
makedepends = python-setuptools
makedepends = python-wheel
noextract = protobuf-cpp-3.20.1.tar.gz
- source = https://developer.nvidia.com/downloads/compute/machine-learning/tensorrt/9.3.0/tensorrt-9.3.0.1.linux.x86_64-gnu.cuda-12.2.tar.gz
- source = git+https://github.com/NVIDIA/TensorRT.git#commit=6d1397ed4bb65933d02725623c122a157544a729
+ source = https://developer.nvidia.com/downloads/compute/machine-learning/tensorrt/10.0.0/tensorrt-10.0.0.6.linux.x86_64-gnu.cuda-12.4.tar.gz
+ source = git+https://github.com/NVIDIA/TensorRT.git#commit=28733f0fdccde2967fed395b06ca491af3a561a9
source = protobuf-protocolbuffers::git+https://github.com/protocolbuffers/protobuf.git
source = cub-nvlabs::git+https://github.com/NVlabs/cub.git
source = git+https://github.com/onnx/onnx-tensorrt.git
@@ -29,8 +29,8 @@ pkgbase = tensorrt
source = 010-tensorrt-use-local-protobuf-sources.patch
source = 020-tensorrt-fix-python.patch
source = TensorRT-SLA.txt
- sha256sums = 66e493e59c5d3ca1e21f090def7da09b8975866a933730657c9f094763694680
- sha256sums = SKIP
+ sha256sums = 0e35729954681411a79ccf31df089523caa11838095fbd025ddc7cd6f73f02de
+ sha256sums = f04165db2cb23084fe39a0f520da58c651098330bf62688df9a27b5c1ae77134
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
@@ -39,7 +39,7 @@ pkgbase = tensorrt
sha256sums = SKIP
sha256sums = dddd73664306d7d895a95e1cf18925b31b52785e468727e4635b45edae5166f9
sha256sums = ba94c0685216fe9566f7989df98b372e72a8da04b66d64380024107f2f7f4a8f
- sha256sums = bb17f9b11fe3d95fe0dfcf0ca2f5bd9fdb80e31e0ae1153c88162f2c54830f2b
+ sha256sums = 4ef20e02ad3093f214838ce2bcc5d032541fb3829e6ad764fd72c4129d86fdd2
sha256sums = 5f68360b4ac4758d207e30fec89c5e829d45bb4c27cae99e3fa6d2b170789370
pkgname = tensorrt
@@ -48,7 +48,7 @@ pkgname = tensorrt
pkgname = python-tensorrt
pkgdesc = A platform for high-performance deep learning inference on NVIDIA hardware (python bindings and tools)
- license = custom
+ license = LicenseRef-Custom
license = Apache
depends = python
depends = python-numpy
@@ -58,6 +58,6 @@ pkgname = python-tensorrt
optdepends = python-protobuf: for polygraphy and tensorflow-quantization python modules
optdepends = python-tensorflow-cuda: for polygraphy python module
optdepends = python-tf2onnx: for tensorflow-quantization python module
- provides = python-onnx-graphsurgeon=0.4.0
- provides = python-polygraphy=0.49.7
+ provides = python-onnx-graphsurgeon=0.5.1
+ provides = python-polygraphy=0.49.9
provides = python-tensorflow-quantization=0.2.0
diff --git a/020-tensorrt-fix-python.patch b/020-tensorrt-fix-python.patch
index 7a78fc909791..3bc97eb92acb 100644
--- a/020-tensorrt-fix-python.patch
+++ b/020-tensorrt-fix-python.patch
@@ -22,8 +22,8 @@
# -------- GLOBAL COMPILE OPTIONS --------
include_directories(${TENSORRT_ROOT}/include ${PROJECT_SOURCE_DIR}/include ${CUDA_INCLUDE_DIRS} ${PROJECT_SOURCE_DIR}/docstrings ${ONNX_INC_DIR} ${PYBIND11_DIR})
--link_directories(${TENSORRT_LIBPATH})
-+link_directories(${TENSORRT_LIBPATH} $ENV{TRT_NONOSS_ROOT}/lib)
+-link_directories(${TENSORRT_BUILD})
++link_directories(${TENSORRT_BUILD} $ENV{TRT_NONOSS_ROOT}/lib)
if (MSVC)
message(STATUS "include_dirs: ${MSVC_COMPILER_DIR}/include ${MSVC_COMPILER_DIR}/../ucrt/include ${NV_WDKSDK_INC}/um ${NV_WDKSDK_INC}/shared")
diff --git a/PKGBUILD b/PKGBUILD
index 84208afe863a..a10f5bcb66c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,20 @@
pkgbase=tensorrt
pkgname=('tensorrt' 'python-tensorrt')
-pkgver=9.3.0.1
-_commit=6d1397ed4bb65933d02725623c122a157544a729
-_cudaver=12.2
+pkgver=10.0.0.6
+_commit=28733f0fdccde2967fed395b06ca491af3a561a9
+_cudaver=12.4
_protobuf_ver=3.20.1
_pybind11_ver=2.9.2
-_python_build=post12.dev1
-_onnx_graphsurgeon_ver=0.4.0
-_polygraphy_ver=0.49.7
+_python_build=b6
+_onnx_graphsurgeon_ver=0.5.1
+_polygraphy_ver=0.49.9
_tensorflow_quantization_ver=0.2.0
pkgrel=1
pkgdesc='A platform for high-performance deep learning inference on NVIDIA hardware'
arch=('x86_64')
url='https://developer.nvidia.com/tensorrt/'
-license=('custom: NVIDIA TensorRT SLA' 'Apache')
+license=('LicenseRef-NVIDIA-TensorRT-SLA' 'Apache-2.0')
makedepends=('git' 'cmake' 'cuda' 'cudnn' 'python' 'python-build' 'python-installer' 'python-onnx'
'python-setuptools' 'python-wheel')
source=("https://developer.nvidia.com/downloads/compute/machine-learning/tensorrt/${pkgver%.*}/tensorrt-${pkgver}.linux.${CARCH}-gnu.cuda-${_cudaver}.tar.gz"
@@ -31,8 +31,8 @@ source=("https://developer.nvidia.com/downloads/compute/machine-learning/tensorr
'020-tensorrt-fix-python.patch'
'TensorRT-SLA.txt')
noextract=("protobuf-cpp-${_protobuf_ver}.tar.gz")
-sha256sums=('66e493e59c5d3ca1e21f090def7da09b8975866a933730657c9f094763694680'
- 'SKIP'
+sha256sums=('0e35729954681411a79ccf31df089523caa11838095fbd025ddc7cd6f73f02de'
+ 'f04165db2cb23084fe39a0f520da58c651098330bf62688df9a27b5c1ae77134'
'SKIP'
'SKIP'
'SKIP'
@@ -41,7 +41,7 @@ sha256sums=('66e493e59c5d3ca1e21f090def7da09b8975866a933730657c9f094763694680'
'SKIP'
'dddd73664306d7d895a95e1cf18925b31b52785e468727e4635b45edae5166f9'
'ba94c0685216fe9566f7989df98b372e72a8da04b66d64380024107f2f7f4a8f'
- 'bb17f9b11fe3d95fe0dfcf0ca2f5bd9fdb80e31e0ae1153c88162f2c54830f2b'
+ '4ef20e02ad3093f214838ce2bcc5d032541fb3829e6ad764fd72c4129d86fdd2'
'5f68360b4ac4758d207e30fec89c5e829d45bb4c27cae99e3fa6d2b170789370')
prepare() {
@@ -131,7 +131,7 @@ package_tensorrt() {
package_python-tensorrt() {
pkgdesc+=' (python bindings and tools)'
- license=('custom' 'Apache')
+ license=('LicenseRef-Custom' 'Apache')
depends=('python' 'python-numpy' 'tensorrt')
optdepends=('python-onnx: for onnx_graphsurgeon python module'
'python-onnxruntime: for onnx_graphsurgeon and polygraphy python modules'
@@ -144,7 +144,7 @@ package_python-tensorrt() {
local _pyver
_pyver="$(python -c 'import sys; print("%s.%s" %sys.version_info[0:2])')"
- python -m installer --destdir="$pkgdir" "TensorRT-${pkgver}/python/tensorrt-${pkgver%.*}.${_python_build}-cp${_pyver/./}-none-linux_${CARCH}.whl"
+ python -m installer --destdir="$pkgdir" "TensorRT-${pkgver}/python/tensorrt-${pkgver%.*}${_python_build}-cp${_pyver/./}-none-linux_${CARCH}.whl"
local _dir
for _dir in TensorRT/tools/{onnx-graphsurgeon,Polygraphy,tensorflow-quantization}/dist
@@ -158,5 +158,5 @@ package_python-tensorrt() {
install -D -m644 "${srcdir}/TensorRT/NOTICE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
install -D -m644 "${srcdir}/TensorRT-SLA.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-NVIDIA-TENSORRT-SLA"
install -D -m644 "${srcdir}/TensorRT-${pkgver}/doc/Acknowledgements.txt" "${pkgdir}/usr/share/licenses/${pkgname}/ACKNOWLEDGEMENTS"
- ln -s "${_sitepkgs}/tensorrt-${pkgver%.*}.${_python_build}.dist-info/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-python-tensorrt"
+ ln -s "${_sitepkgs}/tensorrt-${pkgver%.*}${_python_build}.dist-info/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-python-tensorrt"
}