summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGötz Christ2018-05-16 21:13:38 -0500
committerGötz Christ2018-05-16 21:25:10 -0500
commitdd0f91761024453a176719985991f2b3fa8a4405 (patch)
tree2493a5b43975edb4f56fe3defa9f54250414d6c6
downloadaur-tepl3.tar.gz
First commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5366e4d4c1e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = tepl3
+ pkgdesc = Library that eases the development of GtkSourceView-based text editors and IDEs
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = https://wiki.gnome.org/Projects/Tepl
+ arch = x86_64
+ arch = i686
+ license = LGPL2.1
+ makedepends = gobject-introspection
+ makedepends = vala
+ depends = gtksourceview3
+ depends = uchardet
+ source = https://download.gnome.org/sources/tepl/3.0/tepl-3.0.0.tar.xz
+ sha256sums = 9eb6fceb0b521de7bf684508138a5b8428d9f575c395ba54f9e31597980fd0ef
+
+pkgname = tepl3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68e2082fa514
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# $Id$
+# Maintainer: goetzc
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
+# Contributor: Tobias Bohrmann (PlainTextField) <honeypot.carbage@aechelon.de>
+
+pkgname=tepl3
+_pkgname=tepl
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="Library that eases the development of GtkSourceView-based text editors and IDEs"
+arch=('x86_64' 'i686')
+url="https://wiki.gnome.org/Projects/Tepl"
+license=('LGPL2.1')
+depends=('gtksourceview3' 'uchardet')
+makedepends=('gobject-introspection' 'vala')
+source=("https://download.gnome.org/sources/$_pkgname/${pkgver%.*}/$_pkgname-$pkgver.tar.xz")
+sha256sums=('9eb6fceb0b521de7bf684508138a5b8428d9f575c395ba54f9e31597980fd0ef')
+
+build() {
+ cd $_pkgname-$pkgver
+ ./configure --prefix=/usr
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}