summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkleintux2022-08-25 22:42:47 +0200
committerkleintux2022-08-25 22:42:47 +0200
commita23d567e5a29378dea08d97f8ad84cd8464a9412 (patch)
treebe9bdc7e0a8b347fba7a96aa325cdb2a176d6ea8
parentc24197b36bc67cdcecfb8dc3ec8119d0f7c487ce (diff)
downloadaur-terrafire.tar.gz
adopted. updated to 2.0.5. workaround for source
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD42
2 files changed, 22 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02c36ff5e9ba..225b8244cabc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = terrafire
pkgdesc = Award-winning arcade game featuring rendered 3D graphics, realistic gravitational physics and 360 degree parallax scrolling from ORT Software.
- pkgver = 2.0
- pkgrel = 7
- url = http://www.ortsoftware.com/tf.html
+ pkgver = 2.0.5
+ pkgrel = 1
+ url = https://www.ortsoftware.com/tf.html
arch = i686
arch = x86_64
license = freeware
@@ -11,9 +11,6 @@ pkgbase = terrafire
depends = dosbox
provides = terrafire
source = terrafire.desktop
- source = http://www.ortsoftware.com/tf_full.exe
- md5sums = c144a31089faabfe183fff15a0c3b373
- md5sums = cf078359a989aca11f85ddd3aca9276b
+ sha256sums = f7489700fe3a3795a599b1bedeef3eb279b9949ae7725ec8d924312419113b71
pkgname = terrafire
-
diff --git a/PKGBUILD b/PKGBUILD
index fc15f429db4a..7dd909a6bceb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,40 @@
+# Maintainer: <reg-archlinux AT klein DOT tuxli DOT ch>
pkgname=terrafire
-pkgver=2.0
-pkgrel=7
+pkgver=2.0.5
+pkgrel=1
pkgdesc="Award-winning arcade game featuring rendered 3D graphics, realistic gravitational physics and 360 degree parallax scrolling from ORT Software."
arch=('i686' 'x86_64')
-url="http://www.ortsoftware.com/tf.html"
+url="https://www.ortsoftware.com/tf.html"
license=('freeware')
provides=('terrafire')
-source=('terrafire.desktop' 'http://www.ortsoftware.com/tf_full.exe')
+source=('terrafire.desktop')
depends=('dosbox')
makedepends=('innoextract' 'imagemagick')
-md5sums=('c144a31089faabfe183fff15a0c3b373' 'cf078359a989aca11f85ddd3aca9276b')
+sha256sums=('f7489700fe3a3795a599b1bedeef3eb279b9949ae7725ec8d924312419113b71')
+prepare() {
+ #workaround for curl http 406 error
+ cd "${srcdir}"
+ curl --user-agent "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/87.0.4280.88 Safari/537.36" 'https://www.ortsoftware.com/exe/tf_full.exe' -o tf_full.exe
+}
build() {
- cd "$srcdir"
- msg "Extracting installer contents..."
-
- # Extract all files from the setup program
+ cd "${srcdir}"
innoextract "tf_full.exe" || return 1
-
- # Create a png icon out of the .ico
convert "app/tf.ico" "terrafire.png" || return 1
-
}
package() {
- # Install the shortcut and icon into /usr/share
install -Dm644 ${srcdir}/terrafire.desktop ${pkgdir}/usr/share/applications/terrafire.desktop
install -Dm644 ${srcdir}/terrafire.png ${pkgdir}/usr/share/pixmaps/terrafire.png
- cd "$srcdir"
- cd "app"
- mkdir -p "$pkgdir/opt/terrafire"
- mkdir -p "$pkgdir/usr/bin/"
-
- # Copy all extracted files to the destination folder
- cp -ar * "$pkgdir/opt/terrafire"
+ cd "${srcdir}/app"
+ mkdir -p "${pkgdir}/opt/terrafire"
+ mkdir -p "${pkgdir}/usr/bin/"
+ cp -ar * "${pkgdir}/opt/terrafire"
- # Create a command-line script for launching the game
- cat << EOF > "$pkgdir/usr/bin/terrafire"
+ cat << EOF > "${pkgdir}/usr/bin/terrafire"
#!/bin/bash
# Let us create a hidden folder in the home
mkdir -p "\$HOME/.terrafire"
@@ -57,6 +52,5 @@ done
dosbox -exit "\$HOME/.terrafire/tf.exe"
EOF
- chmod +x "$pkgdir/usr/bin/terrafire"
-
+chmod +x "${pkgdir}/usr/bin/terrafire"
}