summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKatoga2018-03-18 19:00:15 +0100
committerKatoga2018-03-18 19:00:15 +0100
commit71576425b0d91ebde77d827c18248027d9d5c191 (patch)
tree1b14f090da5b566a80a36f7e81cd0b2093121f7f
downloadaur-terraform-index-bin.tar.gz
Initial commit (version 0.0.2-1)
-rw-r--r--.SRCINFO14
-rw-r--r--LICENSE29
-rw-r--r--PKGBUILD22
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..05c1e948e9eb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = terraform-index-bin
+ pkgdesc = A simple tool which prints the AST of a HCL file
+ pkgver = 0.0.2
+ pkgrel = 1
+ url = https://github.com/mauve/terraform-index
+ arch = x86_64
+ license = BSD
+ source = https://github.com/mauve/terraform-index/releases/download/0.0.2/terraform-index-0.0.2-linux-amd64.zip
+ source = LICENSE
+ sha256sums = b10de458b0414a76ea2e18d3ebe3df54e212e09a4b64f8fefecf9f08e906b2d1
+ sha256sums = 8d30e4d4e52fc07a98e90dcbbe71284520019b51b4beb95509b12a04e2cc5cf5
+
+pkgname = terraform-index-bin
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..18d6dd4bdb1e
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,29 @@
+BSD 3-Clause License
+
+Copyright (c) 2017, Mikael Olenfalk
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+
+* Redistributions of source code must retain the above copyright notice, this
+ list of conditions and the following disclaimer.
+
+* Redistributions in binary form must reproduce the above copyright notice,
+ this list of conditions and the following disclaimer in the documentation
+ and/or other materials provided with the distribution.
+
+* Neither the name of the copyright holder nor the names of its
+ contributors may be used to endorse or promote products derived from
+ this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE
+FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
+OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d81dcb0b9c05
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Katoga <katoga.cz@hotmail.com>
+pkgname=terraform-index-bin
+pkgver=0.0.2
+pkgrel=1
+pkgdesc='A simple tool which prints the AST of a HCL file'
+arch=('x86_64')
+url="https://github.com/mauve/terraform-index"
+license=('BSD')
+source=(
+ "https://github.com/mauve/terraform-index/releases/download/${pkgver}/terraform-index-${pkgver}-linux-amd64.zip"
+ 'LICENSE'
+)
+sha256sums=(
+ 'b10de458b0414a76ea2e18d3ebe3df54e212e09a4b64f8fefecf9f08e906b2d1'
+ '8d30e4d4e52fc07a98e90dcbbe71284520019b51b4beb95509b12a04e2cc5cf5'
+)
+
+package() {
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ install -Dm755 "${srcdir}/terraform-index" "${pkgdir}/usr/local/bin/terraform-index"
+}