summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorilmikko2016-10-17 20:30:00 +0100
committerilmikko2016-10-17 20:30:00 +0100
commitb4719fe52f3a5b93baefd0bf470a4979ec4bc1ac (patch)
tree118826b3a5c78046471bc475cc1538d2abedd0e4
parent632731edbb1b7f7c1fbebd107dff4a3772c88919 (diff)
downloadaur-b4719fe52f3a5b93baefd0bf470a4979ec4bc1ac.tar.gz
Changed the data directory to /etc/ instead of /opt/
Added config.txt (loaded by server, everything commented out by default) Unzip does not ask anymore if you want to overwrite Fixed typo in terraria-server.install
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
-rw-r--r--config.txt67
-rwxr-xr-xterraria-server4
-rw-r--r--terraria-server.install2
5 files changed, 79 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94caae179d6d..c2813131752b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = terraria-server
pkgdesc = Official dedicated server for Terraria
pkgver = 1.3.3.3
- pkgrel = 9
+ pkgrel = 10
url = https://terraria.org/
install = terraria-server.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index b2568740a307..304ddb2a0d9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=terraria-server
pkgver=1.3.3.3
-pkgrel=9
+pkgrel=10
pkgdesc="Official dedicated server for Terraria"
arch=('x86_64' 'x86')
license=('unknown')
@@ -15,16 +15,18 @@ _pkgver=$(echo $pkgver | sed 's/\.//g')
source=("http://terraria.org/server/${pkgname}-${_pkgver}.zip"
'terraria-server'
+ 'config.txt'
'terraria-server@.service')
sha256sums=('ecd6ec686d6f46defb3ae0e75d49ce50cd324a4d390fc067177668ea990ad8bc'
- '8a7e23efe3f72d8c88024cf32e53daa4b293bb2b17070dbf80e86876af1e22f9'
+ 'd70dce33d0c1a26211401fe169f643a6198c9292a4297557be154650ffe1c076'
+ '10cc09e9a49ec0d035f2237b610cca8dcc696d327c6943c575564b5ef83f6860'
'27dfa3e01b4da26bccace69bcf02fd91293cac701e48ab358d9495070365c2ac')
package() {
- unzip "${pkgname}-${_pkgver}.zip"
+ unzip -o "${pkgname}-${_pkgver}.zip"
cd 'Dedicated Server/Linux'
- dest="${pkgdir}/opt/terraria-server"
+ dest="${pkgdir}/etc/terraria-server"
install -o 697 -g 697 -d "${dest}"
install -m644 FNA.dll "${dest}/"
install -m644 FNA.dll.config "${dest}/"
@@ -38,8 +40,9 @@ package() {
install -m755 terraria-server "${pkgdir}/usr/bin/"
install -d "${pkgdir}/usr/lib/systemd/system/"
install -m644 terraria-server@.service "${pkgdir}/usr/lib/systemd/system/"
+ install -m755 config.txt "${dest}/"
- install -o 697 -g 697 -d "${pkgdir}/etc/terraria-server/"
+ install -o 697 -g 697 -d "${pkgdir}/srv/terraria"
install -o 697 -g 697 -d "${pkgdir}/var/lib/terraria-server/"
install -d "${pkgdir}/usr/lib/"
diff --git a/config.txt b/config.txt
new file mode 100644
index 000000000000..b9d2b8683ff5
--- /dev/null
+++ b/config.txt
@@ -0,0 +1,67 @@
+#this is an example config file for terraria-server
+
+#the following is a list of available command line parameters:
+
+#-config <config file> Specifies the configuration file to use.
+#-port <port number> Specifies the port to listen on.
+#-players <number> / -maxplayers <number> Sets the max number of players
+#-pass <password> / -password <password> Sets the server password
+#-world <world file> Load a world and automatically start the server.
+#-autocreate <#> Creates a world if none is found in the path specified by -world. World size is specified by: 1(small), 2(medium), and 3(large).
+#-banlist <path> Specifies the location of the banlist. Defaults to "banlist.txt" in the working directory.
+#-worldname <world name> Sets the name of the world when using -autocreate.
+#-secure Adds addition cheat protection to the server.
+#-noupnp Disables automatic port forwarding
+#-steam Enables Steam Support
+#-lobby <friends> or <private> Allows friends to join the server or sets it to private if Steam is enabled
+#-ip <ip address> Sets the IP address for the server to listen on
+#-forcepriority <priority> Sets the process priority for this task. If this is used the "priority" setting below will be ignored.
+#-disableannouncementbox Disables the text announcements Announcement Box makes when pulsed from wire.
+#-announcementboxrange <number> Sets the announcement box text messaging range in pixels, -1 for serverwide announcements.
+
+#remove the # in front of commands to enable them.
+
+#Load a world and automatically start the server.
+#world=/srv/terraria/world1.wld
+
+#Creates a new world if none is found. World size is specified by: 1(small), 2(medium), and 3(large).
+#autocreate=1
+
+#Sets the name of the world when using autocreate
+#worldname=Terraria
+
+#Sets the difficulty of the world when using autocreate 0(normal), 1(expert)
+#difficulty=1
+
+#Sets the max number of players allowed on a server. Value must be between 1 and 255
+#maxplayers=8
+
+#Set the port number
+#port=777
+
+#Set the server password
+#password=p@55w0rd
+
+#Set the message of the day
+#motd=Please don’t cut the purple trees!
+
+#Sets the folder where world files will be stored
+#worldpath=/srv/terraria/
+
+#The location of the banlist. Defaults to "banlist.txt" in the working directory.
+#banlist=banlist.txt
+
+#Adds addition cheat protection.
+#secure=1
+
+#Sets the server language 1:English, 2:German, 3:Italian, 4:French, 5:Spanish
+#lang=1
+
+#Automatically forward ports with uPNP
+#upnp=1
+
+#Reduces enemy skipping but increases bandwidth usage. The lower the number the less skipping will happen, but more data is sent. 0 is off.
+#npcstream=60
+
+#Default system priority 0:Realtime, 1:High, 2:AboveNormal, 3:Normal, 4:BelowNormal, 5:Idle
+#priority=1
diff --git a/terraria-server b/terraria-server
index 2697eee5af8a..1e3a11b09192 100755
--- a/terraria-server
+++ b/terraria-server
@@ -1,5 +1,5 @@
#!/bin/bash
-cd /opt/terraria-server
+cd /etc/terraria-server
export MONO_IOMAP=all
arch=$(uname -m)
-./TerrariaServer.bin.${arch} "$@"
+./TerrariaServer.bin.${arch} -config config.txt "$@"
diff --git a/terraria-server.install b/terraria-server.install
index b1960249209e..9972ba2c99d5 100644
--- a/terraria-server.install
+++ b/terraria-server.install
@@ -25,6 +25,6 @@ post_remove() {
fi
if getent group terraria &>/dev/null; then
- groupdel terrara >/dev/null
+ groupdel terraria >/dev/null
fi
}