summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladimir Tsanev2018-11-04 14:54:39 +0200
committerVladimir Tsanev2018-11-04 14:54:39 +0200
commitda8ba9a0c03a878a12edd72f7a624bf8ebb2c7a4 (patch)
tree1becebf8042184a30c0224b3d56ec4ba08540db4
downloadaur-teseq.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD27
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2a8d719ef680
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = teseq
+ pkgdesc = A tool for analyzing files that contain control characters and terminal control sequences
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = https://www.gnu.org/software/teseq/
+ arch = x86_64
+ license = GPL3
+ source = https://ftp.gnu.org/gnu/teseq/teseq-1.1.1.tar.xz
+ sha256sums = 230d2b4a587542284c415b33557a27774f5ad1580ed9db272bcd1e2034ea0589
+
+pkgname = teseq
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8669752104e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Vladimir Tsanev <tsachev@gmail.com>
+
+pkgname=teseq
+pkgver=1.1.1
+pkgrel=1
+pkgdesc='A tool for analyzing files that contain control characters and terminal control sequences'
+arch=('x86_64')
+url='https://www.gnu.org/software/teseq/'
+license=('GPL3')
+source=("https://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz")
+sha256sums=('230d2b4a587542284c415b33557a27774f5ad1580ed9db272bcd1e2034ea0589')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "${pkgname}-${pkgver}"
+ make -k check
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}/" install
+}